Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000271ScribusPrintingpublic2004-02-16 12:002004-03-26 17:27
Reportermhanski 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000271: Cups options missing
DescriptionI've noticed that there is only an empty window where the CUPS options
should be after choosing File -> Print... -> "Options...". Is it only me or
is there anybody else confronted with this problem?

BTW, CUPS works fine with other applications on my system, which is Mdk
9.1, Scribus Build-ID is 14. February 2004, C-C-T, and "./configure"
returned this messages at the end:


Configuration Summary:

FreeType2 installed: Yes
CUPS installed: Yes
LittleCMS installed: Yes
TiffLib installed: Yes
Using Python < 2.3
TagsNo tags attached.
Patch
Attached Filespng file icon kprinter_lj4.png [^] (36,864 bytes) 2004-03-01 22:36


png file icon scribus_lj5.png [^] (46,444 bytes) 2004-03-01 22:37

- Relationships

-  Notes
(0000588)
plinnell (administrator)
2004-02-26 07:04

I have observed this with a rawhide version of CUPS on RH, which I reverted to the shipped version of CUPS. This returned the options panel. The only CUPS issues I am aware of with Scribus is issues with duplexing on a Fiery RIP, which has a very complicated interface. Franz is aware of this and is working on a solution.

I would check for updated foomatic, CUPS or GS. Note, they are often built and packaged together and upgrading one without the other can cause issues in my experience.
(0000618)
plinnell (administrator)
2004-02-29 21:41

Reminder sent to maciej

Hi Maciej,

Any feedback on this ? Not sure its a Scribus bug, but did not want to close it unless you could confirm it more definitely.

Cheers,
Peter
(0000620)
mhanski (developer)
2004-03-01 08:01
edited on: 2004-03-01 12:54

Hi Peter,
I don't want to upgrade one of these packages without knowing more definitely which one's of them and which minimum versions are requiered for the CUPS options panel to work. The only thing I can confirm at this stage is that it was there in Scribus 1.0 and 1.0.1 and that I've actually never seen it in the newest Scribus 1.1.* versions on the same Mdk 9.1 system.

Here is a list of packages in question, which are installed on my system:

Name: foomatic-db
Version: 3.0-0.beta1.20030310.2mdk

Name: foomatic-db-engine
Version: 3.0-0.beta1.20030310.2mdk

Name: foomatic-filters
Version: 3.0-0.beta1.20030310.2mdk


Name: cups
Version: 1.1.19-0.5mdk

Name: cups-common
Version: 1.1.19-0.5mdk

Name: cups-drivers
Version: 1.1-102mdk

Name: libcups1
Version: 1.1.19-0.5mdk

Name: libcups1-devel
Version: 1.1.19-0.5mdk

Name: ghostscript
Version: 7.07-0.12mdk

edited on: 03-01-04 12:54
(0000623)
plinnell (administrator)
2004-03-01 20:50

Reminder sent to maciej

As a test, please try installing a new driver in CUPS:

1. Download this ppd : http://linuxprinting.org/download/PPD/HP/20031202/hp_laserjet_4.ppd [^]

Save a text file to your desktop.

2. Go into a console: $cupstestppd ~/Desktop/hp_laserjet_4.ppd
This is to ensure the ppd file did not get weird line endings on the download. You should get PASS

3. Open kprinter as root/admin and create a new > Other and point at the PPD. You should have a HP Laser Jet4 /4M show up. call it test or temp.

4. Save and close

5. Restart scribus with a doc open and try the drop down box for the printer and see if the options show up.

This eliminates foomatic and most of the CUPS interface as Scribus directly accesses CUPS.

Let me know the results. Thanks
(0000626)
mhanski (developer)
2004-03-01 22:35

Hi Peter,
here are the test results:

1 & 2:

[maciej@pingwin Desktop]$ cupstestppd ~/Desktop/hp_laserjet_4.ppd
/home/maciej/Desktop/hp_laserjet_4.ppd: PASS

 
 3 & 4:

I created a printer based on your driver and called it testhplj4 (see the 1st screen shot)

5. After restarting scribus the new printer was there, but there were no CUPS options either (see the 2nd screen shot)

Greetings
Maciej
(0000680)
plinnell (administrator)
2004-03-07 04:02

Can't replicate here with SuSE 9.0 or Fedora-1.

Minimum version of CUPS, should be no more than 1.14.

Note: I did find updated versions of CUPS, foomatic and gimp-print here : ftp://carroll.cac.psu.edu/pub/linux/distributions/mandrake/updates/9.1/RPMS/ [^]

Perhaps these might fix the issue.
(0000687)
mhanski (developer)
2004-03-07 12:03
edited on: 2004-03-07 13:16

> ftp://carroll.cac.psu.edu/pub/linux/distributions/mandrake/updates/9.1/RPMS/ [^]

530 User anonymous access denied.

Hi Peter,
since nobody else complains about it, although I posted it to the mailing list, and I'm going to move to Mdk 10 soon, I wouldn't mind, if you close this issue.
br
Maciej

edited on: 03-07-04 13:16
(0000688)
ufechner (reporter)
2004-03-07 13:09

Well, I have the same problem:

scribus 1.15
QT 3.3.0

an gentoo linux, using kde 3.2

I did not have it before upgrading QT and scribus.
(0000701)
cbradney (administrator)
2004-03-07 20:40

I get heaps of printer options here:
Gentoo
cups 1.1.20
CVS
foomatic is 20031018
(0000702)
plinnell (administrator)
2004-03-07 20:52

Reminder sent to ufechner

can you repeat the steps noted below in the comments with the LJ 4 PPD ?

MrB notes also there is a foomatic update in the queue for Gentoo
(0000707)
ufechner (reporter)
2004-03-08 07:49

I did try, but didn't pass step 2.
Will try again tonight.
Regards:

ufechner
(0000708)
cbradney (administrator)
2004-03-08 18:32

I just created a test hplj4000 printer and all the options come through fine into scribus.
(0000767)
plinnell (administrator)
2004-03-19 23:14

not able to duplicate
(0000770)
mhanski (developer)
2004-03-21 21:41

I'm sorry for reopening the bug, but I've just found the reason for this behaviour and this is certainly not a scribus bug, but the messed up default CUPS configuration in MDK9.1. I think this might be useful for some Mdk users.

Here it goes:
in my /etc/cups/cupsd.conf which was created by Mdk installation procedure, there was a buggy entry:

ServerName 169.254.244.0

I don't know where this IP comes from, it's got certainly nothing to do with networks I'm in. I checked it with a friend of mine who also uses Mdk9.1, and he had the same problem, a wrong IP as the ServerName, and he is certainly nobody who would edit it by hand.
I changed it to:

ServerName 127.0.0.1

and switched this option to Yes:

FileDevice Yes

and everything started to work fine, even with the PPD test file from Peter. I can see the Scribus Cups options!
(0000771)
plinnell (administrator)
2004-03-22 05:31

Reminder sent to maciej

Maciej,

As always - helpful.

Yes, it is valuable to know and will keep this in mind if others have CUPS issues.

You can still comment on a closed bug by the way..

Cheers,
Peter
(0000786)
plinnell (administrator)
2004-03-26 17:26

from ufechner via the mail list.. adding this for reference

Hello,

I want to add the following Bugnote to Bug 271, but I can't, because the
bug is closed.

--------------------------------------------------------------------------------------------------------------
I finally solved this problem our network.

It was a dns problem:

If you have the same problem, try on the command line:

lpoptions -l

I got the message:

"destination hpijs has no ppd file"

I looked in the control center of kde for the printer settings, and
found the following URI:

URI: ipp://myserver.olddomain:631/printers/hpijs [^]

I tried to ping myserver.olddomain and it was not resolved, because we
had switched the
local domain name recently.

The ppd file must be shown in the browser, if you enter the following URI:
http://myserver.domain:631/printers/hpijs.ppd [^]

After fixing that (adding the ip to the local hosts file) everythings
worked fine.

I think, in a way, it IS a bug of scribus, because it doesn't give any
debug information.

Regards:

ufechner

- Issue History
Date Modified Username Field Change
2004-02-16 12:00 mhanski New Issue
2004-02-26 07:04 plinnell Note Added: 0000588
2004-02-26 07:04 plinnell Status new => feedback
2004-02-29 21:41 plinnell Note Added: 0000618
2004-03-01 08:01 mhanski Note Added: 0000620
2004-03-01 12:54 mhanski Note Edited: 0000620
2004-03-01 20:50 plinnell Note Added: 0000623
2004-03-01 22:35 mhanski Note Added: 0000626
2004-03-01 22:36 mhanski File Added: kprinter_lj4.png
2004-03-01 22:37 mhanski File Added: scribus_lj5.png
2004-03-07 04:02 plinnell Note Added: 0000680
2004-03-07 04:02 plinnell Resolution open => unable to reproduce
2004-03-07 12:03 mhanski Note Added: 0000687
2004-03-07 13:09 ufechner Note Added: 0000688
2004-03-07 13:16 mhanski Note Edited: 0000687
2004-03-07 20:40 cbradney Note Added: 0000701
2004-03-07 20:52 plinnell Note Added: 0000702
2004-03-08 07:49 ufechner Note Added: 0000707
2004-03-08 18:32 cbradney Note Added: 0000708
2004-03-19 23:14 plinnell Note Added: 0000767
2004-03-19 23:14 plinnell Status feedback => closed
2004-03-21 21:41 mhanski Status closed => feedback
2004-03-21 21:41 mhanski Resolution unable to reproduce => reopened
2004-03-21 21:41 mhanski Note Added: 0000770
2004-03-22 05:31 plinnell Note Added: 0000771
2004-03-22 05:31 plinnell Status feedback => closed
2004-03-26 17:26 plinnell Status closed => feedback
2004-03-26 17:26 plinnell Note Added: 0000786
2004-03-26 17:27 plinnell Status feedback => closed
2004-03-26 17:27 plinnell Resolution reopened => no change required



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker