Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0010875ScribusGeneralpublic2012-07-14 01:552012-07-14 21:17
Reporterchristoph_s 
Assigned ToChelen 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSLinuxOS VersionOpenSUSE 12.1
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0010875: Cutting a text frame crashes Scribus
DescriptionCutting a text frame via the Context Menu crashes Scribus
Steps To Reproduce1. Create a text frame on canvas

2. Use "Cut" from the Context Menu

3. Crash
Additional Information[New Thread 0x7fffda1a0700 (LWP 29436)]
[New Thread 0x7fffd999f700 (LWP 29437)]
[Thread 0x7fffda1a0700 (LWP 29436) exited]
[Thread 0x7fffd999f700 (LWP 29437) exited]

Program received signal SIGSEGV, Segmentation fault.
0x00000000009e5d65 in PageItem_TextFrame::clearContents (this=0x3202ee0)
    at /home/christoph/scribus15/Scribus/scribus/pageitem_textframe.cpp:3307
3307 undoManager->getLastUndo()->setName(Um::ClearText);
(gdb) bt
#0 0x00000000009e5d65 in PageItem_TextFrame::clearContents (this=0x3202ee0)
    at /home/christoph/scribus15/Scribus/scribus/pageitem_textframe.cpp:3307
0000001 0x0000000000c2d177 in ScribusMainWindow::slotEditCut (this=0x1995230)
    at /home/christoph/scribus15/Scribus/scribus/scribus.cpp:5034
0000002 0x00000000007b1230 in ScribusMainWindow::qt_metacall (this=0x1995230, _c=QMetaObject::InvokeMetaMethod, _id=
    79, _a=0x7fffffffac60) at /home/christoph/scribus15/Scribus/scribus/moc_scribus.cxx:512
0000003 0x00007ffff418359a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) ()
   from /usr/lib64/libQtCore.so.4
0000004 0x00007ffff523a5d2 in QAction::triggered(bool) () from /usr/lib64/libQtGui.so.4
0000005 0x00007ffff523a7bf in QAction::activate(QAction::ActionEvent) () from /usr/lib64/libQtGui.so.4
0000006 0x00007ffff5670969 in ?? () from /usr/lib64/libQtGui.so.4
0000007 0x00007ffff56765a2 in ?? () from /usr/lib64/libQtGui.so.4
0000008 0x00007ffff52912b6 in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
0000009 0x00007ffff5677b0b in QMenu::event(QEvent*) () from /usr/lib64/libQtGui.so.4
0000010 0x00007ffff5240be4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
0000011 0x00007ffff524636b in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
0000012 0x00007ffff417081c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
0000013 0x00007ffff5241bb2 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/libQtGui.so.4
0000014 0x00007ffff52be201 in ?? () from /usr/lib64/libQtGui.so.4
0000015 0x00007ffff52bca2a in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/libQtGui.so.4
0000016 0x00007ffff52e42a2 in ?? () from /usr/lib64/libQtGui.so.4
0000017 0x00007fffee20e58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
0000018 0x00007fffee20ed88 in ?? () from /usr/lib64/libglib-2.0.so.0
0000019 0x00007fffee20ef59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
0000020 0x00007ffff419b50f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib64/libQtCore.so.4
0000021 0x00007ffff52e3f2e in ?? () from /usr/lib64/libQtGui.so.4
0000022 0x00007ffff416fa22 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib64/libQtCore.so.4
0000023 0x00007ffff416fc1f in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib64/libQtCore.so.4
0000024 0x00007ffff5673a81 in QMenu::exec(QPoint const&, QAction*) () from /usr/lib64/libQtGui.so.4
0000025 0x00000000008b6b44 in CanvasMode_Normal::createContextMenu (this=0x32ade40, currItem=0x3202ee0, mx=366.75,
    my=210) at /home/christoph/scribus15/Scribus/scribus/canvasmode_normal.cpp:1439
---Type <return> to continue, or q <return> to quit---
0000026 0x00000000008b2b22 in CanvasMode_Normal::mouseReleaseEvent (this=0x32ade40, m=0x7fffffffced0)
    at /home/christoph/scribus15/Scribus/scribus/canvasmode_normal.cpp:864
0000027 0x0000000000d04ab8 in ScribusView::eventFilter (this=0x3532730, obj=0x3567750, event=0x7fffffffced0)
    at /home/christoph/scribus15/Scribus/scribus/scribusview.cpp:4239
0000028 0x00007ffff41709a8 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) ()
   from /usr/lib64/libQtCore.so.4
0000029 0x00007ffff5240baf in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
0000030 0x00007ffff524636b in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
0000031 0x00007ffff417081c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
0000032 0x00007ffff5241bb2 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/libQtGui.so.4
0000033 0x00007ffff52bdb55 in ?? () from /usr/lib64/libQtGui.so.4
0000034 0x00007ffff52bca2a in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/libQtGui.so.4
0000035 0x00007ffff52e42a2 in ?? () from /usr/lib64/libQtGui.so.4
0000036 0x00007fffee20e58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
0000037 0x00007fffee20ed88 in ?? () from /usr/lib64/libglib-2.0.so.0
0000038 0x00007fffee20ef59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
0000039 0x00007ffff419b50f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib64/libQtCore.so.4
0000040 0x00007ffff52e3f2e in ?? () from /usr/lib64/libQtGui.so.4
0000041 0x00007ffff416fa22 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib64/libQtCore.so.4
0000042 0x00007ffff416fc1f in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib64/libQtCore.so.4
0000043 0x00007ffff4173de7 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
0000044 0x0000000001138d4f in mainApp (argc=1, argv=0x7fffffffdd28)
    at /home/christoph/scribus15/Scribus/scribus/main_nix.cpp:86
0000045 0x0000000001138cdc in main (argc=1, argv=0x7fffffffdd28)
    at /home/christoph/scribus15/Scribus/scribus/main_nix.cpp:54
TagsNo tags attached.
Patch
Attached Filesdiff file icon text.diff [^] (488 bytes) 2012-07-14 19:23 [Show Content]

- Relationships

-  Notes
(0028447)
ale (manager)
2012-07-14 09:05

confirmed.

from the menu and ctrl-x it works correctly.
(0028453)
cezaryece (developer)
2012-07-14 11:09

I had similar problems with ClearContents() and I think all that is related with undo.
(0028455)
Chelen (developer)
2012-07-14 13:34
edited on: 2012-07-14 13:34

It is fix since yesterday in my branch. It will be commit in the trunk during the week I hope
As cezaryece said. It was due to undo.

(0028456)
cbradney (administrator)
2012-07-14 13:36

Chelen, if you want to post a patch I will commit later today, thanks
(0028462)
Chelen (developer)
2012-07-14 19:23

This is really a little patch.
(0028463)
cbradney (administrator)
2012-07-14 19:56

Patch applied
(0028465)
christoph_s (administrator)
2012-07-14 21:17

Tested, fixed.

- Issue History
Date Modified Username Field Change
2012-07-14 01:55 christoph_s New Issue
2012-07-14 08:37 christoph_s Assigned To => cezaryece
2012-07-14 08:37 christoph_s Status new => assigned
2012-07-14 08:43 christoph_s Summary Cutting an item crashes Scribus => Cutting a text frame crashes Scribus
2012-07-14 08:44 christoph_s Description Updated View Revisions
2012-07-14 08:44 christoph_s Steps to Reproduce Updated View Revisions
2012-07-14 09:05 ale Note Added: 0028447
2012-07-14 11:08 cezaryece Assigned To cezaryece => Chelen
2012-07-14 11:09 cezaryece Note Added: 0028453
2012-07-14 13:34 Chelen Note Added: 0028455
2012-07-14 13:34 Chelen Note Edited: 0028455 View Revisions
2012-07-14 13:36 cbradney Note Added: 0028456
2012-07-14 19:23 Chelen File Added: text.diff
2012-07-14 19:23 Chelen Note Added: 0028462
2012-07-14 19:56 cbradney Note Added: 0028463
2012-07-14 19:56 cbradney Status assigned => resolved
2012-07-14 19:56 cbradney Fixed in Version => 1.5.0svn
2012-07-14 19:56 cbradney Resolution open => fixed
2012-07-14 21:17 christoph_s Note Added: 0028465
2012-07-14 21:17 christoph_s Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker