Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001099ScribusGeneralpublic04-Sep-17 20:4506-Jan-10 15:05
Reporterpacketbell 
Assigned Tofschmid 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.2 
Target VersionFixed in Version1.3.2cvs 
Summary0001099: Inline graphics
DescriptionThe ability to use (small) graphics directly in a text. Very handy when creating user manuals, like: "Click on the [icon] tool to open a document".

Options should include:

- Baseline shift
- Text flow around the graphic if it spans more than one row.
- Autoscale graphic with text (if text is resized, resize graphic proportionally as well).
Additional InformationI know this feature has been previously dismissed in the mailing list as 'something you typically find in word processors', but it is quite handy for placement of small graphics within a text.
TagsNo tags attached.
Attached Filespng file icon inline-frames.png [^] (114,306 bytes) 05-Jun-15 13:11


png file icon InlineObjDropCaps.png [^] (170,549 bytes) 05-Jun-15 22:40


pdf file icon InlineObjects.pdf [^] (121,284 bytes) 05-Jun-15 22:41
pdf file icon Inline3.pdf [^] (84,923 bytes) 05-Aug-07 22:08

- Relationships
related to 0001305closed Dynamic line spacing 
related to 0002098acknowledged Metabug: New File Format 
related to 0002395closedfschmid Portability: Casting between pointer and int 
has duplicate 0000416closedcbradney inline graphics in text 
has duplicate 0004831feedbackplinnell Add ability to position an image relative to a paragraph, not just a page 
related to 0001138acknowledged Style-sheet for images 
related to 0001155acknowledged Support non-breakable text blocks 

-  Notes
(0002476)
packetbell (reporter)
04-Sep-23 00:06

Another nice tweak for inline graphics would be to place the options above in a 'style' descriptor, so that all inline graphics based on a particular style can be modified at once.

Some other tweaks would also be nice, like assigning spot-colors to an image style, so that all graphics with that style print in blue instead of grayscale for example.
(0002515)
deejay1 (developer)
04-Sep-24 19:51

The problem here is that you can't define a "small" graphic. First time users could think that that would be the normal way of inserting graphics in the text. I think that one can put such a graphics frame in the scrapbook (I didn't tested it though) and drag&drop it from there.
Anyway I can think of an option to use graphics for the bulleted lists
(0002516)
packetbell (reporter)
04-Sep-24 21:27

It doesn't have to be a small graphic, that's just the most practical use of inline graphics. Say if you were writing a manual for Scribus, and instead of saying click on the 'Edit Frame Contents' icon, you could just say click on the [inline_graphic] icon. That's a pretty common use.

Another advantage of inline graphics is that they automatically move with the text. Right now, you could place a small graphic *over* the text, and force text to flow around it, but then you'd have to re-position the graphic everytime the text changes.
(0002519)
louisdesjardins (developer)
04-Sep-25 01:23

>>>> inline graphics [...] automatically move with the text

Agree. I think we definitely want that feature, with all the options cited.

The graphics would then be part of text just like words are, and spaced like words. Could also be alone on a line, centered, left or right aligned. I see so many uses for this feature: drop caps, chapter headers, etc.

I guess any graphic could have the option of being anchored to text.
(0002539)
ringerc (administrator)
04-Sep-27 08:19

I, too, would find this extremely useful. I think it'd be important to permit both vector graphics objects and graphics frames to be used for such in-line graphics, too.

The use I have in mind is classified advertising. Images and laid-out ads are often included in-line in text, and being able to flow them all together would be very helpful.

As for "feature you find in a word processor," I feel compelled to note that it's a feature you find in word processors, FrameMaker, and Adobe InDesign. I'm not convinced it should be dismissed that lightly.

This bug looks like its actually a duplicate of the older 0000416 and I've marked it as such. It might really be better to reverse that and make 0000416 a duplicate of this bug - not sure.
(0005019)
ringerc (administrator)
05-Jun-14 03:14

Franz, you may as well close this one when you're satisfied things are done.

It's totally awesome to have this supported... I'm going to have to get it exposed to the scripter so I can start writing my classified pagination system.
(0005034)
ringerc (administrator)
05-Jun-15 12:38

Just tested out the inline frame support. It's very cool to be able to use any frame, btw.

I managed to use inline text frames to do basic classified-ad-style column layout :-) . It worked, though it took some interesting tweaking with leading etc.

I suspect that to be properly effective inline frames may need flow-around options, and probably dynamic line spacing adjustment. Getting inline objects to play well with surrounding text looks like it might be "interesting". It may also be necessary to be able to "shrink" a text frame hard around the text it contains, since the current behaviour makes it hard to get rid of the large amount of whitespace around inline text frames.

There's also no properties access to the inline objects and no way to select them by clicking on them instead of in them. Probably doesn't matter for now.

This is all VERY exciting. I'm just about done with exams, and I'll definitely have to look at what's involved in inserting inline frames via Python.
(0005037)
fschmid (administrator)
05-Jun-15 12:52

Yes Craig, these inline frames are currently "hot stuff", they need some more fixing the next days. Will try to fix the Story Editor tonight.
(0005039)
ringerc (administrator)
05-Jun-15 13:15

I figured I'd post some info here to help interested people know how to use Franz's latest magic.

To insert a frame inline, you must currently create a frame normally, then copy it, go into edit mode on the text frame and paste it into the text frame. Pretty much anything should work - those bullets and the calculator image in the screenshot are inline with the text :-)

Given that Franz only implemented the basic support for this stuff over the last couple of days, this is pretty awesome.

Attached is a screenshot of how things are working. Currently inline frames only work well if the inline frame size is <= the text height, and the inline frame width is narrower than the column width. Some layout tweaking may still be required to get the desired height etc, too. The big thing is that it works - hoooorray!
(0005049)
fschmid (administrator)
05-Jun-15 22:46

Uploaded two files which show some of the new features:
InlineObjDropCaps.png shows how to use inline Objects as DropCaps
InlineObjects.pdf is a nice example what you can do with textframes
as inline Objects, look at the gray square before the words "Duis viverra"
and view it with maximum magnification in Acrobat Reader.
(0005050)
louisdesjardins (developer)
05-Jun-16 01:52

Hello Franz! Like Craig says: hoooorray!
Very cool! Indeed!
(0005882)
christoph_s (administrator)
05-Aug-04 02:35

Will it be possible to connect/lock/anchor objects outside a frame to the frame content?

I specifically think about marginal notes, since this feature is much required in exhibition catalogues, where a famous or significant quote is very often placed as a marginal note.

ID CS2 has finally introduced this feature.
(0005886)
ringerc (administrator)
05-Aug-04 05:58

I could've sworn someone already filed an RFE for anchoring items to text. I can't seem to find it now though. Would you mind filing a separate bug for it?
(0005895)
ale (manager)
05-Aug-04 13:17

awsome feature... would it feasable to enable also the inserting of groups of frames? (as an exemple if i want to create a quick and dirty formula.)
(0005922)
fschmid (administrator)
05-Aug-07 22:00

Groups of Objects can now used as inline Objects too.

- Issue History
Date Modified Username Field Change
04-Sep-17 20:45 packetbell New Issue
04-Sep-23 00:06 packetbell Note Added: 0002476
04-Sep-24 19:51 deejay1 Note Added: 0002515
04-Sep-24 21:27 packetbell Note Added: 0002516
04-Sep-25 01:23 louisdesjardins Note Added: 0002519
04-Sep-27 08:09 ringerc Relationship added duplicate of 0000416
04-Sep-27 08:19 ringerc Note Added: 0002539
04-Sep-27 08:21 ringerc Relationship added related to 0001138
04-Sep-27 16:24 cbradney Relationship deleted 0000416
04-Sep-27 16:25 cbradney Relationship added has duplicate 0000416
05-Jun-14 03:14 ringerc Status new => assigned
05-Jun-14 03:14 ringerc Assigned To => fschmid
05-Jun-14 03:14 ringerc Note Added: 0005019
05-Jun-15 12:38 ringerc Note Added: 0005034
05-Jun-15 12:41 ringerc Relationship added related to 0001155
05-Jun-15 12:44 ringerc Relationship added related to 0001305
05-Jun-15 12:52 fschmid Note Added: 0005037
05-Jun-15 13:11 ringerc File Added: inline-frames.png
05-Jun-15 13:15 ringerc Note Added: 0005039
05-Jun-15 16:11 ringerc Relationship added related to 0002098
05-Jun-15 22:40 fschmid File Added: InlineObjDropCaps.png
05-Jun-15 22:41 fschmid File Added: InlineObjects.pdf
05-Jun-15 22:46 fschmid Note Added: 0005049
05-Jun-16 01:52 louisdesjardins Note Added: 0005050
05-Jul-11 16:37 ringerc Relationship added related to 0002228
05-Aug-04 02:35 christoph_s Note Added: 0005882
05-Aug-04 05:58 ringerc Note Added: 0005886
05-Aug-04 13:17 ale Note Added: 0005895
05-Aug-07 22:00 fschmid Note Added: 0005922
05-Aug-07 22:08 fschmid File Added: Inline3.pdf
05-Aug-09 19:13 ringerc Relationship added related to 0002395
05-Dec-28 02:19 plinnell Status assigned => resolved
05-Dec-28 02:19 plinnell Fixed in Version => 1.3.2cvs
05-Dec-28 02:19 plinnell Resolution open => fixed
06-Jan-10 15:05 cbradney Status resolved => closed
06-Dec-15 13:52 plinnell Relationship added has duplicate 0004831



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker