Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011022Contributor Builds[All Projects] Generalpublic2012-08-09 15:002014-08-19 03:32
Reporterale 
Assigned Tocezaryece 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Summary0011022: crash after having deleted a endnote
Description- make the default note style a endnote
- add a text frame
- insert a endnote and add some endnote text
- delete the endnote frame
- go into the text frame and add a new note
- crash
Additional InformationGNU gdb (GDB) 7.4.1-debian
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html> [^]
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>... [^]
Reading symbols from /usr/local/bin/scribusgit...done.
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffe1009700 (LWP 5355)]
[New Thread 0x7fffe0808700 (LWP 5370)]
[New Thread 0x7fffdbfff700 (LWP 5371)]
[Thread 0x7fffe0808700 (LWP 5370) exited]
[Thread 0x7fffdbfff700 (LWP 5371) exited]

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff1d1a588 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
(gdb) bt
#0 0x00007ffff1d1a588 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
0000001 0x00000000009dba3e in PageItem_TextFrame::updateNotesMarks (this=0x30ed360, notesMap=...) at /home/ale/docs/src/scribus.git/Scribus/scribus/pageitem_textframe.cpp:5040
0000002 0x00000000009cd025 in PageItem_TextFrame::layout (this=0x30ed360) at /home/ale/docs/src/scribus.git/Scribus/scribus/pageitem_textframe.cpp:2954
0000003 0x0000000000c71886 in ScribusMainWindow::slotInsertMarkNote (this=0x1940490) at /home/ale/docs/src/scribus.git/Scribus/scribus/scribus.cpp:10687
0000004 0x000000000076167f in ScribusMainWindow::qt_static_metacall (_o=0x1940490, _c=QMetaObject::InvokeMetaMethod, _id=211, _a=0x7fffffffcac0)
    at /home/ale/docs/src/scribus.git/Scribus/build/scribus/moc_scribus.cxx:644
0000005 0x00007ffff44595cf in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000006 0x00007ffff4ef5502 in QAction::triggered(bool) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000007 0x00007ffff4ef56f0 in QAction::activate(QAction::ActionEvent) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000008 0x00007ffff4ef5857 in QAction::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000009 0x00007ffff4efb70c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000010 0x00007ffff4effb8a in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000011 0x00007ffff4443bde in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000012 0x00007ffff4f2c534 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000013 0x00007ffff4f2da43 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000014 0x00007ffff4f01869 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000015 0x00007ffff4443bde in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000016 0x00007ffff4f98bca in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000017 0x00007ffff4f99001 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000018 0x00007ffff4f75c58 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000019 0x00007ffff4f9ccf2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000020 0x00007ffff002c205 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000021 0x00007ffff002c538 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000022 0x00007ffff002c5f4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000023 0x00007ffff44722e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000024 0x00007ffff4f9c96e in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000025 0x00007ffff444292f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000026 0x00007ffff4442bb8 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000027 0x00007ffff4447d78 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000028 0x0000000001199d7b in mainApp (argc=1, argv=0x7fffffffe4c8) at /home/ale/docs/src/scribus.git/Scribus/scribus/main_nix.cpp:86
0000029 0x0000000001199d08 in main (argc=1, argv=0x7fffffffe4c8) at /home/ale/docs/src/scribus.git/Scribus/scribus/main_nix.cpp:54
TagsNo tags attached.
Patch
Attached Files

- Relationships

-  Notes
(0028806)
cezaryece (developer)
2012-08-13 09:09

Fixed - check it.
(0028812)
ale (manager)
2012-08-13 13:35

seems to be fixed!

- Issue History
Date Modified Username Field Change
2012-08-09 15:00 ale New Issue
2012-08-09 15:00 ale Status new => assigned
2012-08-09 15:00 ale Assigned To => cezaryece
2012-08-13 09:08 cezaryece Assigned To cezaryece => ale
2012-08-13 09:09 cezaryece Note Added: 0028806
2012-08-13 09:09 cezaryece Status assigned => feedback
2012-08-13 13:35 ale Note Added: 0028812
2012-08-13 13:35 ale Status feedback => assigned
2012-08-13 13:35 ale Status assigned => resolved
2012-08-13 13:35 ale Resolution open => fixed
2012-08-13 13:35 ale Assigned To ale => cezaryece
2014-08-19 03:32 christoph_s Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker