Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011040ScribusGeneralpublic2012-08-20 19:092012-11-13 21:34
Reporterpygmee 
Assigned Topygmee 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
Platformx86OSUbuntuOS Version12.04
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0011040: Collect files in sub-directories
Descriptionactually collect4output collects all the files in one dir. It can be difficult to reuse files on large document such as magazines in which lots of pictures and fonts can be used. Having separate dirs for each collected ressources (fonts, pictures, profile) can be interesting. Adding to that a little report can be include to list ressources with their path and some other document informations to be listed (could be based on JDF or so).
TagsNo tags attached.
Patch
Attached Filespatch file icon collect4output-1.0.patch [^] (4,181 bytes) 2012-08-20 19:10 [Show Content]
patch file icon collect4output-1.1.patch [^] (6,678 bytes) 2012-08-21 16:03 [Show Content]
patch file icon 11040_collect4output-1.2.patch [^] (6,098 bytes) 2012-08-22 23:33 [Show Content]

- Relationships

-  Notes
(0028845)
pygmee (developer)
2012-08-20 19:11

patch V1 does create subdirectories and add ressources in them. May be to directory creation could be improve with a loo on list values. That'll be my next step. Them, report creation.
(0028851)
pygmee (developer)
2012-08-21 16:03

V1.1 adds a more convenient way to add directories and prepares output for a report.
(0028857)
jghali (administrator)
2012-08-22 23:39

Uploaded v1.2 :
- fix compilation due to missing change in collect4ouput.h
- create fonts and profiles directories only if user request those files to be collected
- load fonts and profiles from 'doc_dir/fonts' and 'doc_dir/profiles' when collected doc is loaded
(0028858)
pygmee (developer)
2012-08-23 01:04

great, i had just tested it another way (cf in git collectforoutput branch) but i will learn from yours :)
(0028863)
jghali (administrator)
2012-08-23 22:56

Anything more to do related to th report? Currently that code is mostly commented out...
(0028872)
jghali (administrator)
2012-08-26 23:54

I've committed the patch. For now i've left what relates to the report generation. For the report i would suggest to proceed as following :
- refactor the code so as to list fonts, profiles and images to collect first
- collect fonts, profiles and images according to the determined lists
- generate the report using a single function

Open a new issue when you have the report part ready. And thanks, this is a nice improvement!

- Issue History
Date Modified Username Field Change
2012-08-20 19:09 pygmee New Issue
2012-08-20 19:09 pygmee Status new => assigned
2012-08-20 19:09 pygmee Assigned To => pygmee
2012-08-20 19:10 pygmee File Added: collect4output-1.0.patch
2012-08-20 19:11 pygmee Note Added: 0028845
2012-08-21 16:03 pygmee File Added: collect4output-1.1.patch
2012-08-21 16:03 pygmee Note Added: 0028851
2012-08-22 23:33 jghali File Added: 11040_collect4output-1.2.patch
2012-08-22 23:39 jghali Note Added: 0028857
2012-08-23 01:04 pygmee Note Added: 0028858
2012-08-23 22:56 jghali Note Added: 0028863
2012-08-26 23:54 jghali Note Added: 0028872
2012-08-26 23:54 jghali Status assigned => resolved
2012-08-26 23:54 jghali Fixed in Version => 1.5.0svn
2012-08-26 23:54 jghali Resolution open => fixed
2012-08-27 01:24 jghali Target Version 1.5.0svn => 1.5.0
2012-11-13 21:34 cbradney Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker