Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011430ScribusImport / Exportpublic2013-02-20 08:092013-02-24 21:22
Reporterchristoph_s 
Assigned Tofschmid 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSLinuxOS VersionOpenSUSE 12.1
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0011430: Issues with Apple PICT (PCT) files
DescriptionIn the archive attached to this report, some files can be imported as vector files but not be opened via File > Open. Others are imported, but not correctly.

Creator: Illustrator CS2
TagsNo tags attached.
Patch
Attached Files7z file icon PCT-Issues.7z [^] (1,194,943 bytes) 2013-02-20 08:09

- Relationships

-  Notes
(0029860)
cbradney (administrator)
2013-02-20 22:55

PICT files are images. Image files should never be openable, they should be placeable or importable.
(0029861)
fschmid (administrator)
2013-02-20 23:54

PICT files are both in a way. Vector and Bitmap, they can contain either a bitmap or a collection of vector elements. So they should be openable.
(0029862)
cbradney (administrator)
2013-02-21 00:07

Actually, I think we should move back to just opening SLA files and importing/placing the image/vector files, like Gimp has changed to.
(0029863)
christoph_s (administrator)
2013-02-21 07:28
edited on: 2013-02-21 07:28

I strongly disagree. Many document templates like fliers are available as AI, EPS, CDR, SVG or other formats supported by Scribus. Being able to open them directly is a blessing, as the default page size is automatically correct. Remember that all major vector drawing programs, including Inkscape, are working with page sizes.

We also have a (still rudimentary) IDML importer, i.e., an importer for InDesign *documents*. It'd make no sense to import as vector graphics only.

(0029868)
ale (manager)
2013-02-21 10:24

fully supporting craig!

scribus should only open and save .sla files.

all the rest should be a case for import / export.

and yes, import should be able to create new pages, with the page size being read from the imported file, if it provides the information and the user wants to use them (otherwise use the current page's or the document size; you choose or the user chooses)
(0029878)
christoph_s (administrator)
2013-02-22 09:16

ale, this would make sense if we had an Import dialog for documents, which we haven't. Functionally this would make sense, because "opened" files/documents are always converted to Scribus files. But as long as there is no dedicated Import dialog we better stick with "Open".

Besides, this discussion would be more reasonably placed in a separate bug report or the dev mailing list.
(0029898)
christoph_s (administrator)
2013-02-24 21:22

Tested, fixed. Thanks.

- Issue History
Date Modified Username Field Change
2013-02-20 08:09 christoph_s New Issue
2013-02-20 08:09 christoph_s Status new => assigned
2013-02-20 08:09 christoph_s Assigned To => fschmid
2013-02-20 08:09 christoph_s File Added: PCT-Issues.7z
2013-02-20 22:55 cbradney Note Added: 0029860
2013-02-20 23:54 fschmid Note Added: 0029861
2013-02-21 00:07 cbradney Note Added: 0029862
2013-02-21 07:28 christoph_s Note Added: 0029863
2013-02-21 07:28 christoph_s Note Edited: 0029863 View Revisions
2013-02-21 10:24 ale Note Added: 0029868
2013-02-22 09:16 christoph_s Note Added: 0029878
2013-02-24 11:27 fschmid Status assigned => resolved
2013-02-24 11:27 fschmid Fixed in Version => 1.5.0svn
2013-02-24 11:27 fschmid Resolution open => fixed
2013-02-24 21:22 christoph_s Note Added: 0029898
2013-02-24 21:22 christoph_s Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker