Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011487ScribusUser Interfacepublic13-Apr-08 08:0414-Aug-31 20:21
Reporterchristoph_s 
Assigned Tojghali 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSLinuxOS VersionOpenSUSE 12.1
Product Version1.5.0svn 
Target Version1.5.1Fixed in Version1.5.0svn 
Summary0011487: [TESTED-PATCH] Add tooltips to the Picture Browser
DescriptionThe Picture Browser is extremely versatile, but due to missing tooltips, it's not easy to use, leaving it to users' experimentations to figure out how it works.
Tagseasyhack, tooltips
Attached Filesdiff file icon 11487-part1.diff [^] (17,304 bytes) 14-Aug-19 23:39 [Show Content]
diff file icon 11487-part2.diff [^] (4,845 bytes) 14-Aug-19 23:39 [Show Content]
diff file icon 11487-part1CORRECT.diff [^] (17,163 bytes) 14-Aug-21 02:41 [Show Content]

- Relationships
related to 0012622closedjghali [PATCH] Fix inconsistent Character Palette tooltips 

-  Notes
(0030056)
JLuc (updater)
13-Apr-08 10:35

In 1.4.3 and 1.5 on ubuntu, there are hints on every button and value displayed in the picture manager (active through Extra > Manage Picture), so i dont understand your report.

Only thing i notice that might be improved is that on the first tab, the hints appear when hovering the *value* but do not appear when hovering the *label*.
(0030061)
christoph_s (administrator)
13-Apr-08 22:58

The Picture Browser is only available in 1.5.0svn. It's not the same as "Manage Images".
(0030069)
JLuc (updater)
13-Apr-10 22:50

Ah OK. AMOF most of the buttons in the top have hints except :
- "Include subdirectories"
- "Allways on top"
- "Autosave settings"
- "Close"
"Go" button has a hint that could introduce the 3 possible values for the select.

Not a hint problem, but "Preview with information" select value should be "Preview with file name" since that's the feature actually.

As for the bottom part of the dialog, none of the inputs has hints... As a consequence example : i could not understand the use of the "Image frames" select in the "Insert image" pane.
(0033190)
Kunda (developer)
14-Aug-06 21:49

Who wants to make a patch for this ?
(0033292)
FirasH (updater)
14-Aug-19 23:41

Added .diff files.
Built & tested before uploading. Non-tooltips changes are made due to the newer save format.
(0033305)
FirasH (updater)
14-Aug-20 23:33

I found a very small problem in the .diff file. I'll later upload a better fix for the issue.
(0033307)
FirasH (updater)
14-Aug-21 02:41

Attached the correct .diff for 11487-part1
(0033336)
jghali (administrator)
14-Aug-24 15:16

Applied, thanks!
(0033408)
FirasH (updater)
14-Aug-31 20:21

Thanks jghali!
Fixed in 1.5.0.svn (19468).

- Issue History
Date Modified Username Field Change
13-Apr-08 08:04 christoph_s New Issue
13-Apr-08 10:35 JLuc Note Added: 0030056
13-Apr-08 22:58 christoph_s Note Added: 0030061
13-Apr-10 22:50 JLuc Note Added: 0030069
14-Jul-03 07:25 Kunda Tag Attached: easyhack
14-Jul-03 07:26 Kunda Target Version 1.5.0 => 1.5.1
14-Aug-01 22:56 Kunda Tag Attached: tooltips
14-Aug-06 21:49 Kunda Note Added: 0033190
14-Aug-06 21:49 Kunda Status new => feedback
14-Aug-19 23:39 FirasH File Added: 11487-part1.diff
14-Aug-19 23:39 FirasH File Added: 11487-part2.diff
14-Aug-19 23:41 FirasH Note Added: 0033292
14-Aug-19 23:41 FirasH Summary Add tooltips to the Picture Browser => [PATCH] Add tooltips to the Picture Browser
14-Aug-20 00:31 FirasH Relationship added related to 0012622
14-Aug-20 14:45 Kunda Status feedback => confirmed
14-Aug-20 23:33 FirasH Note Added: 0033305
14-Aug-21 02:41 FirasH File Added: 11487-part1CORRECT.diff
14-Aug-21 02:41 FirasH Note Added: 0033307
14-Aug-24 00:13 FirasH Summary [PATCH] Add tooltips to the Picture Browser => [TESTED-PATCH] Add tooltips to the Picture Browser
14-Aug-24 15:16 jghali Note Added: 0033336
14-Aug-24 15:16 jghali Status confirmed => resolved
14-Aug-24 15:16 jghali Fixed in Version => 1.5.0svn
14-Aug-24 15:16 jghali Resolution open => fixed
14-Aug-24 15:16 jghali Assigned To => jghali
14-Aug-31 20:21 FirasH Note Added: 0033408
14-Aug-31 20:21 FirasH Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker