Mantis Issue Tracking for Scribus
· Hosting provided by / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011539ScribusGeneralpublic2013-05-24 01:582014-09-20 05:35
Assigned To 
PlatformOSLinuxOS Version
Product Version1.5.0svn 
Target VersionFixed in Version1.5.0svn 
Summary0011539: Groups are broken in multiple ways
DescriptionI'm more bald because of groups. Simply put, groups are broken. Both in 1.4.x stable, and 1.5.x development.

Now and then groups randomly disappear. Grouping elements can randomly cause a run-away process that burns up CPU time until I kill it. Acting on more than one selected group at once (say scaling them) causes random weird things to happen, like popping back to the original size after un-grouping them.

It's hard to make this a concise and direct bug report, because there seems to be so many problems with groups that it's hard to narrow it down to one specific problem.
Steps To ReproduceMy madness comes from wanting to make print documents with source material from sources where the only work-flow is to get it into scribus via PDF/PS. PDF didn't work because all strings using a specific font would be lost. PS worked, but _everything_ is in groups of groups of groups when importing the PS, and madness ensued from that point on.
TagsNo tags attached.
Attached Filespdf file icon Mac_Numbers.pdf [^] (84,538 bytes) 2014-08-22 05:43
png file icon Screenshot-page1-imported-to-landscape.png [^] (149,957 bytes) 2014-08-31 07:00

png file icon Scribus_r19468.png [^] (379,422 bytes) 2014-08-31 15:29

- Relationships
related to 0012718closedjghali Color Management breaks formatting 

-  Notes
JLuc (developer)
2013-05-24 10:12

*Tester and reporter advice* : allthough maybe difficult with your documents, you should try to pinpoint specific problems, so as developpers to be able to tackle the issue.
Begin with simple situations so as to have clear reports. Avoid groups of groups at first. Create one dedicated bug for each specific problem you find. When usefull, upload sample document demonstrating problem.
Kunda (manager)
2014-07-07 15:20

FishB8, based on Jluc request above, can you reproduce the phenomenon exactly ?
This helps us to specifically locate the problem. If you can run a debugger on it while it crashes would be even better. Thanks.
Kunda (manager)
2014-08-21 13:36

FishBB, please respond so that we can tackle this problem.
FishB8 (reporter)
2014-08-21 17:06

Sorry I must have missed the earlier message. I thought I had included a sample file, but that apparently is not the case. I believe the files giving me problems are PDFs exports from Numbers for Mac.

I will re-test tonight at home where I keep a SVN build up-to-date, and if there is still problems, I will provide a sample document.
FishB8 (reporter)
2014-08-22 05:43

Ok, I tried this a year ago and when I would ungroup the imported PDF pages, various elements would randomly go missing, or elements would be misplaced. (Probably was not applying group transforms to child objects correctly)

Trying it now, the behavior is not as erratic, but now the imported content looks almost nothing the the source.

I'm uploading the Mac Numbers PDF file so that you can try it out for yourself.
Kunda (manager)
2014-08-31 07:12

Uploaded a screenshot of the 1st page imported on to OSX 10.8.5 1.5.0svn r19430
AFAICT the Mac_Numbers.pdf import in to Scribus seems like it's not as wide and therefore not the same proportions to the original PDF. But I don't see off-hand how the orignal content differs from the imported content. Help me understand, FishB8.

As for ungrouping, the issue to use the ungrouped elements becomes complex because there are layers of elements stacked on top of each other. I could see how that would be an issue.

Also, I did encounter a crash just like described in 0011134
FishB8 (reporter)
2014-08-31 15:29

hmm. that is very different from what I am seeing. The import was looking very close (with the exception of a missing title) when I first filed this bug, but now it's missing quite a few things. (although the preview looks correct)

I just now built from tip of svn (r19468). It was built without libvisio, libmspub, libpagemaker, and libcdr.

Perhaps a dependency is having problems, but scribus uses an internal pdf parser doesn't it?

Screenshot attached.
Kunda (manager)
2014-08-31 16:16

Good question. Lets see what others with more understanding know what's going on here.

I'm not so versed here but I wonder if this is a dependeny issue like ghostscript or poppler?

On my end I have pretty much all the dependencies installed (except for libcdr - which is not relevant). But I'm not sure this is a librevenge suite issue.

BTW, if you make the screenshot file size smaller than what you have it (mine is 150k) it will render when this page is loaded.
FishB8 (reporter)
2014-08-31 16:26

Well, for reference my system (gentoo) has ghostscript-9.14, poppler-0.26.4, and librevenge-0.0.1
FishB8 (reporter)
2014-08-31 16:30

Also, I'm using cmake (as opposed to qmake) to build it if that makes any difference.
Kunda (manager)
2014-09-12 02:22

I built with cmake as well so I don't think that is the issue. Please ask on Mailing List.
FishB8 (reporter)
2014-09-20 02:35


Good news: I had time today to try and fiddle with the svn build and try to figure out what is going on. Ultimately I've found that the groups problems I was having before are gone. I can ungroup things and move them around without members disappearing, jumping to weird places, or crashing scribus. So, I'm convinced that the original bug is squashed.

Bad news: I figured out why my screenshot looked messed up with parts missing. Turns out that if I disabled color management everything looks correct.

The color profiles used aren't anything exotic. "sRGB" and "GREYCoL TR006 Coated" for RGB and CMYK colors respectively.

Should I file a separate bug, or perhaps this is already a know issue?
Kunda (manager)
2014-09-20 05:35

Since it doesn't seem there is an open issue with Color Management that matches your discovery I've cloned this issue to 0012718 Please continue to populate that with data. If you need me to change the summary or description, please let me know through the comment section.
Closing this bug for now as per your report of it being fixed.

- Issue History
Date Modified Username Field Change
2013-05-24 01:58 FishB8 New Issue
2013-05-24 10:12 JLuc Note Added: 0030171
2014-07-07 15:20 Kunda Note Added: 0032540
2014-07-07 15:20 Kunda Status new => feedback
2014-08-21 13:36 Kunda Note Added: 0033309
2014-08-21 17:06 FishB8 Note Added: 0033315
2014-08-21 17:06 FishB8 Status feedback => new
2014-08-22 05:43 FishB8 Note Added: 0033316
2014-08-22 05:43 FishB8 File Added: Mac_Numbers.pdf
2014-08-31 07:00 Kunda File Added: Screenshot-page1-imported-to-landscape.png
2014-08-31 07:12 Kunda Note Added: 0033387
2014-08-31 15:29 FishB8 Note Added: 0033394
2014-08-31 15:29 FishB8 File Added: Scribus_r19468.png
2014-08-31 16:16 Kunda Note Added: 0033397
2014-08-31 16:26 FishB8 Note Added: 0033398
2014-08-31 16:30 FishB8 Note Added: 0033400
2014-09-12 02:22 Kunda Note Added: 0033634
2014-09-20 02:35 FishB8 Note Added: 0033763
2014-09-20 05:25 Kunda Issue cloned: 0012718
2014-09-20 05:25 Kunda Relationship added related to 0012718
2014-09-20 05:35 Kunda Note Added: 0033777
2014-09-20 05:35 Kunda Status new => closed
2014-09-20 05:35 Kunda Resolution open => fixed
2014-09-20 05:35 Kunda Fixed in Version => 1.5.0svn

Copyright © 2000 - 2015 MantisBT Team
Powered by Mantis Bugtracker