Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011874ScribusTablespublic2013-12-06 15:522014-04-06 20:29
ReporterFirasH 
Assigned Tojghali 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0011874: First Line Offset in Tables is not saved and radio buttons are not selectable
DescriptionProperties > Text > First Line Offset does not work as supposed for Table cells.
Changes are not saved, even if applied until closing and reopening the document. The black circle of the radio buttons under First Line Offset is always on "Maximum Ascent"
Steps To Reproduce1) Create a new document with a Table (number of Rows/Columns is not important)
2) Write some text in one of the cells (all of them have this issue)
3) Go to Properties > Text > First Line Offset
4) Try selecting "Font Ascent", "Line Spacing" or "Baseline Grid"

The Offset is applied to the First Line, but the "Maximum Ascent" radio button is always selected.

5) Save the document an reopen it

After reopening the document the First Line Offset returns to "Maximum Ascent"
Additional InformationScribus SVN 18624
TagsNo tags attached.
Patch
Attached Files

- Relationships

-  Notes
(0031355)
FirasH (developer)
2014-02-21 14:27

Now with Scribus 1.5.0 SVN (18828) and Qt 5.2.1 the issue with the radio button seems resolved.

The only problem still there is that the entry selected under "First Line Offset" is not saved and consequently not restored as expected after re-opening the document.
(0031359)
Kunda (manager)
2014-02-21 21:55

Reproducible on OSX 10.8.5
Qt version 5.2.1.
Scribus Version 1.5.0.svn
12 February 2014
Build ID: C-C-T-F-C1.12.16-Mac/-64bit
Using Ghostscript version 9.07
(0031399)
jghali (administrator)
2014-02-25 22:14

Fixed. A warning tho : to fix this issue (+ a few similar ones) a file format change was required. I'll keep the old table reading code as is for 1-2 weeks in order to allow old 1.5.0svn document to be converted. I'll do a cleanup afterwards: as with every development version, we reserve us a right to do breaking changes when required.
(0031623)
christoph_s (administrator)
2014-04-05 16:39

FirasH, can you please re-test?
(0031633)
FirasH (developer)
2014-04-06 12:56

Re-tested, cannot reproduce the issue.

- Issue History
Date Modified Username Field Change
2013-12-06 15:52 FirasH New Issue
2013-12-08 23:46 jghali Target Version => 1.5.0
2014-02-21 14:27 FirasH Note Added: 0031355
2014-02-21 21:55 Kunda Note Added: 0031359
2014-02-25 22:14 jghali Note Added: 0031399
2014-02-25 22:14 jghali Status new => resolved
2014-02-25 22:14 jghali Fixed in Version => 1.5.0svn
2014-02-25 22:14 jghali Resolution open => fixed
2014-02-25 22:14 jghali Assigned To => jghali
2014-04-05 16:39 christoph_s Note Added: 0031623
2014-04-06 12:56 FirasH Note Added: 0031633
2014-04-06 20:29 christoph_s Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker