Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011938ScribusStory Editor / Text Framespublic2014-01-10 18:322014-11-25 22:13
ReporterJLuc 
Assigned ToFirasH 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionreopened 
PlatformOSOS Version
Product Version1.5.0svn 
Target VersionFixed in Version1.5.0svn 
Summary0011938: [PATCH tested ok] 'Paste' not available in table cell
DescriptionIts not possible to paste into a table cell some text that has been copied outside scribus (Libreoffice calc, firefox)

- menu entry is not active
- CTRL+V inserts a 'v' !

Pasting into a text frame is OK though.

Steps To Reproduceopen libreoffice or firefox
select text
copy it
click on scribus
edit cell content
paste
TagsNo tags attached.
PatchYes
Attached Filesdiff file icon 11938-Patch.diff [^] (1,222 bytes) 2014-11-24 16:24 [Show Content]
diff file icon 11938-FinalPatch.diff [^] (2,176 bytes) 2014-11-24 17:03 [Show Content]

- Relationships

-  Notes
(0031024)
jghali (administrator)
2014-01-10 21:39
edited on: 2014-01-10 21:43

Works on Windows 7.

(0031027)
FirasH (developer)
2014-01-10 22:33

Same issue here on openSUSE 13.1 (SVN 18705).
You can copy/paste the text inside of a table using the Story editor. From canvas it does not paste the copied text.
(0031028)
JLuc (updater)
2014-01-10 23:00

I forgot to mention : it doesnt work on Ubuntu 13.10
(0031029)
FirasH (developer)
2014-01-10 23:03

I've made some test and here are the results:
Scribus does not paste the text copied from Firefox in the Table if this text has been copied after opening a New Document in Scribus.
(Edit > Paste is not clickable)

If you copy the text and then create a new document Scribus works as expected.

As I sad in the previous note copy/paste always works from the Story Editor. (Even if Edit > Paste is not clickable)
(0032398)
cbradney (administrator)
2014-07-01 22:31

I have no issue pasting from any app into tables, but I get no context menu in edit mode, nor for cells.
(0032400)
cbradney (administrator)
2014-07-01 23:51

r19307 has a first part of this fix.. some clean up to come tomorrow
(0032839)
christoph_s (administrator)
2014-07-20 00:01

Tested, fixed. Thanks.
(0034236)
FirasH (developer)
2014-11-23 19:05

There is something not working here. Investigating...
(0034239)
FirasH (developer)
2014-11-24 16:23

The issue is:
0) Create a new document in Scribus
1) Copy some text from Firefox
2) Insert a Table on canvas
3) Double-click on the cell to edit its content
Edit > Paste is not enabled.

4) Insert a text Frame
5) Double-click on the Text Frame to edit its content
6) Double click on the cell
Edit > Paste is now available.

This workaround works because in line 242 of "appmodehelper.cpp" there is:
(*a_scrActions)["editPaste"]->setEnabled( textFrameEditMode || (currItem == NULL) );
that keeps Paste enabled: (currItem == NULL).

Uploaded a patch that fixes Edit > Paste not enabled.
(0034240)
FirasH (developer)
2014-11-24 17:04

FinalPatch is a better fix as when copying text while in modeEditTable, its not needed to exit and re-enable modeEditTable.
(0034241)
JLuc (updater)
2014-11-24 17:34

I confirm it doesnt work, now.
(CTRL+V doesnt type v as a text neither, now)
(0034246)
JLuc (updater)
2014-11-25 22:12

I tested the finalpatch
and i confirm it's OK : it fixes the Paste issue.

- Issue History
Date Modified Username Field Change
2014-01-10 18:32 JLuc New Issue
2014-01-10 18:32 JLuc Tag Attached: table
2014-01-10 21:39 jghali Note Added: 0031024
2014-01-10 21:43 jghali Note Edited: 0031024 View Revisions
2014-01-10 22:33 FirasH Note Added: 0031027
2014-01-10 23:00 JLuc Note Added: 0031028
2014-01-10 23:03 FirasH Note Added: 0031029
2014-07-01 20:08 FirasH Status new => confirmed
2014-07-01 22:31 cbradney Note Added: 0032398
2014-07-01 23:26 cbradney Assigned To => cbradney
2014-07-01 23:26 cbradney Status confirmed => assigned
2014-07-01 23:51 cbradney Note Added: 0032400
2014-07-02 21:14 cbradney Status assigned => resolved
2014-07-02 21:14 cbradney Fixed in Version => 1.5.0svn
2014-07-02 21:14 cbradney Resolution open => fixed
2014-07-20 00:01 christoph_s Note Added: 0032839
2014-07-20 00:01 christoph_s Status resolved => closed
2014-10-09 01:03 Kunda Tag Detached: table
2014-11-23 19:05 FirasH Assigned To cbradney => FirasH
2014-11-23 19:05 FirasH Note Added: 0034236
2014-11-23 19:05 FirasH Status closed => feedback
2014-11-23 19:05 FirasH Resolution fixed => reopened
2014-11-23 19:05 FirasH Status feedback => assigned
2014-11-24 16:23 FirasH Note Added: 0034239
2014-11-24 16:24 FirasH File Added: 11938-Patch.diff
2014-11-24 16:25 FirasH Patch => Yes
2014-11-24 17:03 FirasH File Added: 11938-FinalPatch.diff
2014-11-24 17:04 FirasH Note Added: 0034240
2014-11-24 17:34 JLuc Note Added: 0034241
2014-11-25 22:12 JLuc Note Added: 0034246
2014-11-25 22:13 JLuc Summary 'Paste' not available in table cell => [PATCH tested ok] 'Paste' not available in table cell



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker