Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012141ScribusImport / Exportpublic14-Mar-12 07:0514-Mar-13 23:47
Reporterchristoph_s 
Assigned Tofschmid 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSOpenSUSE 64 BitOS Version13.1
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0012141: Scribus can't open SLA.GZ files anymore
DescriptionTrying to open a SLA.GZ file created with 1.5.0 results in an error message. If this is due to an outdated zlib, the CMake files should be adjusted.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0031503)
jghali (administrator)
14-Mar-12 08:36

Unable to reproduce. If your zlib was too old, you would simply not be able to build.
(0031504)
FirasH (developer)
14-Mar-12 17:33

I tried to reproduce this issue saving as sla.gz and then reopening the document, but for me Scribus didn't have any problem.
Scribus 1.5.0 SVN (18902) - Qt 5.2.1 - zlib 1.2.8
(0031505)
fschmid (administrator)
14-Mar-12 20:42

I can reproduce that behaviour if the resulting .gz file is smaller than 4096 bytes. Try to save a very simple file, e.g containing only one rectangle as .sla.gz. If the file is smaller than 4096 bytes it can't be opened, this seems to be a limitation of the zlib.
(0031510)
christoph_s (administrator)
14-Mar-13 23:47

Tested, fixed. Thanks.

- Issue History
Date Modified Username Field Change
14-Mar-12 07:05 christoph_s New Issue
14-Mar-12 08:36 jghali Note Added: 0031503
14-Mar-12 17:33 FirasH Note Added: 0031504
14-Mar-12 20:42 fschmid Note Added: 0031505
14-Mar-13 22:31 fschmid Status new => resolved
14-Mar-13 22:31 fschmid Fixed in Version => 1.5.0svn
14-Mar-13 22:31 fschmid Resolution open => fixed
14-Mar-13 22:31 fschmid Assigned To => fschmid
14-Mar-13 23:47 christoph_s Note Added: 0031510
14-Mar-13 23:47 christoph_s Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker