Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012347ScribusShape Drawingpublic2014-06-05 13:582014-08-19 21:32
ReporterFirasH 
Assigned Tojghali 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSopenSUSEOS Version13.1
Product Version1.5.0svn 
Target Version1.5.1Fixed in Version1.5.0svn 
Summary0012347: Deleting Bezier Curve nodes leads to wrong result
DescriptionDeleting Bezier Curve nodes, as in the described Steps, leads to wrong result.
Steps To Reproduce0) Create a new document
1) Insert a Bezier Curve (B) with 3 or 4 nodes (reproducible also with more nodes after deleting the redundant nodes)
2) Double-click on the Bezier Curve so that "Nodes" window appears
3) Select "Delete Nodes" and delete one of the 3 or 4 nodes of the Bezier Curve

The Bezier Curve disappers (small red selection rectangle, so its formally still present).
Undo restores properly the edited curve.
Additional InformationScribus 1.5.0 SVN (19180)
Could not reproduce with 1.4.4
TagsNo tags attached.
Patch
Attached Files

- Relationships
related to 0007628new Manipulating a Line/Bezier Curve causes change in XY postition 
related to 0012140closedjghali Convert to > Polygon crashes Scribus in determined condition 
related to 0012608closed Delete Bezier node --> Crash 
related to 0012249closedjghali Deleting Bezier Curve nodes crashes/freezes Scribus in determined condition 

-  Notes
(0032148)
FirasH (developer)
2014-06-13 16:06

Screencast: https://www.dropbox.com/s/u2f9tq4q0hi0u16/12347.mp4 [^]
Download & Watch.
(0032728)
Kunda (manager)
2014-07-14 03:01

Confirmed on r19342
AFAICT, this shows that Belzier curves are broken. Upgrading to 'Major'
(0033284)
FirasH (developer)
2014-08-19 16:01

Thanks jghali!
Fixed in 1.5.0.svn (19430).
(0033290)
Kunda (manager)
2014-08-19 21:32

Can confirm fix

- Issue History
Date Modified Username Field Change
2014-06-05 13:58 FirasH New Issue
2014-06-13 16:06 FirasH Note Added: 0032148
2014-07-14 03:01 Kunda Note Added: 0032728
2014-07-14 03:01 Kunda Severity minor => major
2014-07-14 03:01 Kunda Status new => confirmed
2014-07-14 03:01 Kunda Target Version => 1.5.1
2014-07-14 06:12 Kunda Relationship added related to 0007628
2014-07-29 12:47 FirasH Relationship added related to 0012140
2014-08-15 17:11 FirasH Relationship added related to 0012608
2014-08-15 18:11 FirasH Relationship added related to 0012249
2014-08-19 16:01 FirasH Note Added: 0033284
2014-08-19 16:01 FirasH Status confirmed => resolved
2014-08-19 16:01 FirasH Fixed in Version => 1.5.0svn
2014-08-19 16:01 FirasH Resolution open => fixed
2014-08-19 16:01 FirasH Assigned To => jghali
2014-08-19 21:32 Kunda Note Added: 0033290
2014-08-19 21:32 Kunda Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker