Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012468ScribusUsabilitypublic14-Jul-03 19:0914-Jul-05 18:07
ReporterPeterBenedek 
Assigned Tojghali 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSLinux Mint OS Version17 (32bit)
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.4.5.svn 
Summary0012468: Typing 01 in page selector triggers crash
DescriptionEnvironment: Linux Mint 17
Version: Scribus 1.5.0 (https://launchpad.net/~scribus/+archive/ppa [^] [^])
Language: HU

Number of pages: 01 -> Scribus Crash
Steps To Reproduce1.) Open new document
2.) Write pages number: 01
3.) Enter

Scribus crashhes due Signal 0000006
TagsNo tags attached.
Attached Filespng file icon Page_number_crash.png [^] (16,922 bytes) 14-Jul-03 19:09

- Relationships

-  Notes
(0032445)
FirasH (updater)
14-Jul-03 19:17

Issue present on 1.4.5.svn (19295) and 1.5.0.svn (19309).
(0032446)
FirasH (updater)
14-Jul-03 19:21

Program received signal SIGABRT, Aborted.
0x00007fffef509849 in raise () from /lib64/libc.so.6
(gdb) bt
 0 0x00007fffef509849 in raise ()
   from /lib64/libc.so.6
 1 0x00007fffef50acd8 in abort ()
   from /lib64/libc.so.6
 2 0x00007ffff74168ae in QMessageLogger::fatal(char const*, ...) const ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 3 0x00007ffff7411d74 in qt_assert_x(char const*, char const*, char const*, int) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 4 0x00000000008436e7 in QList<ScPage*>::at (this=0x33f1958, i=1)
    at /home/.../Qt/5.3/gcc_64/include/QtCore/qlist.h:479
 5 0x0000000000cd1c2f in ScribusMainWindow::setCurrentPage (this=0x19cbab0, p=2)
    at /home/.../Scribus/scribus/scribus.cpp:8891
 6 0x000000000078f0b8 in ScribusMainWindow::qt_static_metacall (_o=0x19cbab0, _c=QMetaObject::InvokeMetaMethod, _id=44,
    _a=0x7fffffffc260) at /home/.../Scribus/build/scribus/moc_scribus.cpp:993
 7 0x00007ffff768a7b1 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 8 0x00000000007b2b24 in PageSelector::GotoPage (this=0x1c83130, _t1=2)
    at /home/.../Scribus/build/scribus/ui/moc_pageselector.cpp:169
 9 0x0000000000fb1ee5 in PageSelector::GotoPgE (this=0x1c83130, i=1)
    at /home/.../Scribus/scribus/ui/pageselector.cpp:144
 10 0x00000000007b28de in PageSelector::qt_static_metacall (_o=0x1c83130, _c=QMetaObject::InvokeMetaMethod, _id=5,
    _a=0x7fffffffc460) at /home/.../Scribus/build/scribus/ui/moc_pageselector.cpp:109
 11 0x00007ffff768a7b1 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 12 0x00007ffff6da1671 in QComboBox::activated(int) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 13 0x00007ffff6da2da5 in ?? ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 14 0x00007ffff6dab631 in ?? ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 15 0x00007ffff768a7b1 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 16 0x00007ffff6de32e5 in ?? ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 17 0x00007ffff768a7b1 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 18 0x00007ffff6e7094c in QWidgetLineControl::processKeyEvent(QKeyEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 19 0x00007ffff6dde489 in QLineEdit::keyPressEvent(QKeyEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 20 0x00007ffff6cc5c9d in QWidget::event(QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 21 0x00007ffff6de134a in QLineEdit::event(QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 22 0x00007ffff6da7e5b in QComboBox::keyPressEvent(QKeyEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 23 0x00007ffff6cc5c9d in QWidget::event(QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 24 0x00007ffff6da5319 in QComboBox::event(QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 25 0x00007ffff6c8da94 in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 26 0x00007ffff6c91994 in QApplication::notify(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 27 0x00007ffff7658f04 in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 28 0x00007ffff6ce89f0 in ?? ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 29 0x00007ffff6c8da94 in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 30 0x00007ffff6c910b6 in QApplication::notify(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 31 0x00007ffff7658f04 in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 32 0x00007ffff6504c3a in QGuiApplicationPrivate::processKeyEvent(QWindowSystemInterfacePrivate::KeyEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Gui.so.5
 33 0x00007ffff650cf55 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Gui.so.5
 34 0x00007ffff64f2208 in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Gui.so.5
 35 0x00007fffe548c460 in ?? ()
   from /home/.../Qt/5.3/gcc_64/plugins/platforms/libqxcb.so
 36 0x00007fffecddd316 in g_main_dispatch (context=0x7fffe0001740)
    at gmain.c:3066
 37 g_main_context_dispatch (context=context@entry=0x7fffe0001740)
    at gmain.c:3642
 38 0x00007fffecddd668 in g_main_context_iterate (context=context@entry=0x7fffe0001740, block=block@entry=1,
    dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3713
 39 0x00007fffecddd70c in g_main_context_iteration (context=0x7fffe0001740, may_block=1)
    at gmain.c:3774
 40 0x00007ffff76b3574 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 41 0x00007ffff765711b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 42 0x00007ffff765bfe5 in QCoreApplication::exec() ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 43 0x000000000123ffb0 in mainApp (argc=1, argv=0x7fffffffdd18)
    at /home/.../Scribus/scribus/main_nix.cpp:86
 44 0x000000000123ff40 in main (argc=1, argv=0x7fffffffdd18)
    at /home/.../Scribus/scribus/main_nix.cpp:54
(gdb) continue
Continuing.
Scribus Crash
-------------
Scribus crashes due to Signal 6
Calling Emergency Save

Program received signal SIGSEGV, Segmentation fault.
0x0000000000cd2a20 in ScribusMainWindow::emergencySave (this=0x0) at /home/.../Scribus/scribus/scribus.cpp:9066
9066 QList<QMdiSubWindow *> windows = mdiArea->subWindowList();
(0032456)
jghali (administrator)
14-Jul-03 21:33

The crash is fixed. There is however a Qt bug related to the processing of leading 0 : https://bugreports.qt-project.org/browse/QTBUG-25968. [^] This one is not dependent from us.
(0032494)
FirasH (updater)
14-Jul-05 18:07

Cannot reproduce with 1.4.5.svn (19313) and 1.5.0.svn (19314). Closing.

- Issue History
Date Modified Username Field Change
14-Jul-03 19:09 PeterBenedek New Issue
14-Jul-03 19:09 PeterBenedek File Added: Page_number_crash.png
14-Jul-03 19:16 FirasH Status new => confirmed
14-Jul-03 19:17 FirasH Note Added: 0032445
14-Jul-03 19:21 FirasH Note Added: 0032446
14-Jul-03 21:03 cbradney Assigned To => cbradney
14-Jul-03 21:03 cbradney Status confirmed => assigned
14-Jul-03 21:12 cbradney Assigned To cbradney => jghali
14-Jul-03 21:17 Kunda Target Version => 1.5.0
14-Jul-03 21:27 jghali Summary Page number 01 --> Crash => Typing 01 in page selector triggers crash
14-Jul-03 21:33 jghali Note Added: 0032456
14-Jul-03 21:33 jghali Status assigned => resolved
14-Jul-03 21:33 jghali Fixed in Version => 1.4.5.svn
14-Jul-03 21:33 jghali Resolution open => fixed
14-Jul-05 18:07 FirasH Note Added: 0032494
14-Jul-05 18:07 FirasH Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker