Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012472ScribusGeneralpublic14-Jul-04 17:1614-Jul-08 19:14
ReporterFirasH 
Assigned Tojghali 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSopenSUSEOS Version13.1
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0012472: Changing from Single Page to Double Page layout may lead to crash
DescriptionChanging from Single Page to Double Page layout may lead to crash.
Steps To ReproduceDidn't find specific steps (I reproduced it testing with a new doc 3-4 times), but the issue can be always reproduced with the attached document.

Basically I created a Single Page document, then working on it I decided to change it Double Page. The document was created in various sessions, so I closed and reopened Scribus more times.

0) Open the attached document
1) Open the "Preflight Verifier"
2) Double-click on Page 4 > Applied master page has ...
3) Go to: Edit > Master Pages
Under Arrange Pages you can notice that there is an empty space then Normal.

4) Double-click on the empty space, type some characters, then press enter
Scribus crashes due to Signal 6
Additional InformationScribus 1.5.0.svn (19314)


ASSERT: "MasterPages.at(number)->pageName()==oldPageName" in file /home/.../Scribus/scribus/scribusdoc.cpp, line 2676

Program received signal SIGABRT, Aborted.
0x00007fffef509849 in raise () from /lib64/libc.so.6
(gdb) bt
 0 0x00007fffef509849 in raise ()
   from /lib64/libc.so.6
 1 0x00007fffef50acd8 in abort ()
   from /lib64/libc.so.6
 2 0x00007ffff74168ae in QMessageLogger::fatal(char const*, ...) const ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 3 0x00007ffff7411d11 in qt_assert(char const*, char const*, int) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 4 0x0000000000d124ee in ScribusDoc::renameMasterPage (this=0x3453a70, oldPageName=..., newPageName=...)
    at /home/.../Scribus/scribus/scribusdoc.cpp:2676
 5 0x0000000000faccca in PagePalette_MasterPages::renameMasterPage (this=0x2f66a30, item=0x3488e90)
    at /home/.../Scribus/scribus/ui/pagepalette_masterpages.cpp:504
 6 0x00000000007b167b in PagePalette_MasterPages::qt_static_metacall (_o=0x2f66a30, _c=QMetaObject::InvokeMetaMethod, _id=7,
    _a=0x7fffffffcbf0) at /home/.../Scribus/build/scribus/ui/moc_pagepalette_masterpages.cpp:111
 7 0x00007ffff768a7b1 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 8 0x00007ffff6f3a7e2 in QListWidget::itemChanged(QListWidgetItem*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 9 0x00007ffff768a7b1 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 10 0x00007ffff770729c in QAbstractItemModel::dataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 11 0x00007ffff6f3ce65 in ?? ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 12 0x00007ffff6f3db0b in QListWidgetItem::setData(int, QVariant const&) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 13 0x00007ffff6f3b398 in ?? ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 14 0x00007ffff6f673de in QStyledItemDelegate::setModelData(QWidget*, QAbstractItemModel*, QModelIndex const&) const ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 15 0x00007ffff6edfca2 in QAbstractItemView::commitData(QWidget*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 16 0x00007ffff6ee0792 in ?? ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 17 0x00007ffff768a7b1 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 18 0x00007ffff7026e8f in QAbstractItemDelegate::commitData(QWidget*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 19 0x00007ffff6f66f4a in ?? ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 20 0x00007ffff768c8f6 in QObject::event(QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 21 0x00007ffff6c8da94 in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 22 0x00007ffff6c910b6 in QApplication::notify(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 23 0x00007ffff7658f04 in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 24 0x00007ffff765ba88 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 25 0x00007ffff76b3143 in ?? ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 26 0x00007fffecddd316 in g_main_dispatch (context=0x7fffe0001740)
    at gmain.c:3066
 27 g_main_context_dispatch (context=context@entry=0x7fffe0001740)
    at gmain.c:3642
 28 0x00007fffecddd668 in g_main_context_iterate (context=context@entry=0x7fffe0001740, block=block@entry=1,
    dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3713
 29 0x00007fffecddd70c in g_main_context_iteration (context=0x7fffe0001740, may_block=1)
    at gmain.c:3774
 30 0x00007ffff76b3574 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 31 0x00007ffff765711b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 32 0x00007ffff765bfe5 in QCoreApplication::exec() ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 33 0x000000000123ff28 in mainApp (argc=1, argv=0x7fffffffdd18)
    at /home/.../Scribus/scribus/main_nix.cpp:86
 34 0x000000000123feb8 in main (argc=1, argv=0x7fffffffdd18)
    at /home/.../Scribus/scribus/main_nix.cpp:54
(gdb) continue
Continuing.
Scribus Crash
-------------
Scribus crashes due to Signal 6
Calling Emergency Save

Program received signal SIGSEGV, Segmentation fault.
0x0000000000cd2a20 in ScribusMainWindow::emergencySave (this=0x0) at /home/.../Scribus/scribus/scribus.cpp:9066
9066 QList<QMdiSubWindow *> windows = mdiArea->subWindowList();
TagsNo tags attached.
Attached Files? file icon MasterPageCrash.sla [^] (16,275 bytes) 14-Jul-04 17:16

- Relationships

-  Notes
(0032484)
Kunda (manager)
14-Jul-05 02:11

Can exactly reproduce crash according to instructions on r19309
(0032560)
jghali (administrator)
14-Jul-07 23:18

I fixed the crash. However if you can find how pages can get empty master page names, that would be nice. Please open another issue if you do.
(0032585)
Kunda (manager)
14-Jul-08 15:28

Confirmed that there is no 'ghost' (empty) master page like before. FirasH, can you reproduce how you got an empty master page?
(0032594)
FirasH (developer)
14-Jul-08 19:14

Thanks jghali!
Scribus 1.5.0.svn (19331): cannot reproduce the crash.
If I find generic steps I'll add them in a new report.
Closing.

- Issue History
Date Modified Username Field Change
14-Jul-04 17:16 FirasH New Issue
14-Jul-04 17:16 FirasH File Added: MasterPageCrash.sla
14-Jul-05 02:11 Kunda Note Added: 0032484
14-Jul-05 02:11 Kunda Status new => confirmed
14-Jul-05 02:12 Kunda Target Version => 1.5.0
14-Jul-07 23:18 jghali Note Added: 0032560
14-Jul-07 23:18 jghali Status confirmed => resolved
14-Jul-07 23:18 jghali Fixed in Version => 1.5.0svn
14-Jul-07 23:18 jghali Resolution open => fixed
14-Jul-07 23:18 jghali Assigned To => jghali
14-Jul-08 15:28 Kunda Note Added: 0032585
14-Jul-08 19:14 FirasH Note Added: 0032594
14-Jul-08 19:14 FirasH Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker