Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012546ScribusUndo/Redopublic14-Jul-21 18:1814-Jul-31 00:25
ReporterFirasH 
Assigned Tojghali 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSFreeBSDOS Version10.0.2
Product Version1.5.0svn 
Target Version1.5.1Fixed in Version1.4.5.svn 
Summary0012546: Undo button might be disabled closing Nodes window
DescriptionUndo button might be disabled closing Nodes window.
Steps To Reproduce0) Create a new document
1) Insert a item that has nodes (example: Shape, Bezier Curve, Freehand Line
2) Double-click on the Freehand Line (Nodes windows opens)
3) Close Nodes window

Undo button is not clickable (you need to use Windows > Action History).
It is clickable if a change is applied to the Nodes.
Additional InformationScribus 1.5.0.svn (19357)
TagsNo tags attached.
Attached Files

- Relationships
child of 0012500acknowledged Metabug: Undo/Redo (1.5.0.svn) 

-  Notes
(0032884)
Kunda (developer)
14-Jul-21 18:26

Firash, you mean the yellow undo arrow is disabled?
Or that undo should re-open node window?
Undo keyboard shortcut (cmd+z) works.
(0032887)
FirasH (updater)
14-Jul-21 18:31

The Undo button in the toolbar (Edit > Undo is the same).
(0032888)
Kunda (developer)
14-Jul-21 18:45

OSX 10.8.5. 1.5.0svn r19357
can't reproduce. made a screencast
https://www.dropbox.com/s/92ry5agmrqqtg4y/undo%20-%20Broadband.m4v [^]
(0032895)
FirasH (updater)
14-Jul-22 00:14

I reproduced the bug with Qt 5.2.1 on FreeBSD, but could not with Qt 5.3.1 on openSUSE.
I investigated a bit and ended up with the following:

0) Create a new document and make sure Windows > Outline is opened
1) Insert a Shape (S)
2) From Windows > Outline double-click on the Shape entry (Nodes window opens)
3) Close Nodes window with ESC or OK or X button (not Cancel)

Undo button is greyed out.
(0032896)
FirasH (updater)
14-Jul-22 00:49

Also 1.4.5.svn (19345) has the issue described in the report.
(0032897)
Kunda (developer)
14-Jul-22 01:03

Wow, nice.
Confirmed on OSX 10.8.5. 1.5.0svn r19357 based on 0012546:0032895
(0033103)
FirasH (updater)
14-Jul-31 00:25

Thanks jghali!
Fixed in 1.4.5.svn (19389) and 1.5.0.svn (19390).

- Issue History
Date Modified Username Field Change
14-Jul-21 18:18 FirasH New Issue
14-Jul-21 18:19 FirasH Relationship added child of 0012500
14-Jul-21 18:26 Kunda Note Added: 0032884
14-Jul-21 18:31 FirasH Note Added: 0032887
14-Jul-21 18:45 Kunda Note Added: 0032888
14-Jul-22 00:14 FirasH Note Added: 0032895
14-Jul-22 00:49 FirasH Note Added: 0032896
14-Jul-22 01:03 Kunda Note Added: 0032897
14-Jul-22 01:03 Kunda Status new => confirmed
14-Jul-22 01:03 Kunda Target Version => 1.5.1
14-Jul-30 23:25 jghali Status confirmed => resolved
14-Jul-30 23:25 jghali Fixed in Version => 1.4.5.svn
14-Jul-30 23:25 jghali Resolution open => fixed
14-Jul-30 23:25 jghali Assigned To => jghali
14-Jul-31 00:25 FirasH Note Added: 0033103
14-Jul-31 00:25 FirasH Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker