Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012563ScribusUsabilitypublic2014-07-27 18:392014-10-14 22:07
ReporterPeterBenedek 
Assigned Tocbradney 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSLinux Mint OS Version17 (32bit)
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version 
Summary0012563: Crash when copy/pasting text box in conjunction with invoking Story Editor
DescriptionSample documents are included.
Document textbox copied, pasted, deleted causes a crash.
Special characters causes it?

Link this video: https://www.dropbox.com/s/o64ospdh8vhhcof/TextBox_Copy_Crash.avi [^]
Steps To Reproduce1) Open document.
2) Click textbox.
3) CTRL + C
4) CTRL + V
5) Click Story Editor icon in icon menu.
6) Close Story Editor.
7) CTRL + V
8) Click Story Editor icon in icon menu.
9) Close Story Editor.
10) Repeat steps 7-9 for 4 to 10 more times

Crashes Signal 11
TagsNo tags attached.
Patch
Attached Files? file icon Dokumentum-8.sla [^] (14,960 bytes) 2014-07-27 18:39

- Relationships

-  Notes
(0033044)
Kunda (manager)
2014-07-27 21:00

Can reproduce on OSX 10.8.5 1.5svn r19374
Also edited the report for further clarity.
(0033898)
cbradney (administrator)
2014-10-05 22:46
edited on: 2014-10-05 22:47

Unable to reproduce on r19551 on OSX, I can get to over 20 textboxes without an issue.

(0033899)
JLuc (updater)
2014-10-05 23:00

unable to reproduce too.
(0033904)
Kunda (manager)
2014-10-06 00:37

Cannot reproduce anymore on OSX 10.9.5 1.5.0svn r19552 (Qt5.3.2)

- Issue History
Date Modified Username Field Change
2014-07-27 18:39 PeterBenedek New Issue
2014-07-27 18:39 PeterBenedek File Added: Dokumentum-8.sla
2014-07-27 21:00 Kunda Note Added: 0033044
2014-07-27 21:00 Kunda Summary Special text box. => Crash when copy/pasting text box in conjunction with invoking Story Editor
2014-07-27 21:00 Kunda Steps to Reproduce Updated View Revisions
2014-07-27 21:00 Kunda Status new => confirmed
2014-07-27 21:00 Kunda Target Version => 1.5.0
2014-07-27 21:01 Kunda Steps to Reproduce Updated View Revisions
2014-09-11 04:34 Kunda Severity crash => block
2014-10-05 22:46 cbradney Note Added: 0033898
2014-10-05 22:47 cbradney Note Edited: 0033898 View Revisions
2014-10-05 23:00 JLuc Note Added: 0033899
2014-10-06 00:37 Kunda Note Added: 0033904
2014-10-06 00:38 Kunda Status confirmed => resolved
2014-10-06 00:38 Kunda Resolution open => fixed
2014-10-06 00:38 Kunda Assigned To => cbradney
2014-10-14 22:07 cbradney Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker