Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012585ScribusUser Interfacepublic2014-08-01 23:202014-10-08 01:23
ReporterKunda 
Assigned Tocbradney 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.5.0svn 
Target VersionFixed in Version1.5.0svn 
Summary0012585: [TESTED-PATCH] Statustip missing for Preview Quality & Visual Appearance
DescriptionStatustips missing for:
Preview Quality
Visual Appearance
Steps To Reproduce0) Launch Scribus, no opened document is necessary
1) Move the mouse pointer over the tools in the screenshot

No statustip is shown in the lower-left part of the UI as with the other tools.
Additional InformationScribus 1.5.0.svn (19393)
TagsNo tags attached.
Patch
Attached Filespng file icon toolbar.png [^] (11,870 bytes) 2014-08-01 23:20


patch file icon actionmanager.cpp.patch [^] (1,840 bytes) 2014-08-01 23:54 [Show Content]
diff file icon 12585.diff [^] (632 bytes) 2014-09-29 14:10 [Show Content]

- Relationships
related to 0012501closedjghali [TESTED-PATCH] Tooltip missing for Barcode 

-  Notes
(0033140)
FirasH (developer)
2014-08-01 23:55
edited on: 2014-08-01 23:56

Added .patch with status tooltip for Toggle CMS, Preview Mode, Edit in Preview Mode.
(Includes the .patch of 12501)

(0033165)
Kunda (manager)
2014-08-04 01:14

The patch commit r19394 successfully committed most of the missing statusbar tooltips except:
Preview Quality
Visual Appearance

Also from ticket 0012501 statusbar tooltip missing:
Barcode
(0033211)
Kunda (manager)
2014-08-08 21:10

2 statusbar tooltips still incomplete:
Preview Quality
Visual Appearance
(0033347)
Kunda (manager)
2014-08-25 18:17

Barcode tooltip resolved (0012501)
Just this issue still remains now.
(0033838)
gpittman (developer)
2014-09-26 17:57

Seems to be fixed, not sure when.
(0033839)
Kunda (manager)
2014-09-26 19:12

gpittman, no in the latest revision 19541
I'm wondering if you read the bug report correctly.
The tooltips for: 'Preview Quality' and 'Visual Appearance' work but NOT in the tooltips in the lower left status bar.
(0033841)
gpittman (developer)
2014-09-26 21:47

Since I don't have any icons for these functions in the lower status bar, why would I have tooltips there?
These icons are in the toolbar, and have tooltips.
(0033842)
Kunda (manager)
2014-09-27 05:15

I see. So it sounds like you don't see the utility in having those 2 non-icons having status bar tooltips. Personally, I'm OK with either decision: with or without a status bar tooltip. What do others think ?
(0033845)
FirasH (developer)
2014-09-29 14:08

Tested and attached the fix for Preview Quality and Visual Appearance.
(0033907)
Kunda (manager)
2014-10-06 01:06

Please apply patch. Thanks!
(0033924)
Kunda (manager)
2014-10-08 01:16

Patch committed in r19555. Thanks Craig and FirasH!

- Issue History
Date Modified Username Field Change
2014-08-01 23:20 Kunda New Issue
2014-08-01 23:20 Kunda File Added: toolbar.png
2014-08-01 23:20 Kunda Issue generated from: 0012501
2014-08-01 23:20 Kunda Tag Attached: tooltips
2014-08-01 23:24 FirasH Relationship added related to 0012501
2014-08-01 23:31 Kunda Summary [PATCH] Tooltips missing for Toolbar icons (Preview Mode etc..) => Tooltips missing for Toolbar icons (Preview Mode etc..)
2014-08-01 23:54 FirasH File Added: actionmanager.cpp.patch
2014-08-01 23:55 FirasH Note Added: 0033140
2014-08-01 23:56 FirasH Note Edited: 0033140 View Revisions
2014-08-01 23:57 FirasH Status new => confirmed
2014-08-01 23:57 FirasH Summary Tooltips missing for Toolbar icons (Preview Mode etc..) => [PATCH] Tooltips missing for Toolbar icons (Preview Mode etc..)
2014-08-02 10:14 cbradney Status confirmed => resolved
2014-08-02 10:14 cbradney Fixed in Version => 1.5.0svn
2014-08-02 10:14 cbradney Resolution open => fixed
2014-08-02 10:14 cbradney Assigned To => cbradney
2014-08-04 01:14 Kunda Note Added: 0033165
2014-08-08 21:10 Kunda Note Added: 0033211
2014-08-08 21:10 Kunda Status resolved => confirmed
2014-08-08 21:13 Kunda Summary [PATCH] Tooltips missing for Toolbar icons (Preview Mode etc..) => [PATCH] Tooltips missing for Toolbar icons (Preview Quality & Visual Appearance)
2014-08-08 21:13 Kunda Description Updated View Revisions
2014-08-25 18:17 Kunda Note Added: 0033347
2014-09-26 17:57 gpittman Note Added: 0033838
2014-09-26 19:12 Kunda Note Added: 0033839
2014-09-26 21:47 gpittman Note Added: 0033841
2014-09-27 05:15 Kunda Note Added: 0033842
2014-09-29 14:08 FirasH Note Added: 0033845
2014-09-29 14:10 FirasH File Added: 12585.diff
2014-09-29 14:10 FirasH Summary [PATCH] Tooltips missing for Toolbar icons (Preview Quality & Visual Appearance) => [TESTED PATCH] Tooltips missing for Toolbar icons (Preview Quality & Visual Appearance)
2014-09-29 14:20 FirasH Summary [TESTED PATCH] Tooltips missing for Toolbar icons (Preview Quality & Visual Appearance) => [TESTED-PATCH] Statustip missing for Preview Quality & Visual Appearance
2014-09-29 14:20 FirasH Description Updated View Revisions
2014-09-29 14:20 FirasH Steps to Reproduce Updated View Revisions
2014-10-06 01:06 Kunda Note Added: 0033907
2014-10-07 22:40 cbradney Status confirmed => resolved
2014-10-08 01:16 Kunda Note Added: 0033924
2014-10-08 01:16 Kunda Status resolved => closed
2014-10-08 01:23 Kunda Tag Detached: tooltips



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker