Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001990ScribusUser Interfacepublic2005-05-15 14:222010-05-26 11:10
ReporterHoward White 
Assigned Tocbradney 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
Platformn/aOSOS Version
Product Version1.3.0cvs 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0001990: Improved control of Page Size menu
DescriptionDropdown menu in 1.3.0 contains 0000075:0000060 page sizes, many of which ("Elephant", "Foolscap") are not likely to be used by many. This menu is unwieldy.
Further, it is not possible to save user-defined page sizes.
Steps To Reproducen/a
Additional InformationProposed:
Creation of "Page Size" sets, analogous to Keyboard Shortcut Sets. The user would be able to:

1. Create a set or sets containing only sizes he is likely to use.
2. Add to sets custom, user-defined and user-named sizes.

TagsNo tags attached.
Patch
Attached Filesjpg file icon macuglyness.jpg [^] (60,669 bytes) 2005-05-16 08:43


jpg file icon newdoclinux.jpg [^] (26,923 bytes) 2005-05-16 08:44

- Relationships
has duplicate 0006945closedcbradney Better organisation of the list of pre-set sizes in New Document > Document layout > Size 
child of 0003821acknowledged Metabug: Usability 

-  Notes
(0004661)
cbradney (administrator)
2005-05-16 08:45
edited on: 2005-05-16 08:46

If this is the reason (see macuglyness.jpg) then either Qt/Mac has problems or the Mac GUI has problems. This is a serious usability issue, consider the newdoclinux.jpg. The combobox operates as expected on Linux, not filling the whole screen with the list. No wonder you want this fixed for Mac, however, I think there are other issues to be fixed elsewhere!!!!

(0019472)
louisdesjardins (developer)
2008-04-13 15:57

As per the long note I put on the (unfortunately) duplicate bug entry I made, I agree 100% with Howard White.

Moreover, giving a look at
http://en.wikipedia.org/wiki/Paper_size [^]
reveals that although the actual list in Scribus seems comprehensive (to an extent that goes way beyond the average needs of users), it isn’t in fact! If we put those Grand Jésus and Petit écolier, then we surely need the Japanese B-series variant, the Architectural sizes and all the Other size we can find on this well-documented page, do we?

Meanwhile we can make this small correction:

Actual figures
Grand Jésus 58,4200 cm X 71,1200 cm
Format écolier 33,0200 cm X 20,3200 cm

Figures as we find them here
http://fr.wikipedia.org/wiki/Format_de_papier#Formats_fran.C3.A7ais [^]
* Écolier : 31 cm X 40 cm
* Jésus : 56 cm X 76 cm

And here for variants of Jésus
http://fr.wikipedia.org/wiki/J%C3%A9sus_%28papier%29 [^]
* Petit Jésus, ou Jésus de musique : 55 × 70 cm
* Jésus : 56 × 72 cm
* Grand Jésus : 56 × 76 cm

- Issue History
Date Modified Username Field Change
2005-05-15 14:22 Howard White New Issue
2005-05-15 15:03 cbradney Status new => assigned
2005-05-15 15:03 cbradney Assigned To => cbradney
2005-05-16 08:43 cbradney File Added: macuglyness.jpg
2005-05-16 08:44 cbradney File Added: newdoclinux.jpg
2005-05-16 08:45 cbradney Note Added: 0004661
2005-05-16 08:46 cbradney Note Edited: 0004661
2006-05-15 20:20 christoph_s Relationship added child of 0003821
2008-04-12 19:46 cbradney Relationship added has duplicate 0006945
2008-04-13 15:57 louisdesjardins Note Added: 0019472
2008-04-15 21:59 cbradney Target Version => 1.3.6
2010-05-25 02:02 cbradney Status assigned => resolved
2010-05-25 02:02 cbradney Fixed in Version => 1.5.0svn
2010-05-25 02:02 cbradney Resolution open => fixed
2010-05-26 11:10 cbradney Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker