Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002167ScribusInternalpublic2005-06-30 17:532005-10-02 23:02
Reporterringerc 
Assigned Tofschmid 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
Platformx86 LinuxOSFedora CoreOS Version3
Product Version1.3.0cvs 
Target VersionFixed in Version1.3.1cvs 
Summary0002167: Spot colours
DescriptionSupport for spot colours is important for many people to get full use out of Scribus. There are work arounds right now (wiki.scribus.net/index.php/Simple_Scribus_Spot_Colour_Printing_method) but they're not exactly convenient.

If we support multiple colour formats in future, say CMYK, RGB, RGBA, etc, we could also support "named colours" that have a viewing/printing colour associated with them but are distinct from normal multi-channel colours. In other words, spot colours.

Once we support real spot colours in the app's internal colour model, we could extend this to support true spot colours in TIFF, PS, EPS, PDF and PSD imports and exports.

There's still the PANTONE issue to consider, but I'm not sure that matters too much - I don't think anything requires our spot colour names to be PANTONE ones, or stops us offering user defined named colours so the user can import whatever they want.
TagsNo tags attached.
Patch
Attached Files

- Relationships
related to 0000612closedfschmid the order of the colors 
related to 0002322closedfschmid Rename CMYKColor to ScColor 
related to 0002705closedplinnell Spot Color Seperations are not working 

-  Notes
(0005285)
ringerc (administrator)
2005-06-30 17:56

A useful conversation on #ghostscript that I jumped into when I noticed it was about spot colour in gs:

stefan911 Gigs2: thanks
Gigs2 stefan911: this is a serious one for us, if we use parentheses it limits us to 4 colors, if we don't use them, we can't have colors like "Dark Blue" so our development is effectively stalled
ringerc Hmm ... support for > 4 colours in gs? Is this related to spot colour?
ringerc If so, this is something I'm interested in knowing more about re gs as well.
Gigs2 ringerc: yes, tiffsep device supports up to colors, 4 spot colors and CMYK
stefan911 I thought spot colors used pantone numbers or other ink system #'s rather than names like dark blue, tells you what I know
Gigs2 stefan911: they usually do
Gigs2 stefan911: but "Pantone 121 CV" still need parentheses
adcoby gigs: For spot color names, use either parenthesis (i.e a PostScript string) or a leading slash (i.e. a PostScript name). Do not do both for a single colorant.
Gigs2 adcoby: ah, excellent
Gigs2 adcoby: I was hoping it was somthing stupid
Gigs2 thanks
ringerc Gigs2: That's great. Seems to be in 8.51 too. Now I need to look into what's involved in producing gs-friendly spot colour PS from Scribus.
Gigs2 cool
adcoby In Postscript and PDF, spot colors are defined using the Separation and DeviceN color spaces.
adcoby In Ghostscript, only a few output formats support anything besides Gray, RGB, or CMYK.
ringerc Good to know.
adcoby For these devices, spot colors are converted to Gray, RGB, or CMYK by using the tint trasnform function in the color space.
Gigs2 adcoby: psd format will carry spots through right?
adcoby The psdcmyk and tiffsep devices, produce output that actually has the spot color info.
Gigs2 adcoby: closing bug, thanks
ringerc Mind if I note this conversation on the scribus bug tracking spot colour?
ringerc You folks know some useful things :-)
ringerc eh, don't worry ... should just note the important info anyway.
Gigs2 I don't care
Gigs2 you can copy my bug report, it notes the syntax to select spot colors
adcoby please do what you want with the text here.
ringerc Thanks.
Gigs2 bug 688178 for gs
Gigs2 that contains a lot about the correct way to select spot colors for output
Gigs2 and how not to do it :)
(0005286)
ringerc (administrator)
2005-06-30 17:58
edited on: 2005-06-30 17:59

http://bugs.ghostscript.com/show_bug.cgi?id=688178 [^]

(0005583)
mhanski (developer)
2005-07-14 09:39

it seems, fup.de is willing to pay for this feature, see this mail:

nashi.altmuehlnet.de/pipermail/scribus/2005-July/011987.html

- Issue History
Date Modified Username Field Change
2005-06-30 17:53 ringerc New Issue
2005-06-30 17:56 ringerc Note Added: 0005285
2005-06-30 17:57 ringerc Status new => acknowledged
2005-06-30 17:58 ringerc Relationship added related to 0000612
2005-06-30 17:58 ringerc Note Added: 0005286
2005-06-30 17:59 ringerc Note Edited: 0005286
2005-06-30 19:35 mhanski Description Updated
2005-07-14 09:39 mhanski Note Added: 0005583
2005-08-22 01:02 fschmid Status acknowledged => resolved
2005-08-22 01:02 fschmid Fixed in Version => 1.3.1cvs
2005-08-22 01:02 fschmid Resolution open => fixed
2005-08-22 01:02 fschmid Assigned To => fschmid
2005-09-17 09:30 ringerc Relationship added related to 0002322
2005-10-02 23:02 plinnell Status resolved => closed
2005-10-10 08:18 ringerc Relationship added related to 0002705



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker