Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000315ScribusUser Interfacepublic2004-03-03 10:132005-10-29 22:38
Reporterprokoudine 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.3.2cvs 
Summary0000315: Document navigation improvements
Description1. Zooming a document by Shift/Ctrl + mouse scroll.

2. Panning a document by holding mouse wheel pushed down (as a button) and moving around.
TagsNo tags attached.
Patch
Attached Files

- Relationships
has duplicate 0000327closedcbradney pan = click & drag mouse wheel 

-  Notes
(0000633)
prokoudine (reporter)
2004-03-03 10:24

OK, an improvement to this feature reqest

shift+scroll=page down

ctrl+scroll=zoom

middle click = pan
(0000634)
cbradney (administrator)
2004-03-03 10:28

sounds reasonable.

Franz: would it be possible to give a way for the user to assign these? like the keyboard shortcuts are?
(0000638)
fschmid (administrator)
2004-03-04 00:42

You can zoom in or out with pressing the wheel and rotating the wheel.
(0000643)
cbradney (administrator)
2004-03-04 00:46

Yes, they didnt like that because pressing and scrolling is apparently difficult.
(0000948)
prokoudine (reporter)
2004-04-07 15:23

The second part of this feature request is luckily overriden by 0000431
(0001581)
mega (reporter)
2004-05-26 09:15

There are requests for improve ZOOM tool with MouseWheel. I make next one. Zooming with Ctrl+Wheel is so much intuitive, it make work with document quicker.

I think, Ctrl+Wheel should be enabled to all tools (as in other programs), not only if zoom tool is active. There is no reason to make this possible only for zoom tool.
(0003266)
alexandre (developer)
2004-12-28 17:36

And please add a zoom tool similar to GIMP's one. The current one isn't easy to use.

- Issue History
Date Modified Username Field Change
2004-03-03 10:13 prokoudine New Issue
2004-03-03 10:24 prokoudine Note Added: 0000633
2004-03-03 10:28 cbradney Note Added: 0000634
2004-03-04 00:42 fschmid Note Added: 0000638
2004-03-04 00:46 cbradney Note Added: 0000643
2004-03-08 02:29 cbradney Relationship added has duplicate 0000327
2004-04-07 15:23 prokoudine Note Added: 0000948
2004-04-07 16:36 cbradney Category General => User Interface
2004-05-26 09:15 mega Note Added: 0001581
2004-12-28 17:36 alexandre Note Added: 0003266
2005-10-29 22:34 plinnell Status new => closed
2005-10-29 22:34 plinnell Resolution open => fixed
2005-10-29 22:34 plinnell Fixed in Version => 1.3.2cvs
2005-10-29 22:38 plinnell Status closed => resolved
2005-10-29 22:38 plinnell Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker