Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003291ScribusUser Interfacepublic06-Feb-25 14:2608-May-04 00:19
Reportermhanski 
Assigned Toplinnell 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionno change required 
PlatformallOSallOS Versionall
Product Version1.3 
Target VersionFixed in Version 
Summary0003291: Preferences>General: Font face setting needed
DescriptionPlease include font face settings for menus and palettes into Preferences>General (mock up attached)
Additional Informationcurrently we have to use qtconfig to achieve this in non-KDE environments (Gnome, XFCE,..), otherwise Scribus can pick up an inappriopriate font -- I've already experienced this on Ubuntu and with Live DTP CD. This small change would free Scribus from this the-facto dependency.
TagsNo tags attached.
Attached Filespng file icon prefences_general_with_font_face.png [^] (54,890 bytes) 06-Feb-25 14:26


png file icon european_desktop_chinese_scribus.png [^] (33,801 bytes) 06-Apr-11 16:09

- Relationships
related to 0003967closedfschmid Preferences/General: Font size setting for Palette titles needed 
related to 0003983closedjghali scribus does not respect the windows ui font but uses its own 
related to 0002464acknowledged Metabug: GUI appearance 
related to 0002751closed Scribus and Gnome: setting GUI font size and encoding 
related to 0003816closedcbradney Preferences/Tools: Add appriopriate titles for subsections 
related to 0004423closedcbradney Metabug: Ubuntu/Kubuntu issues that prevent it from being the perfect platform for Scribus 
child of 0003821acknowledged Metabug: Usability 

-  Notes
(0008916)
cbradney (administrator)
06-Feb-26 09:17

Why should it be up to us to fix distros' problems? They should learn to package things correctly.
(0008918)
mhanski (developer)
06-Feb-26 11:33

hmm..,this is not about fixing some distros problems (this has nothing to do with a distro, but with different desktop environments).

This is about adding some more usability to the Scribus GUI and making Scribus a better, more DE/distro/OS independent application. There already are font size settings for menus and palettes, adding font face to them would additionally allow e.g. a Chinese, or Russian, or Polish user to switch to an appriopriate font face containing their national glyphs, if they decide to switch Scribus to other language than their desktop environment language and don't want to see lots of squares.

Hope this helps to clarify my reasons :)
(0008919)
mhanski (developer)
06-Feb-26 11:38
edited on: 06-May-14 01:49

Reminder sent to: ringerc

ringerc, I'm adding you to this rfe, because we've already discussed some of the problems in RFE 0002751

(0008921)
cbradney (administrator)
06-Feb-26 13:50

I don't see why we should have to produce this (while it is easy), when the distros should be packaging qtconfig for users to config their apps, AS WELL AS those distros providing a decent initial setup for them, particularly the Gnome based ones. I'm not sure I see why one use would want to have one font for the GUI and therefore support for native glyphs and not have them in their other apps.
(0008922)
mhanski (developer)
06-Feb-26 14:28

- case 1 (real life): my win desktop at work is German, because i live and work in Austria, I want to have Scribus in Polish (russian, chinese), without reconfiguring the whole desktop

- case 2 (real life): translating the GUI: i can switch the lang from within the Scribus with the great feature of yours :), but I have to go to qtconfig to switch the fonts to actually see the national glyphs -- why shouldn't it be done easier?
(0008923)
cbradney (administrator)
06-Feb-26 14:38

Ok, I can agree with case 1, but as you are not Austrian, why not run your desktop in Polish?

I'm not sure how real life case 2 is for non translators tho.. maybe it is, maybe not.
(0009807)
ringerc (administrator)
06-Apr-11 15:45

This should not be necessary. Qt does, or should do, glyph substitution when glyphs are unavailable in the primary selected font. Is this not happening in your environment?
(0009809)
mhanski (developer)
06-Apr-11 16:13

ringerc,i've uploaded a screenshot of my win32 desktop to demonstrate one of the situations, where the possibility to choose the Scribus GUI font would be very useful (see euroepean_desktop_chinese_scribus.png). Understandably, such language combinations can be plenty :)
(0009811)
ringerc (administrator)
06-Apr-11 21:04

IMO that's a Qt issue, possibly a Qt bug. Qt is supposed to do glyph substitution to ensure that text in the UI can be displayed correctly. It is evidently not doing that correctly on win32 (maybe trying too hard to use native menus etc when they lack the needed functionality?).

Scribus should not need to add extra preferences to accomplish this. The right behavior is for an appropriate font to be used automatically, preferably with glyph substitution done where required. Adding preferences should be a last resort if no better fix can be found.
(0009814)
mhanski (developer)
06-Apr-11 21:38

I've seen this 3 times so far:
-- ubuntu with gnome, where pl glyphs where replaced by squares, although the gnome desktop was pl ans system wide fonts were installed (running qtconfig solved this)

-- live dtp cd (same behaviour, fonts with pl glyphs available, but i couldn't point Scribus to them)

-- now win32 with rather exotic fonts:)

ringerc, even if this is a qt issue, you are assuming, that the system wide font containing the missing glyphs is available (which needn't be a case, this could be a font from user's home order) and that qt knows for better which glyphs to use as replacement (what i saw on ubuntu, was rather horrible). I would suggest, let qt do this job, but if it fails, give the user the opportunity to correct it to his taste.
(0013155)
sladen (reporter)
06-Oct-28 22:49

Could somebody provide an example of what 'qtconfig' is changing; for instance, their before and after versions of '/etc/qt.rc' or similar file.

If Scribus isn't coming with sane configuration defaults out-of-the-box in Ubuntu, then that's a bug and we'd like to fix it in Ubuntu. (A user should not have to configure their software in order to make it useful!).

AFAICT 'qtconfig' is not more of a control panel of customisation utility; can we an intelligent that this utility might produce included by default?

Could somebody confirm that this bug is actually about whether the Qt font rendering services perform "glyph substitution" for missing characters automatically.
(0013156)
cbradney (administrator)
06-Oct-28 22:56

a) qtconfig should be included in the qt package on debian and ubuntu so users with qt apps can configure them to look like their gnome interface, or the configuration of the gui should have an option to apply the settings to qt based apps too.
b) this bug has nothing to do with glyph substition, it is about providing a decent GUI for pure Qt apps on debian and Ubuntu without the user needing to configure them.
c) Yes you could probably include a decent qtrc to set the fonts as appropriate based on the selected ones in gnome however when the user changes them, they need to be able to change them for qt apps too.
(0013158)
mhanski (developer)
06-Oct-28 23:50
edited on: 06-Oct-28 23:51

Reminder sent to: plinnell

Peter, you've got a still untouched stock Ubuntu, I presume -- could you provide here an example of /etc/qt.rc before and after a decent facelift with qtconfig? Paul Sladen would need the latter to incude it into Ubuntu.

I can't do it myself, I'm on Kubuntu.

(0019574)
plinnell (administrator)
08-Apr-30 16:14

Ok, with a fresh install of Hardy in VM with KDE4, everything works perfectly and I can use non-Latin fonts, and starting Scribus in Polish, along with other Latin2 langs works fine.

That said, I maintain, along with cbradney that this is a missing dependency on ubuntu when Scribus is installed. Here is the description from synaptic:
(0019575)
plinnell (administrator)
08-Apr-30 16:15

The Qt3 Configuration Application
The Qt Configuration program allows end users to configure the look
and behavior of any Qt3 application. It is mostly only necessary
on systems which don't run KDE because the KDE control center already
covers this configuration automatically for the users Qt3 applications
according to his desktop settings in KDE. However, if you need to run
CJK-fonts or other non-latin scripts, you will most likely want to
install this package.
(0019576)
sladen (reporter)
08-Apr-30 16:28

(Please correct me if these notes are wrong).

Scribus doesn't pick the font for the menus.

Qt (the widget set), uses the the font in the .qtconfig configuration file (or the default).

Scribus must not require additional configuration *just to work*.

It 'qtconfig' is making a change to a text-file, we can include that change in the first place.
(0019577)
plinnell (administrator)
08-Apr-30 16:56

> Scribus doesn't pick the font for the menus.

Correct

> Qt (the widget set), uses the the font in the .qtconfig configuration file (or the default).

qt.rc or qt3.rc depending on packaging by distro

> Scribus must not require additional configuration *just to work*.

For someone on a Gnome or XFCE desktop without qt3-config, I am not sure how this can be done at all. As far as I know there is no control center applet to handle themes or UI fonts like kcm-gtk does in KDE.

> It 'qtconfig' is making a change to a text-file, we can include that change in the first place.

The problem with just adding a qt.rc is there will never be one size fits all which can work. What is appropriate for a CJK or Indic user might not be useful for me. The earlier issues with Lohit are indicative. Likewise picking Bitstream Vera over DejaVu would also be bad for Slavic or Cyrillic languages.

What I cannot understand is why there is so much resistance to adding a relatively small package as a dependency. qt3config is automatically added to any qt3 install on Fedora, Suse and Mandriva. We also include it in our Win32 packages, even if it is not strictly required.
(0019578)
sladen (reporter)
08-Apr-30 17:28

> For someone on a Gnome or XFCE desktop without qt3-config

A much higher-level issue. If a user clicks "?????????? Scribus" ("install Scribus") then that is what should happen. There should be no further configuration (required) for basic operation *at all*.

Package dependencies take care of required libraries; package install script automate special cases.

Imagine getting the keys to a new car and finding that it has no steering wheel fitted.

If the _toolkit_ is picking a font that does not have characters for the current locale, there's two places to fix this:

  (a) the font that the toolkit is picking

  (b) the (coverage of) glyphs present in the font being picked.

If manual changes are necessary, I would like to automate those changes for everyone. To do that, we need to collective agree on two things:

  (a) What overrides/changes are required.

  (b) When the changes need to be [automatically] applied.
(0019579)
sladen (reporter)
08-Apr-30 17:32

(Ha, it's a bit difficult to give examples of i10n font issues when the bugtracker can't handle UTF-8 examples!)
(0019580)
sladen (reporter)
08-Apr-30 17:39

FWIW, reported the issue with Mantis (this bugtracker) not handling UTF-8 at:

  http://www.mantisbt.org/bugs/view.php?id=9118 [^]
(0019581)
plinnell (administrator)
08-Apr-30 18:22

Well I have done some testing with Hardy running under ubuntu desktop /gnome and every language I picked came up with no missing glyphs. So, in this case, I am include to close this bug. It seems the updates to font packages seemed to have help this a lot.

JFYI, I have not seen this issue on other distros I have run Scribus on.
(0019582)
cbradney (administrator)
08-Apr-30 18:39

My take on this is that qt apps require qt, and qt apps' users' require to be able to configure them, if the system they use cant do it for them. Therefore, qtconfig should be a dependency of qt itself - ie dont split the damn thing out in the first place.
(0019609)
plinnell (administrator)
08-May-04 00:19

Closing It is not our bug

- Issue History
Date Modified Username Field Change
06-Feb-25 14:26 mhanski New Issue
06-Feb-25 14:26 mhanski File Added: prefences_general_with_font_face.png
06-Feb-25 14:27 mhanski Relationship added related to 0002751
06-Feb-26 03:06 mhanski OS => Kubuntu
06-Feb-26 03:06 mhanski OS Version => Dapper Drake
06-Feb-26 03:06 mhanski Platform => Pentium(R) M processor 1.50GHz
06-Feb-26 03:09 mhanski Summary Preferances>General: Font face setting needed => Preferences>General: Font face setting needed
06-Feb-26 09:17 cbradney Note Added: 0008916
06-Feb-26 11:33 mhanski Note Added: 0008918
06-Feb-26 11:38 mhanski Note Added: 0008919
06-Feb-26 13:50 cbradney Note Added: 0008921
06-Feb-26 14:28 mhanski Note Added: 0008922
06-Feb-26 14:38 cbradney Note Added: 0008923
06-Apr-11 13:07 mhanski Product Version 1.3.3cvs => 1.3.4cvs
06-Apr-11 15:45 ringerc Note Added: 0009807
06-Apr-11 15:45 ringerc Status new => acknowledged
06-Apr-11 16:09 mhanski File Added: european_desktop_chinese_scribus.png
06-Apr-11 16:13 mhanski Note Added: 0009809
06-Apr-11 21:04 ringerc Note Added: 0009811
06-Apr-11 21:38 mhanski Note Added: 0009814
06-May-14 01:27 mhanski OS Kubuntu => all
06-May-14 01:27 mhanski OS Version Dapper Drake => all
06-May-14 01:27 mhanski Platform Pentium(R) M processor 1.50GHz => all
06-May-14 01:27 mhanski Product Version 1.3.4cvs => 1.3
06-May-14 01:49 mhanski Note Edited: 0008919
06-May-15 20:03 christoph_s Relationship added child of 0003821
06-Jun-14 14:10 mhanski Relationship added related to 0003816
06-Jul-03 21:30 mhanski Relationship added related to 0003967
06-Jul-05 12:25 mhanski Relationship added related to 0003983
06-Jul-20 10:56 mhanski Relationship added related to 0002464
06-Oct-18 08:42 mhanski Relationship added related to 0004423
06-Oct-28 22:49 sladen Note Added: 0013155
06-Oct-28 22:56 cbradney Note Added: 0013156
06-Oct-28 23:50 mhanski Note Added: 0013158
06-Oct-28 23:51 mhanski Note Edited: 0013158
08-Apr-30 16:14 plinnell Note Added: 0019574
08-Apr-30 16:15 plinnell Note Added: 0019575
08-Apr-30 16:28 sladen Note Added: 0019576
08-Apr-30 16:56 plinnell Note Added: 0019577
08-Apr-30 17:28 sladen Note Added: 0019578
08-Apr-30 17:32 sladen Note Added: 0019579
08-Apr-30 17:39 sladen Note Added: 0019580
08-Apr-30 18:22 plinnell Note Added: 0019581
08-Apr-30 18:23 plinnell Status acknowledged => resolved
08-Apr-30 18:23 plinnell Resolution open => no change required
08-Apr-30 18:39 cbradney Note Added: 0019582
08-Apr-30 19:06 plinnell Assigned To => plinnell
08-Apr-30 19:06 plinnell Status resolved => assigned
08-May-04 00:19 plinnell Note Added: 0019609
08-May-04 00:19 plinnell Status assigned => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker