Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008470ScribusPlug-inspublic2009-09-27 05:002010-10-29 19:24
Reporterchristoph_s 
Assigned ToHerm 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSLinuxOS VersionOpenSUSE 10.3
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version 
Summary0008470: Crash when trying to load bitmaps via GM
DescriptionScribus crashes reliably when an image type supported by GM is selected in the file dialog.

Tested with GM 1.1.8 and 1.2.5
Additional InformationLoading image "/Daten/SuSE-93_alt/christoph/BSG (5).tga" Tumbnail: true
Detected format: "Truevision Targa image" , has matte(alpha): false

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb535f700 (LWP 5365)]
0x08c3201c in read_rgb (input=0xbfcc51b0, output=0x8f84360, width=1152,
    height=708)
    at /home/christoph/scribus15svn/trunk/Scribus/scribus/scimgdataloader_gmagick.cpp:95
95 *buffer++ = ScaleQuantumToChar(GetBlueSample(pixels[i]));
(gdb) bt
#0 0x08c3201c in read_rgb (input=0xbfcc51b0, output=0x8f84360, width=1152,
    height=708)
    at /home/christoph/scribus15svn/trunk/Scribus/scribus/scimgdataloader_gmagick.cpp:95
0000001 0x08c32984 in ScImgDataLoader_GMagick::loadPicture (this=0x8f84358,
    fn=@0xbfcc57dc, res=72, thumbnail=true)
    at /home/christoph/scribus15svn/trunk/Scribus/scribus/scimgdataloader_gmagick.cpp:222
0000002 0x0888f87f in ScImage::LoadPicture (this=0xbfcc5580, fn=@0xbfcc57dc,
    page=1, cmSettings=@0xbfcc565c, useEmbedded=false, useProf=false,
    requestType=ScImage::Thumbnail, gsRes=72, realCMYK=0xbfcc567b,
    showMsg=false)
    at /home/christoph/scribus15svn/trunk/Scribus/scribus/scimage.cpp:2047
0000003 0x084285b2 in FDialogPreview::GenPreview (this=0x9f7e100, name=@0xbfcc57dc)
    at /home/christoph/scribus15svn/trunk/Scribus/scribus/ui/customfdialog.cpp:152
0000004 0x0842a4f7 in CustomFDialog::fileClicked (this=0x9f53248, path=@0xbfcc5908)
    at /home/christoph/scribus15svn/trunk/Scribus/scribus/ui/customfdialog.cpp:415
0000005 0x0824bfc6 in CustomFDialog::qt_metacall (this=0x9f53248,
    _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfcc58cc)
    at /home/christoph/scribus15svn/trunk/Scribus/scribus/ui/moc_customfdialog.cxx:112
---Type <return> to continue, or q <return> to quit---
0000006 0xb5f61ee7 in QMetaObject::activate (sender=0xa073c60,
    from_signal_index=38, to_signal_index=38, argv=0xbfcc58cc)
    at kernel/qobject.cpp:3113
0000007 0xb5f62602 in QMetaObject::activate (sender=0xa073c60, m=0xb6e29120,
    local_signal_index=2, argv=0xbfcc58cc) at kernel/qobject.cpp:3187
0000008 0xb6ab0a23 in QFileDialog::currentChanged (this=0xa073c60, _t1=@0xbfcc5908)
    at .moc/release-shared/moc_qfiledialog.cpp:257
0000009 0xb6aba197 in QFileDialogPrivate::_q_currentChanged (this=0xa1e5f40,
    index=@0x9cf2318) at dialogs/qfiledialog.cpp:2785
0000010 0xb6abf1dc in QFileDialog::qt_metacall (this=0xa073c60,
    _c=QMetaObject::InvokeMetaMethod, _id=17, _a=0xbfcc5a38)
    at .moc/release-shared/moc_qfiledialog.cpp:178
0000011 0x082720fc in ScFileWidget::qt_metacall (this=0xa073c60,
    _c=QMetaObject::InvokeMetaMethod, _id=53, _a=0xbfcc5a38)
    at /home/christoph/scribus15svn/trunk/Scribus/scribus/ui/moc_scfilewidget.cxx:58
0000012 0xb5f61ee7 in QMetaObject::activate (sender=0x95834e0,
    from_signal_index=5, to_signal_index=5, argv=0xbfcc5a38)
    at kernel/qobject.cpp:3113
0000013 0xb5f62602 in QMetaObject::activate (sender=0x95834e0, m=0xb6e2bcd0,
    local_signal_index=1, argv=0xbfcc5a38) at kernel/qobject.cpp:3187
0000014 0xb6b5e539 in QItemSelectionModel::currentChanged (this=0x95834e0,
    _t1=@0x9cf2318, _t2=@0x923abd0)
---Type <return> to continue, or q <return> to quit---
    at .moc/release-shared/moc_qitemselectionmodel.cpp:153
0000015 0xb6b5ead7 in QItemSelectionModel::setCurrentIndex (this=0x95834e0,
    index=@0x9cf2318, command=@0xbfcc5b70)
    at itemviews/qitemselectionmodel.cpp:1123
0000016 0xb6b0dd23 in QAbstractItemView::mousePressEvent (this=0xa404be0,
    event=0xbfcc630c) at itemviews/qabstractitemview.cpp:1514
0000017 0xb662dfe4 in QWidget::event (this=0xa404be0, event=0xbfcc630c)
    at kernel/qwidget.cpp:7545
0000018 0xb69c6bc3 in QFrame::event (this=0xa404be0, e=0xbfcc630c)
    at widgets/qframe.cpp:559
0000019 0xb6a6237f in QAbstractScrollArea::viewportEvent (this=0xa404be0, e=0x0)
    at widgets/qabstractscrollarea.cpp:962
0000020 0xb6b11d1a in QAbstractItemView::viewportEvent (this=0xa404be0,
    event=0xbfcc630c) at itemviews/qabstractitemview.cpp:1476
0000021 0xb6a64295 in QAbstractScrollAreaFilter::eventFilter (this=0x95f68c8,
    o=0xa04d560, e=0xbfcc630c) at widgets/qabstractscrollarea_p.h:100
0000022 0xb5f4ca51 in QCoreApplicationPrivate::sendThroughObjectEventFilters (
    this=0x8f3ae78, receiver=0xa04d560, event=0xbfcc630c)
    at kernel/qcoreapplication.cpp:726
0000023 0xb65d64d3 in QApplicationPrivate::notify_helper (this=0x8f3ae78,
    receiver=0xa04d560, e=0xbfcc630c) at kernel/qapplication.cpp:4052
0000024 0xb65dab4f in QApplication::notify (this=0xbfccbf08, receiver=0xa04d560,
    e=0xbfcc630c) at kernel/qapplication.cpp:3758
---Type <return> to continue, or q <return> to quit---
0000025 0xb5f4c5eb in QCoreApplication::notifyInternal (this=0xbfccbf08,
    receiver=0xa04d560, event=0xbfcc630c) at kernel/qcoreapplication.cpp:610
0000026 0xb65dc131 in QApplicationPrivate::sendMouseEvent (receiver=0xa04d560,
    event=0xbfcc630c, alienWidget=0xa04d560, nativeWidget=0x9f53248,
    buttonDown=0xb6e38a20, lastMouseReceiver=@0xb6e38a24)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
0000027 0xb664983f in QETWidget::translateMouseEvent (this=0x9f53248,
    event=0xbfcc78e8) at kernel/qapplication_x11.cpp:4402
0000028 0xb6648ea2 in QApplication::x11ProcessEvent (this=0xbfccbf08,
    event=0xbfcc78e8) at kernel/qapplication_x11.cpp:3421
0000029 0xb667147a in x11EventSourceDispatch (s=0x8f413a0, callback=0,
    user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
0000030 0xb5d6b6d6 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
0000031 0xb5d6ea72 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
0000032 0xb5d6f02e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
0000033 0xb5f78c18 in QEventDispatcherGlib::processEvents (this=0x8f3e090,
    flags=@0xbfcc7a88) at kernel/qeventdispatcher_glib.cpp:327
0000034 0xb6671275 in QGuiEventDispatcherGlib::processEvents (this=0x8f3e090,
    flags=@0xbfcc7ab8) at kernel/qguieventdispatcher_glib.cpp:202
0000035 0xb5f4b79d in QEventLoop::processEvents (this=0xbfcc7b2c,
    flags=@0xbfcc7af4) at kernel/qeventloop.cpp:149
0000036 0xb5f4ba2a in QEventLoop::exec (this=0xbfcc7b2c, flags=@0xbfcc7b34)
    at kernel/qeventloop.cpp:201
---Type <return> to continue, or q <return> to quit---
0000037 0xb6aac893 in QDialog::exec (this=0x9f53248) at dialogs/qdialog.cpp:498
0000038 0x08938d8c in ScribusMainWindow::CFileDialog (this=0x8faaf78,
    wDir=@0xbfcc7c74, caption=@0xbfcc7c70, filter=@0xbfcc7c6c,
    defNa=@0xbfcc7c68, optionFlags=3, docom=0x0, doFont=0x0, doProfiles=0x0)
    at /home/christoph/scribus15svn/trunk/Scribus/scribus/scribus.cpp:8744
0000039 0x089529ff in ScribusMainWindow::slotGetContent (this=0x8faaf78)
    at /home/christoph/scribus15svn/trunk/Scribus/scribus/scribus.cpp:4261
0000040 0x08276142 in ScribusMainWindow::qt_metacall (this=0x8faaf78,
    _c=QMetaObject::InvokeMetaMethod, _id=57, _a=0xbfcc7e9c)
    at /home/christoph/scribus15svn/trunk/Scribus/scribus/moc_scribus.cxx:468
0000041 0xb5f61ee7 in QMetaObject::activate (sender=0x92613f0,
    from_signal_index=5, to_signal_index=6, argv=0xbfcc7e9c)
    at kernel/qobject.cpp:3113
0000042 0xb5f62370 in QMetaObject::activate (sender=0x92613f0, m=0xb6e1f7e8,
    from_local_signal_index=1, to_local_signal_index=2, argv=0xbfcc7e9c)
    at kernel/qobject.cpp:3207
0000043 0xb65cf3c1 in QAction::triggered (this=0x92613f0, _t1=false)
    at .moc/release-shared/moc_qaction.cpp:236
0000044 0xb65cfe5f in QAction::activate (this=0x92613f0, event=QAction::Trigger)
    at kernel/qaction.cpp:1160
0000045 0xb6a0afd0 in QMenuPrivate::activateCausedStack (this=0x9ebf398,
    causedStack=@0xbfcc7f78, action=0x92613f0, action_e=QAction::Trigger,
    self=true) at widgets/qmenu.cpp:967
---Type <return> to continue, or q <return> to quit---
0000046 0xb6a11b25 in QMenuPrivate::activateAction (this=0x9ebf398,
    action=0x92613f0, action_e=QAction::Trigger, self=<value optimized out>)
    at widgets/qmenu.cpp:1060
0000047 0xb6a13ebd in QMenu::mouseReleaseEvent (this=0xa416618, e=0xbfcc84cc)
    at widgets/qmenu.cpp:2254
0000048 0xb662dd39 in QWidget::event (this=0xa416618, event=0xbfcc84cc)
    at kernel/qwidget.cpp:7549
0000049 0xb6a0f7f5 in QMenu::event (this=0xa416618, e=0xbfcc84cc)
    at widgets/qmenu.cpp:2353
0000050 0xb65d64fc in QApplicationPrivate::notify_helper (this=0x8f3ae78,
    receiver=0xa416618, e=0xbfcc84cc) at kernel/qapplication.cpp:4056
0000051 0xb65dab4f in QApplication::notify (this=0xbfccbf08, receiver=0xa416618,
    e=0xbfcc84cc) at kernel/qapplication.cpp:3758
0000052 0xb5f4c5eb in QCoreApplication::notifyInternal (this=0xbfccbf08,
    receiver=0xa416618, event=0xbfcc84cc) at kernel/qcoreapplication.cpp:610
0000053 0xb65dc131 in QApplicationPrivate::sendMouseEvent (receiver=0xa416618,
    event=0xbfcc84cc, alienWidget=0x0, nativeWidget=0xa416618,
    buttonDown=0xb6e38a20, lastMouseReceiver=@0xb6e38a24)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
0000054 0xb6649a78 in QETWidget::translateMouseEvent (this=0xa416618,
    event=0xbfcc9aa8) at kernel/qapplication_x11.cpp:4336
0000055 0xb6648ea2 in QApplication::x11ProcessEvent (this=0xbfccbf08,
    event=0xbfcc9aa8) at kernel/qapplication_x11.cpp:3421
---Type <return> to continue, or q <return> to quit---
0000056 0xb667147a in x11EventSourceDispatch (s=0x8f413a0, callback=0,
    user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
0000057 0xb5d6b6d6 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
0000058 0xb5d6ea72 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
0000059 0xb5d6f02e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
0000060 0xb5f78c18 in QEventDispatcherGlib::processEvents (this=0x8f3e090,
    flags=@0xbfcc9c48) at kernel/qeventdispatcher_glib.cpp:327
0000061 0xb6671275 in QGuiEventDispatcherGlib::processEvents (this=0x8f3e090,
    flags=@0xbfcc9c78) at kernel/qguieventdispatcher_glib.cpp:202
0000062 0xb5f4b79d in QEventLoop::processEvents (this=0xbfcc9cec,
    flags=@0xbfcc9cb4) at kernel/qeventloop.cpp:149
0000063 0xb5f4ba2a in QEventLoop::exec (this=0xbfcc9cec, flags=@0xbfcc9cf4)
    at kernel/qeventloop.cpp:201
0000064 0xb6a14147 in QMenu::exec (this=0xa416618, p=@0xbfcc9d54, action=0x0)
    at widgets/qmenu.cpp:1993
0000065 0x083abdbf in CanvasMode_Normal::createContextMenu (this=0x9ee4930,
    currItem=0xa2e7408, mx=418.75, my=307.8125)
    at /home/christoph/scribus15svn/trunk/Scribus/scribus/canvasmode_normal.cpp:1453
0000066 0x083aedcc in CanvasMode_Normal::mouseReleaseEvent (this=0x9ee4930,
    m=0xbfcca68c)
    at /home/christoph/scribus15svn/trunk/Scribus/scribus/canvasmode_normal.cpp:772
---Type <return> to continue, or q <return> to quit---
0000067 0x08a2183c in ScribusView::eventFilter (this=0xa2f1420, obj=0xa306eb8,
    event=0xbfcca68c)
    at /home/christoph/scribus15svn/trunk/Scribus/scribus/scribusview.cpp:4821
0000068 0xb5f4ca51 in QCoreApplicationPrivate::sendThroughObjectEventFilters (
    this=0x8f3ae78, receiver=0xa306eb8, event=0xbfcca68c)
    at kernel/qcoreapplication.cpp:726
0000069 0xb65d64d3 in QApplicationPrivate::notify_helper (this=0x8f3ae78,
    receiver=0xa306eb8, e=0xbfcca68c) at kernel/qapplication.cpp:4052
#70 0xb65dab4f in QApplication::notify (this=0xbfccbf08, receiver=0xa306eb8,
    e=0xbfcca68c) at kernel/qapplication.cpp:3758
0000071 0xb5f4c5eb in QCoreApplication::notifyInternal (this=0xbfccbf08,
    receiver=0xa306eb8, event=0xbfcca68c) at kernel/qcoreapplication.cpp:610
0000072 0xb65dc131 in QApplicationPrivate::sendMouseEvent (receiver=0xa306eb8,
    event=0xbfcca68c, alienWidget=0xa306eb8, nativeWidget=0x8faaf78,
    buttonDown=0xb6e38a20, lastMouseReceiver=@0xb6e38a24)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
0000073 0xb664983f in QETWidget::translateMouseEvent (this=0x8faaf78,
    event=0xbfccbc68) at kernel/qapplication_x11.cpp:4402
0000074 0xb6648ea2 in QApplication::x11ProcessEvent (this=0xbfccbf08,
    event=0xbfccbc68) at kernel/qapplication_x11.cpp:3421
0000075 0xb667147a in x11EventSourceDispatch (s=0x8f413a0, callback=0,
    user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
0000076 0xb5d6b6d6 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
---Type <return> to continue, or q <return> to quit---
0000077 0xb5d6ea72 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
0000078 0xb5d6f02e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
0000079 0xb5f78c18 in QEventDispatcherGlib::processEvents (this=0x8f3e090,
    flags=@0xbfccbe08) at kernel/qeventdispatcher_glib.cpp:327
0000080 0xb6671275 in QGuiEventDispatcherGlib::processEvents (this=0x8f3e090,
    flags=@0xbfccbe38) at kernel/qguieventdispatcher_glib.cpp:202
0000081 0xb5f4b79d in QEventLoop::processEvents (this=0xbfccbeb0,
    flags=@0xbfccbe74) at kernel/qeventloop.cpp:149
0000082 0xb5f4ba2a in QEventLoop::exec (this=0xbfccbeb0, flags=@0xbfccbeb8)
    at kernel/qeventloop.cpp:201
0000083 0xb5f4dbc1 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
0000084 0xb65d5ce7 in QApplication::exec () at kernel/qapplication.cpp:3525
0000085 0x08c333f2 in mainApp (argc=1, argv=0xbfccbff4)
    at /home/christoph/scribus15svn/trunk/Scribus/scribus/main_nix.cpp:84
0000086 0x08c33462 in main (argc=0, argv=0x0)
    at /home/christoph/scribus15svn/trunk/Scribus/scribus/main_nix.cpp:52
TagsNo tags attached.
Patch
Attached Files? file icon lprof1.xcf [^] (14,600 bytes) 2009-09-27 21:43
? file icon BSG (5).tga [^] (1,516,449 bytes) 2009-09-27 21:44

- Relationships

-  Notes
(0024051)
Herm (administrator)
2010-06-11 21:49

I'm still not able to reproduce this. Could you please test again with a current build?
(0024758)
Herm (administrator)
2010-10-29 17:12

This bug should be fixed by the changes in r15677.

- Issue History
Date Modified Username Field Change
2009-09-27 05:00 christoph_s New Issue
2009-09-27 05:00 christoph_s Status new => assigned
2009-09-27 05:00 christoph_s Assigned To => Herm
2009-09-27 21:43 christoph_s File Added: lprof1.xcf
2009-09-27 21:44 christoph_s File Added: BSG (5).tga
2010-06-11 21:49 Herm Note Added: 0024051
2010-10-29 17:12 Herm Note Added: 0024758
2010-10-29 17:12 Herm Status assigned => resolved
2010-10-29 17:12 Herm Resolution open => fixed
2010-10-29 19:24 christoph_s Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker