Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000866ScribusGeneralpublic2004-07-16 11:362013-01-08 02:19
Reportermhanski 
Assigned Tofschmid 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformanyOSanyOS Versionany
Product Version1.3 
Target VersionFixed in Version1.5.0svn 
Summary0000866: Implement check box radio behaviour in PDF forms
DescriptionRequest submitted via mailing list nashi.altmuehlnet.de/pipermail/scribus/2004-July/005702.html

Quotation:
> > 2. How to get checkboxes to exhibit radio behaviour, where
> > only one of a group of checkboxes can be in a selected state
> > at one time.
> This is not implemented yet, cause the PDF-Reference is somewhat
> unclear in that topic. The difficulty is to get a pretty look
> for the radiobuttons. But i will have a look at it.

I was told by an Acrobat user that the names of the checkboxes
have to be the same, just the values to be returned are
different to get radio button behaviour. I tried to do
this, scribus was upset if I made the names of the fields
the same in the normal properties display. One sequence
that sort of worked was to create two checkboxes (check0 and
check1), then I went back and changed the name of check0 to
check1 in the PDF properties, exported the PDF file.
In Acrobat reader selecting the first check box would change
the selection on the second checkbox at the same time
resulting in both boxes either checked or unchecked.
I don't see how to change the returned values for checkboxes.
TagsNo tags attached.
Patch
Attached Files

- Relationships
related to 0003180closedfschmid checkboxes are badly exported to PDF 
related to 0000865acknowledged Allow changing tab order of pdf form fields 
related to 0003282closedfschmid Fonts don't work with text fields of forms. 
child of 0000111assigned Scribus Document File format 
child of 0003831acknowledged Metabug: PDF Forms 

-  Notes
(0008179)
claudiofelix (reporter)
2006-01-18 21:15

I have the same problem here. Since I didn't find any radio button, I tried to implement its functionatity using checkboxes and javascript, but I couldn't find a way to access the checkbox group as an array. In HTML it can be done naming all checkboxes the same and then accessing them like an array. It would be nice if we could do the same in Scribus.
(0018037)
mhanski (developer)
2007-11-28 21:08

Workaround (until it's really fixed):
http://wiki.scribus.net/index.php/How_to_simulate_Radio_Buttons_on_PDF_forms [^]
(0022032)
BelJoost (reporter)
2009-06-25 09:44

This issue seems to me a duplicate of 0007322 and is related to issue 0008201.

Unfortunately the workaround only solves part of the/my problem. When the PDF form is manualy filled the workaround works just fine, but when the form is filled by another program you cannot set the value of one field by its export value.

For example a yes/no radiobutton: Instead of setting a fieldgroup with the export value yes or no I have to either set a field yes to true or a field no to true.

I wonder if those fieldgroups are a Adobe proprietary extension or are standard PDF functionality?

- Issue History
Date Modified Username Field Change
2004-07-16 11:36 mhanski New Issue
2005-04-27 18:00 mhanski Description Updated
2005-10-09 01:34 mhanski Relationship added child of 0000111
2005-10-09 07:50 ringerc Status new => acknowledged
2005-10-09 22:12 mhanski Relationship added related to 0000865
2006-01-18 21:15 claudiofelix Note Added: 0008179
2006-02-10 01:47 mhanski Relationship added related to 0003180
2006-02-23 10:46 mhanski Product Version => 1.3.3cvs
2006-04-19 19:24 mhanski Relationship added related to 0003282
2006-04-27 11:45 mhanski OS Mandrake Linux Official => any
2006-04-27 11:45 mhanski OS Version 10 => any
2006-04-27 11:45 mhanski Platform AMD Athlon XP 3000+ => any
2006-04-27 11:45 mhanski Product Version 1.3.3cvs => 1.3
2006-04-27 11:45 mhanski Note Added: 0010537
2006-04-27 11:46 mhanski Note Deleted: 0010537
2006-05-17 19:48 mhanski Relationship added child of 0003831
2006-11-01 23:48 plinnell Status acknowledged => assigned
2006-11-01 23:48 plinnell Assigned To => fschmid
2007-11-28 21:08 mhanski Note Added: 0018037
2009-06-25 09:44 BelJoost Note Added: 0022032
2012-12-10 22:42 fschmid Status assigned => resolved
2012-12-10 22:42 fschmid Fixed in Version => 1.5.0svn
2012-12-10 22:42 fschmid Resolution open => fixed
2013-01-08 02:19 christoph_s Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker