Mantis Issue Tracking for Scribus
· Hosting provided by / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008823ScribusGeneralpublic2010-02-16 01:582015-02-28 19:56
Assigned Tocbradney 
PrioritynormalSeverityfeatureReproducibilityhave not tried
PlatformOSOS Version
Product Version 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0008823: New non modal resource manager
DescriptionThis is a parent for all RFEs related to a unified resource management (colour palettes, gradients etc.)
Steps To ReproduceSee [^] for further information
TagsNo tags attached.
Attached Files

- Relationships
related to 0004379new Basic pattern sets for inclusion in Scribus 
related to 0012792assignedfschmid Support for Illustrator resources (ex. gradients and symbols)  
related to 0011564assignedfschmid Missing gradient functionality 

-  Notes
christoph_s (administrator)
2015-02-17 08:45

I'm resetting this to "assigned", as it's not complete yet (colour palettes, patterns, gradients etc.). Many thanks, though, for this great new feature.
cbradney (administrator)
2015-02-17 09:18

And I'm resolving this.. you get me more examples of the stuff, and I can implement it. I cannot code this without at least 2-3 examples of each type. Each one can be a new feature request. Things like gradients - we don't have a file format for those, so forget them for now.
JLuc (developer)
2015-02-17 21:09

tested with SVN 19826 :

I got 2 fonts listed : lato and blokk
first time i try dl a font, i got following message
"QSslSocket: cannot resolve SSLv2_client_method"
and no result is achieved.
For further dls, i aint got no message nor result neither.

jghali points [^]
christoph_s (administrator)
2015-02-18 07:43
edited on: 2015-02-21 13:59

Craig, colour palettes in various formats are already included in Scribus. As of 1.5.0svn, Scribus supports the following formats: native Scribus palettes (XML), VIVA palettes (XML), GIMP colour palettes (GPL), EPS, AI and AutoCAD Color Books (ACB). For Scribus XML and EPS files, you can use Scribus svn (1.4.x or 1.5.0svn). GIMP colour palettes are included in GIMP, Inkscape and Krita. Sample AI palettes can be found here: [^] The Resene palettes I've created for Scribus 1.4.x are based on the original AutoCAD files: [^] Support for VIVA XML isn't necessary in the RM, since no colour vendor is supporting this format. It's only needed for those who switch VIVA to Scribus.

As for gradients, Scribus *does* have its own format (SGR). You have to ask Franz why Scribus can't save gradients in this format yet ;) In addition to SGR, Scribus can also use the GIMP gradient format (GGR). As with GIMP palettes, these are included in GIMP, Inkscape and Krita.

Regarding patterns, see bug 0004379

- Issue History
Date Modified Username Field Change
2010-02-16 01:58 christoph_s New Issue
2010-02-16 01:58 christoph_s Status new => confirmed
2010-02-16 01:58 christoph_s Status confirmed => acknowledged
2011-04-16 18:26 cbradney Target Version 1.5.1svn => 1.5.1
2015-02-16 23:36 cbradney Patch => No
2015-02-16 23:36 cbradney Target Version 1.5.1 => 1.5.0
2015-02-16 23:37 cbradney Status acknowledged => resolved
2015-02-16 23:37 cbradney Fixed in Version => 1.5.0svn
2015-02-16 23:37 cbradney Resolution open => fixed
2015-02-16 23:37 cbradney Assigned To => cbradney
2015-02-17 08:45 christoph_s Note Added: 0034525
2015-02-17 08:45 christoph_s Status resolved => assigned
2015-02-17 09:18 cbradney Note Added: 0034526
2015-02-17 09:18 cbradney Status assigned => resolved
2015-02-17 21:09 JLuc Note Added: 0034528
2015-02-18 07:43 christoph_s Note Added: 0034535
2015-02-18 07:44 christoph_s Relationship added related to 0004379
2015-02-18 07:46 christoph_s Relationship added related to 0012792
2015-02-18 07:48 christoph_s Relationship added related to 0011564
2015-02-21 13:59 Kunda Note Edited: 0034535 View Revisions
2015-02-28 19:46 Kunda Status resolved => feedback
2015-02-28 19:46 Kunda Resolution fixed => reopened
2015-02-28 19:56 cbradney Status feedback => closed
2015-02-28 19:56 cbradney Resolution reopened => fixed

Copyright © 2000 - 2015 MantisBT Team
Powered by Mantis Bugtracker