Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0009419ScribusUsabilitypublic2010-10-21 13:162012-07-01 22:35
Reportercezaryece 
Assigned Tocezaryece 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformLinuxOSOS Version
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0009419: Patch for YesToAll button in Contenst/Clear warning
DescriptionI prepare patch which add "Yes To All" button for warning box when you clear contents for more than one text frame, so warning appear only once and all selected frames will cleared.
Additional InformationIt is my first patch, so be patient for my uknowledge if something is wrong.
Patch is against 15608 rev.
TagsNo tags attached.
Patch
Attached Filesdiff file icon scribusdoc.diff [^] (2,791 bytes) 2010-10-21 13:16 [Show Content]
diff file icon scribusdoc.cpp.diff [^] (1,459 bytes) 2010-10-23 16:06 [Show Content]

- Relationships
has duplicate 0009803closedjghali Make Edit/Contents/Clear warning appearing once 

-  Notes
(0024692)
plinnell (administrator)
2010-10-22 23:08

Thanks for the patch. I will test and report.
(0024694)
cezaryece (developer)
2010-10-23 16:13

I have made new patch because first one was unusable as I heard.
After discusion with a_l_e I have change this patch and now it simply make warning window appear only once when first text frame is reached. "Yes" aply clearing for all selected text frames, "No" skip all selected text frames, but all selected other frames are cleared.
I hope this is more sensible, because Scribus not show for which text frame warning appear, so there is no reason to ask for each one.
Also I hope diff file will be applicable.
(0024695)
cezaryece (developer)
2010-10-23 16:16

You can change summary of this ticket, now it is not "Yes To All" button. Now it should be "making Contents/Clear warning appearing once" instead.
(0024806)
cbradney (administrator)
2010-11-04 18:03

I don't understand why the Yes to All option was taken away. If you have multiple selected, you might not want to clear them all...
(0024812)
cezaryece (developer)
2010-11-05 08:16

If you don't want to clear all selected frames, what for you select unwanted frames?
And what for is warning for each frame if you don't see for which one?
(0028333)
jghali (administrator)
2012-06-30 16:21

I applied the 'Yes to all' variant. If user use the 'Yes' button in case of multiple selection, he has at least the choice to stop directly in case of error.

- Issue History
Date Modified Username Field Change
2010-10-21 13:16 cezaryece New Issue
2010-10-21 13:16 cezaryece File Added: scribusdoc.diff
2010-10-22 23:07 plinnell Assigned To => plinnell
2010-10-22 23:07 plinnell Status new => assigned
2010-10-22 23:08 plinnell Note Added: 0024692
2010-10-22 23:08 plinnell Target Version => 1.5.0svn
2010-10-23 16:06 cezaryece File Added: scribusdoc.cpp.diff
2010-10-23 16:13 cezaryece Note Added: 0024694
2010-10-23 16:16 cezaryece Note Added: 0024695
2010-11-04 18:03 cbradney Note Added: 0024806
2010-11-05 08:16 cezaryece Note Added: 0024812
2012-06-18 21:25 cbradney Assigned To plinnell => cezaryece
2012-06-30 16:21 jghali Note Added: 0028333
2012-06-30 16:21 jghali Status assigned => resolved
2012-06-30 16:21 jghali Fixed in Version => 1.5.0svn
2012-06-30 16:21 jghali Resolution open => fixed
2012-06-30 16:21 jghali Target Version 1.5.0svn => 1.5.0
2012-07-01 22:35 cbradney Status resolved => closed
2012-07-02 23:24 jghali Relationship added has duplicate 0009803



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker