Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0009446ScribusScripterpublic2010-10-30 15:342014-07-03 06:51
Reporterplinnell 
Assigned Tojainbasil 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Version1.5.0svn 
Target Version1.6 milestoneFixed in Version 
Summary0009446: Scripter2 Throws an Error on Startup
Description 
 
<type 'exceptions.AttributeError'>
Python 2.6.5: /usr/bin/python
Sat Oct 30 15:34:11 2010

A problem occurred in a Python script. Here is the sequence of function calls leading up to the error, in the order they occurred.
 /opt/150x/lib/scribus/plugins/scripter/init_scripter.py in createMenu(mainWindow=<PyQt4.QtGui.QMainWindow object>)
   87

   88 def createMenu(mainWindow):

   89 Scripter.menu = ScripterMenu(mainWindow)

   90

   91 Scripter.connect("createMenu(QMainWindow*)", createMenu)

builtin Scripter = <mikro.ScripterImpl object>, Scripter.menu undefined, global ScripterMenu = <class '__main__.ScripterMenu'>, mainWindow = <PyQt4.QtGui.QMainWindow object>

 /opt/150x/lib/scribus/plugins/scripter/init_scripter.py in __init__(self=<__main__.ScripterMenu object>, parent=<PyQt4.QtGui.QMainWindow object>)
   59 self.setObjectName("Menu")

   60 self.popup = QMenu(i18n("Scripter"))

   61 MenuHooks().insertMenuAfter("E&xtras", self.popup)

   62 self._load_entries()

   63

global MenuHooks = <class 'scripter_hooks.MenuHooks'>, ).insertMenuAfter = <unbound method MenuHooks.insertMenuAfter>, self = <__main__.ScripterMenu object>, self.popup = <PyQt4.QtGui.QMenu object>

 /opt/150x/lib/scribus/plugins/scripter/scripter_hooks.py in __init__(self=<scripter_hooks.MenuHooks object>, window=None)
   20

   21 def __init__(self, window=None):

   22 self.window = window or Scripter.dialogs.mainWindow.qt

   23 self.menubar = self.window.menuBar()

   24 self.menus = []

self = <scripter_hooks.MenuHooks object>, self.window undefined, window = None, builtin Scripter = <mikro.ScripterImpl object>, Scripter.dialogs = <mikro.DialogsAPI object>, Scripter.dialogs.mainWindow = None, Scripter.dialogs.mainWindow.qt undefined

<type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'qt'
      args = ("'NoneType' object has no attribute 'qt'",)
      message = "'NoneType' object has no attribute 'qt'"
TagsNo tags attached.
Patch
Attached Files

- Relationships
has duplicate 0009968closedjghali Error message on startup 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2010-10-30 15:34 plinnell New Issue
2010-10-30 15:34 plinnell Status new => assigned
2010-10-30 15:34 plinnell Assigned To => h_a_j_s
2011-05-12 22:50 plinnell Assigned To h_a_j_s => jainbasil
2011-05-19 00:31 jghali Target Version 1.5.0svn => 1.5.0
2011-05-19 00:31 jghali Description Updated View Revisions
2011-05-19 00:32 jghali Relationship added has duplicate 0009968
2013-05-28 05:50 plinnell Status assigned => resolved
2013-05-28 05:50 plinnell Resolution open => unable to reproduce
2013-06-24 07:32 christoph_s Status resolved => closed
2014-07-03 06:51 Kunda Target Version 1.5.0 => 1.6 milestone



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker