View Issue Details

IDProjectCategoryView StatusLast Update
0001047ScribusPrintingpublic2008-02-08 16:17
ReporterZhang Weiwu Assigned Tochristoph_s  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformunixOSFreeBSDOS Version4.10
Product Version1.2 
Target VersionFixed in Version 
Summary0001047: scribus (or rather say ghostscript) failed to produce postscript level 2 ps file.
DescriptionIt's out of my knowledge to determine if this is a ghostscript bug or scribus bug: scribus could produce postscript level 3 file, but ghostscript failed to downgrade to level 2.
Steps To Reproduce1) open the buggy file attached to bug 0001046
2) click print to ps file, adjust ps level to 2
3) print it. Scribus runs busy for a while, and 0 byte postscript file is created. A gs.core is left on home directory.
Additional Informationghostscript is v7.07

if I let scribus create ps level 3 file, and downlevel it to level 2 by using ps2ps(1) in the ghostscript package, I got:

% ps2ps Document-3.ps Document-2.ps
Segmentation Fault (Core dumped)
TagsNo tags attached.
Patch

Activities

Zhang Weiwu

2004-09-09 02:12

reporter   ~0002343

Now I use ps2ps on Gentoo Linux from ghostscript 7.07.1, the process does not coredump and created a printable level 2 file. So it seems this is a fixed ghostscript problem?

Zhang Weiwu

2004-09-09 02:26

reporter   ~0002344

Just for reference, the resulted ps level 2 file is attached.

I close this bug because I can do the conversion in gs 7.07.1 in Gentoo. However there is no 7.07.1 gs port in FreeBSD yet. I'll re-test it when there is 7.07.1 gs on FBSD.

cbradney

2004-09-09 06:32

administrator   ~0002345

Reminder sent to Zhang Weiwu

If you are using Gentoo, we suggest to unmerge ghostscript and emerge ghostscript-afpl. The afpl licensed version is MUCH better as it is at version 8.14.

Issue History

Date Modified Username Field Change
2004-09-09 02:07 Zhang Weiwu New Issue
2004-09-09 02:12 Zhang Weiwu Note Added: 0002343
2004-09-09 02:26 Zhang Weiwu Note Added: 0002344
2004-09-09 02:26 Zhang Weiwu Status new => closed
2004-09-09 06:32 cbradney Note Added: 0002345
2008-02-08 16:17 christoph_s Status closed => resolved
2008-02-08 16:17 christoph_s Resolution open => no change required
2008-02-08 16:17 christoph_s Assigned To => christoph_s
2008-02-08 16:17 christoph_s Status resolved => closed