View Issue Details

IDProjectCategoryView StatusLast Update
0010063ScribusFontspublic2011-06-21 11:25
ReporterAlmaTlust Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0010063: Non roman fonts not displayed (but displayed well in editor)
DescriptionSome non-roman scripts are not displayed at all or wrong, both in 1.4rc5 and in 1.5trunk (kubuntu 11.04).
Steps To ReproduceCopy non roman text from bibletime to scribus (e.g. Thai)
Text is not displayed nor rendered correctly (diacritics), but is displayed in text editor.
Additional InformationI work with SIL Int. which does language development work in over 70 countries, and would like to propagate Scribus for layouting; but as long as rendering of minority languages doesn't work well, we can't use scribus.
TagsNo tags attached.
Patch

Relationships

duplicate of 0003928 closedFahad Support line breaking for Thai text 

Activities

jghali

2011-06-21 11:12

administrator   ~0026445

For now non latin language are not supported. Work for implementing non latin languages support is going on in a specific branch. Closing as this is a duplicate of other already submitted issues.

ale

2011-06-21 11:25

manager   ~0026446

hi

we have a branch with support for indic scripts.

currently, the project seems to be orphaned: please get in touch with us if you think you can provide programming work to get this sorted out!

Issue History

Date Modified Username Field Change
2011-06-21 08:28 AlmaTlust New Issue
2011-06-21 11:12 jghali Note Added: 0026445
2011-06-21 11:12 jghali Relationship added duplicate of 0003928
2011-06-21 11:12 jghali Status new => resolved
2011-06-21 11:12 jghali Resolution open => duplicate
2011-06-21 11:12 jghali Assigned To => jghali
2011-06-21 11:13 jghali Status resolved => closed
2011-06-21 11:25 ale Note Added: 0026446