View Issue Details

IDProjectCategoryView StatusLast Update
0010541ScribusCanvaspublic2016-12-08 22:04
ReporterVladimir Savic Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityhave not tried
Status assignedResolutionfixed 
Product Version1.5.0 
Target Version1.5.4Fixed in Version 
Summary0010541: Guides jumping around on mouse click
DescriptionOK. I admit that the subject is a bit too harsh, but there is a serious usability issue here.
Namely, if you click somewhere near the guide on canvas, with near meaning cursor has changed shape into moving double-head arrow, guide will immediately jump to that position, which is clearly wrong. What should happen is - wait until mouse button is down AND dragging occurs for further then few pixels away, then move guide. Otherwise, do nothing!
TagsNo tags attached.
PatchNo

Activities

ale

2012-01-31 15:09

manager   ~0027635

hi franz,

does not really look fixed to me...
when you're at 100% zoom, can you to select a guide for the "align and distribute" without moving it?

i can't...

ale

2012-02-17 15:35

manager   ~0027703

if i understood it correctly, vlada agrees that this is not fixed...

Vladimir Savic

2012-03-27 22:02

reporter   ~0027871

Right, ale. It's not.

Vladimir Savic

2014-04-04 13:21

reporter   ~0031603

As far as I get it, the main problem is Scribus' approach to handling moving of object.

Scribus should attempt to figure out if mouse has traveled some, quite often in preferences tweakable, amount of on-screen pixels after mouse press event. If so, then start moving and resizing. If mouse button happens to be released without pointer leaving radius of let's say 5px, then ignore user's intervetion completely.

Scribus relies on settable timer value. Unorthodox approach. Even worse, it can easily make other operations unpredictable. Beside this guide jumping problem I've had problem with RMB click at handle (resizing to margin operation) too.

Kunda

2015-05-05 01:49

manager   ~0035027

Says it was fixed. Undoing that due to the commentary in the thread. Assigning to 1.5.1

Issue History

Date Modified Username Field Change
2012-01-26 14:30 ale New Issue
2012-01-26 14:31 ale Reporter ale => user445
2012-01-26 14:31 ale Description Updated View Revisions
2012-01-26 22:31 fschmid Status new => resolved
2012-01-26 22:31 fschmid Fixed in Version => 1.5.0svn
2012-01-26 22:31 fschmid Resolution open => fixed
2012-01-26 22:31 fschmid Assigned To => fschmid
2012-01-31 15:09 ale Note Added: 0027635
2012-02-06 20:39 cbradney Reporter user445 => Vladimir Savic
2012-02-17 15:35 ale Note Added: 0027703
2012-02-17 15:35 ale Status resolved => assigned
2012-03-27 22:02 Vladimir Savic Note Added: 0027871
2014-04-04 13:21 Vladimir Savic Note Added: 0031603
2015-05-05 01:49 Kunda Note Added: 0035027
2015-05-05 01:49 Kunda Patch => No
2015-05-05 01:49 Kunda Fixed in Version 1.5.0svn =>
2015-05-05 01:49 Kunda Target Version => 1.5.1
2016-01-23 17:17 cbradney Target Version 1.5.1 => 1.5.3
2016-12-08 22:04 Kunda Target Version 1.5.3 => 1.5.4