View Issue Details

IDProjectCategoryView StatusLast Update
0010623ScribusOS-MacOSXpublic2016-12-08 21:39
Reporterrobcander Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformMacOSOS XOS Version10.6.8
Product Version1.4.0 
Target Version1.5.3Fixed in Version 
Summary0010623: OSX Dual Screen bug: Starting Scribus results in the Properties Window being displayed with a position of -1280
DescriptionStarting Scribus results in the Properties Window being displayed with a position of -1280, even though the attribute value for key=left in the PropertiesPalette element shows a positive value.

XLl elements are those in the file prefs140.xml
Steps To ReproduceFor this you require two screens, one positioned to the left of the main (right) screen:-

- start Scribus - Properties window is shown at position -1280, appearing in the left-hand window

- move the Properties window to the right-hand window, that is the position is now positive

- close Scribus - the attribute value for key=left in the PropertiesPalette element shows the correct positive value.

- start Scribus - Properties window is again shown at position -1280.

Tagsdual-monitor
PatchNo

Relationships

related to 0009719 confirmed Palettes/Windows position not saved after restart (or even in the same session) 
related to 0009707 closed Problems while using 2 monitors; Scribus with non-default Monitor 
related to 0013978 assignedcbradney Regression: Docked palettes position is not saved between sessions (0011544

Activities

cbradney

2012-03-14 21:12

administrator   ~0027810

So, I was able to set my 2nd screen to the left of my iMac like it sounds like you have your set up.

It seems the 0 X value is at the left of the iMac screen (that with the Dock in it) and a negative X value for a window or palette occurs when the item is on the left screen. Scribus opens and closes the palettes where I left them, not like you describe...

Kunda

2014-07-04 13:10

manager   ~0032473

robcander, would you respond to MrB and also check if issue still persists today with latest stable (or development version) of Scribus?
(Marking as feedback and poised to close if we don't hear from OP)

robcander

2014-07-04 13:36

reporter   ~0032476

Feedback

Issue is still present in Scribus 1.4.4. Scribus does not remember the position of the Properties window if a second screen is being used, always placing it at the left-hand side of the left-hand screen.

The problem is exacerbated by an issue with the Mac whereby if a second screen is attached, but not switched on, the screen is still detected by OSX.

Neither problem is serious, I just have to remember to unplug the second screen if I need to work with a single screen.

Thanks

Kunda

2014-07-04 13:45

manager   ~0032479

Robcander, thanks.

Craig, I've assigned this to you based on your participation and bumped this to 1.6 due to higher priorities of the upcoming 1.5.0 release.

cbradney

2015-02-01 15:31

administrator   ~0034412

Seems fine with 1.5.0...

Kunda

2015-02-01 15:50

manager   ~0034413

Last edited: 2015-02-01 15:51

View 2 revisions

robcander, can you test on the 1.5svn (link: http://sourceforge.net/projects/scribus/files/scribus-svn/1.5.0.svn/ ) to confirm ?
Note: Please install in to a separate directory or it will overwrite your current 1.4.4 Scribus application)

Kunda

2016-02-27 13:21

manager   ~0038915

Robcander, 1.5.1 has been released... can you test this ticket using https://sourceforge.net/projects/scribus/files/scribus-devel/1.5.1/scribus-1.5.1.dmg/download ?

Kunda

2016-03-22 12:42

manager   ~0039331

robcander, ping

Kunda

2016-04-24 13:04

manager   ~0040440

Related:
0009719
0009707

Kunda

2016-11-12 11:54

manager   ~0042402

Unable to reproduce in 1.5.x
Resolving

Issue History

Date Modified Username Field Change
2012-03-11 10:12 robcander New Issue
2012-03-11 12:51 jghali Severity major => minor
2012-03-14 21:12 cbradney Note Added: 0027810
2014-07-04 13:10 Kunda Note Added: 0032473
2014-07-04 13:10 Kunda Status new => feedback
2014-07-04 13:36 robcander Note Added: 0032476
2014-07-04 13:36 robcander Status feedback => new
2014-07-04 13:41 Kunda Assigned To => cbradney
2014-07-04 13:41 Kunda Status new => feedback
2014-07-04 13:41 Kunda Target Version => 1.6 milestone
2014-07-04 13:45 Kunda Note Added: 0032479
2014-10-08 18:37 Kunda Category Mac OS => OS-MacOSX
2015-02-01 15:22 Kunda Patch => No
2015-02-01 15:22 Kunda Summary Starting Scribus results in the Properties Window being displayed with a position of -1280 => OSX Dual Screen bug: Starting Scribus results in the Properties Window being displayed with a position of -1280
2015-02-01 15:31 cbradney Note Added: 0034412
2015-02-01 15:50 Kunda Note Added: 0034413
2015-02-01 15:51 Kunda Note Edited: 0034413 View Revisions
2016-02-27 13:21 Kunda Note Added: 0038915
2016-02-27 13:29 Kunda Tag Attached: dual-monitor
2016-02-27 13:29 Kunda Relationship added related to 0009719
2016-03-22 12:42 Kunda Note Added: 0039331
2016-04-24 13:04 Kunda Relationship added related to 0009707
2016-04-24 13:04 Kunda Note Added: 0040440
2016-05-04 05:29 Kunda Relationship added related to 0013978
2016-11-12 11:54 Kunda Status feedback => resolved
2016-11-12 11:54 Kunda Resolution open => unable to reproduce
2016-11-12 11:54 Kunda Note Added: 0042402
2016-11-21 01:38 Kunda Target Version 1.6 milestone =>
2016-12-05 20:21 cbradney Status resolved => closed
2016-12-08 21:39 cbradney Target Version => 1.5.3