View Issue Details

IDProjectCategoryView StatusLast Update
0010640ScribusDocumentationpublic2014-06-22 09:49
Reporternakamoto Assigned Tocbradney  
Status closedResolutionfixed 
PlatformMac OS XOSOS Version
Product Version1.4.1.svn 
Target VersionFixed in Version 
Summary0010640: Installing_from_SVN_on_Mac_OS_X Wiki is out-of-date.
DescriptionScribus Wiki ( says that cmake command should be:

cmake -DBUILD_OSX_BUNDLE=1 -DWANT_CAIRO=1 -DCMAKE_INSTALL_PREFIX:PATH=/Users/<your username>/Applications/Scribus.App/Contents/ ../trunk/Scribus/

However, as of 1.4.x, install path should be:

-DCMAKE_INSTALL_PREFIX:PATH=/Users/<your username>/Applications/

Other than that,
. WANT_CAIRO is not used ( so, should be removed )
. podofo should be mentioned as a required libary as Windows Wiki.
TagsNo tags attached.



2012-03-27 19:00

administrator   ~0027868

Why should the install path be as you suggest?
Why should podofo be marked as required? Its not required.


2012-03-27 21:33

reporter   ~0027870

Can you really build with the instruction in current page ?

If CMAKE_INSTALL_PREFIX:PATH=/Users/<your username>/Applications/Scribus.App/Contents/, cmake 2.8.7 builds Scribus.App/... in the path. So, Scribus.App/Contents/Scribus.App/... is built.

If podofo is not installed, cmake complains.
Podofo is listed as a required in :
, so it is consistent to list it on Mac build page.


2012-03-28 19:29

administrator   ~0027874

Yes.. my cmake line is:



2012-03-28 19:40

administrator   ~0027875

malex, jghali.. any idea why podofo is set as required on those pages? It is not a build requirement


2012-03-28 21:30

administrator   ~0027876

I do not see where podofo is listed as a requirement in cmake related instructions. It is a dependency yes, but optional.

On Windows, building with cmake has not really go past experimental stage and build instructions :
1) clearly mentions cmake is not the preferred way to build scribus on Windows
2) clearly mentions that user must retrieve latest build instructions in svn

Latest build instructions available on svn use the visual studio projects available in win32 directory. And for building with visual studio projects, podofo is required.


2012-03-28 21:33

reporter   ~0027877

Your cmake command line is different from the one on the page.
Does it affect the build location ?
Does the instructed cmake line really build correctly* ?


2012-03-29 01:12

reporter   ~0027878

Last edited: 2012-04-02 01:27

View 2 revisions

As cmake displays warning about importai/importps if podofo is not installed, it is more user-friendly to mention podofo as an optional dependency like the other platform-specific pages.

I built Scribus on several Mac OS X installations according to the instruction using macports, and always had to change CMAKE_INSTALL_PREFIX:PATH to avoid generating nested
I use macports 2.0.4 and cmake 2,8.7, the latest ones as of today. Are they different from yours ?

Here is the output of my cmake in Scribus/build directory.

cmake -DBUILD_OSX_BUNDLE=1 -DCMAKE_INSTALL_PREFIX:PATH=/Users/nakamoto/Applications/ ../

-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Checking whether C compiler has -isysroot
-- Checking whether C compiler has -isysroot - yes
-- Checking whether C compiler supports OSX deployment target flag
-- Checking whether C compiler supports OSX deployment target flag - yes
-- Check for working C compiler: /Developer/usr/bin/gcc
-- Check for working C compiler: /Developer/usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Checking whether CXX compiler has -isysroot
-- Checking whether CXX compiler has -isysroot - yes
-- Checking whether CXX compiler supports OSX deployment target flag
-- Checking whether CXX compiler supports OSX deployment target flag - yes
-- Check for working CXX compiler: /Developer/usr/bin/c++
-- Check for working CXX compiler: /Developer/usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Scribus 1.4.1.svn will be built to install into /Users/nakamoto/Applications
-- Machine: i686-apple-darwin11, void pointer size: 8
-- Found target X86
-- Found Snow Leopard Target: Apple, 64 bit, X86
-- Building for target i686-apple-darwin11
-- APPLEBUNDLE install prefix: /Users/nakamoto/Applications/
-- Using standard ApplicationDataDir. You can change it with -DAPPLICATION_DATA_DIR
Setting x86_64 Architecture for OSX Build/Bundle
-- x86_64 /Developer/SDKs/MacOSX10.7.sdk
-- OSX Minimum Version: 10.6
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - not found.
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - found
-- Looking for QT_MAC_USE_COCOA
-- Looking for QT_MAC_USE_COCOA - found
-- Found Qt4: /usr/bin/qmake (found suitable version "4.8.0", required is "4.6.0")
Qt4 Found OK
-- Building without Qt3 Support (GOOD)
-- Found ZLIB: /usr/lib/libz.dylib
ZLIB Library Found OK
-- Found PNG: /opt/local/lib/libpng.dylib
Using PNG Library: /opt/local/lib/libpng.dylib
PNG Library Found OK
-- Found JPEG: /opt/local/lib/libjpeg.dylib
JPEG Library Found OK
-- Found TIFF: /opt/local/lib/libtiff.dylib
TIFF Library Found OK
-- Found PythonLibs: /usr/lib/libpython2.7.dylib
Python Library Found OK
-- Found Freetype: /opt/local/lib/libfreetype.dylib
-- FreeType2 Library Found OK
-- Looking for FT_Get_First_Char in /opt/local/lib/libfreetype.dylib
-- Looking for FT_Get_First_Char in /opt/local/lib/libfreetype.dylib - found
-- Looking for FT_Get_Next_Char in /opt/local/lib/libfreetype.dylib
-- Looking for FT_Get_Next_Char in /opt/local/lib/libfreetype.dylib - found
-- checking for one of the modules 'libcairo>=1.2.0;cairo>=1.2.0'
CAIRO Library Found OK
-- Looking for ippDeleteAttribute in cups
-- Looking for ippDeleteAttribute in cups - found
-- Found Cups: /usr/lib/libcups.dylib
CUPS Library Found OK
-- Found LibXml2: /opt/local/lib/libxml2.dylib
LIBXML2 Library Found OK
LCMS 2 ReleaseLibrary: /opt/local/lib/liblcms2.dylib
LCMS 2 Library: /opt/local/lib/liblcms2.dylib
LittleCMS Library >= 2.1 Found OK
-- checking for one of the modules 'fontconfig'
FontConfig Found OK
ASpell or its developer libraries NOT found - Disabling support for spell checking
PoDoFo found OK
system hyphenation library NOT found - will use internal one
-- Check if the system is big endian
-- Searching 16 bit integer
-- Looking for sys/types.h
-- Looking for sys/types.h - found
-- Looking for stdint.h
-- Looking for stdint.h - found
-- Looking for stddef.h
-- Looking for stddef.h - found
-- Check size of unsigned short
-- Check size of unsigned short - done
-- Using unsigned short
-- Check if the system is big endian - little endian
-- Looking for dlfcn.h
-- Looking for dlfcn.h - found
-- Looking for unistd.h
-- Looking for unistd.h - found
-- Looking for sys/stat.h
-- Looking for sys/stat.h - found
-- Looking for include files HAVE_ENDIAN_H
-- Looking for include files HAVE_ENDIAN_H - not found.
-- Looking for include files HAVE_FCNTL_H
-- Looking for include files HAVE_FCNTL_H - found
RPATH: lib/scribus/plugins/;
-- Boost version: 1.49.0
Boost Library Found OK
-- Boost: FOUND, building 2geomtools
-- Source header files will be installed
-- /Users/nakamoto/SVN/Scribus/resources/translations/po
-- The following GUI languages will be installed:
-- Configuring done
CMake Warning at scribus/CMakeLists.txt:707 (ADD_EXECUTABLE):
  Cannot generate a safe linker search path for target Scribus because files
  in some directories may conflict with libraries in implicit directories:

    link library [libpython2.7.dylib] in /usr/lib may be hidden by files in:
    link library [libz.dylib] in /usr/lib may be hidden by files in:

  Some of these libraries may not be found correctly.

-- Generating done
-- Build files have been written to: /Users/nakamoto/SVN/Scribus/build


2012-04-05 01:47

reporter   ~0027900

The packaged has shared libraries inside.
It would be convenient for users that the page contains the information about the process of copying (and using install_name_tool to change the path ?).


2014-06-12 23:42

manager   ~0032121

Last edited: 2014-06-13 01:08

View 2 revisions

Nakamoto, do you want access to the wiki to alter this page? Or you can tell me what to change and I will change it. I am the author of the page. I haven't manually installed Scribus 1.5svn via SVN

EDIT: I've emphasized for users to use Scribus and Homebrew page instead.


2014-06-13 09:37

reporter   ~0032138

Last edited: 2014-06-13 09:57

View 2 revisions

I tried to build from svn (trunk) today, and failed.

1. Mac OS X 10.9 has <machine/endian.h>, but CMake fails in compiling a file which has <endian.h>.
2. Even after solving the problem above (by copying endian.h), the build fails in finding cairo, though cairo is already installed. Does it expect cairo under third_party directory rather than system default ?

So, I do not know what to say now.
I will try homebrew installation.

Edit: Installed, but does not work. "Scribus crashes due to Signal 0000011"


2014-06-13 11:58

manager   ~0032143

Last edited: 2014-06-13 12:00

View 2 revisions

What version of OS X are you running?

re: compile directly from SVN
I haven't tried to compile trunk without a package manager. You are running in to some odd errors. I have not had an issue before the <endian.h>. Cairo package I installed via homebrew (through the formula) because it was more up-to-date (note: it also required Xquartz as a dependency IIRC).

re: Homebrew installation
Ok, so this compiled all the way with no issue and then you opened it up and it Signal 0000011'd you?
Do me a favor and run:
brew gist-logs scribus-dev
and then send me the url that's generated


2014-06-16 00:57

reporter   ~0032190

Version = 10.9.3

Here you go:


2014-06-16 01:05

manager   ~0032191

I don't see an issue here. Nakamoto come to IRC (Freenode #scribus) or lets communicate through ML. This is preferred than communicating through the bugtracker


2014-06-16 01:23

reporter   ~0032192

It looks like exiting for some reason. The log is:[270]: (net.scribus.381248[677]) Exited with code: 255


2014-06-16 01:54

manager   ~0032193

@nakamoto please listen to my previous request. This is not the place to troubleshoot the build. Connect through or irc://

Issue History

Date Modified Username Field Change
2012-03-26 03:45 nakamoto New Issue
2012-03-27 19:00 cbradney Note Added: 0027868
2012-03-27 21:33 nakamoto Note Added: 0027870
2012-03-28 19:29 cbradney Note Added: 0027874
2012-03-28 19:40 cbradney Note Added: 0027875
2012-03-28 21:30 jghali Note Added: 0027876
2012-03-28 21:33 nakamoto Note Added: 0027877
2012-03-29 01:12 nakamoto Note Added: 0027878
2012-04-02 01:27 nakamoto Note Edited: 0027878 View Revisions
2012-04-05 01:47 nakamoto Note Added: 0027900
2014-06-12 23:42 Kunda Note Added: 0032121
2014-06-13 01:08 Kunda Note Edited: 0032121 View Revisions
2014-06-13 09:37 nakamoto Note Added: 0032138
2014-06-13 09:57 nakamoto Note Edited: 0032138 View Revisions
2014-06-13 11:58 Kunda Note Added: 0032143
2014-06-13 12:00 Kunda Note Edited: 0032143 View Revisions
2014-06-14 06:38 cbradney Status new => resolved
2014-06-14 06:38 cbradney Resolution open => fixed
2014-06-14 06:38 cbradney Assigned To => cbradney
2014-06-16 00:57 nakamoto Note Added: 0032190
2014-06-16 01:05 Kunda Note Added: 0032191
2014-06-16 01:23 nakamoto Note Added: 0032192
2014-06-16 01:54 Kunda Note Added: 0032193
2014-06-22 09:49 cbradney Status resolved => closed