View Issue Details

IDProjectCategoryView StatusLast Update
0010992ScribusUser Interfacepublic2019-06-18 07:52
ReporterJLuc Assigned Tocbradney  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status newResolutionreopened 
Product Version1.5.0svn 
Target VersionFixed in Version1.5.0svn 
Summary0010992: display possible keyboard modifiers for current action
DescriptionPossible modifiers are powerfull but would be easyer reminded and better used
when there would be a reminder of them somewhere on screen when usefull.
On the "info palette" or on the "statusbar" (since its a hint about current state's potential)
Additional InformationAs wikipedia states it, << a modifier key is a special key (or combination) on a computer keyboard that temporarily modifies the normal action of another key when pressed together. By themselves, modifier keys usually do nothing; that is, pressing any of the Shift, Alt, or Ctrl keys alone does not (generally) trigger any action from the computer. >>

For example, pressing the SHIFT key during a Resize-Frame action induces this resize action to be constrained so it keeps the vertical-horizontal ratio of the frame.
When begining a Resize-Frame action, the status bar would display "SHIFT : constrain ratio".
TagsNo tags attached.
PatchNo

Relationships

related to 0015713 closedJLuc Provide new "fixed viewport" image resize mode 

Activities

cbradney

2013-09-09 18:53

administrator   ~0030581

Commit 18469 now has fileNew working.

cbradney

2013-09-09 19:54

administrator   ~0030582

Commit #18470

JLuc

2013-09-12 21:44

developer   ~0030586

I was not clear enough.

With "Keyboard modifiers" i did not mean "keyboard shortcuts", but the keys that can be pressed so as to modify the current action.
Keyboard modifiers generaly are : SHIFT, CTRL, ALT, Fn (function), ALTGR key, and sometime Windows key (or SUPER key) or Command-Apple key afaik.
In other words wikipedia explains so (http://en.wikipedia.org/wiki/Modifier_key) : << a modifier key is a special key (or combination) on a computer keyboard that temporarily modifies the normal action of another key when pressed together. By themselves, modifier keys usually do nothing; that is, pressing any of the Shift, Alt, or Ctrl keys alone does not (generally) trigger any action from the computer. >>

For example, once the "create text frame" tool is selected, pressing the CTRL key changes the tool's action : it now creates a square.

The request is to display the active modifiers that the user can use with the current tool.
It could be displayed in the status bar since the current modifiers possibilities are part of the current state/status of scribus.

This text should change when the tool changes.

For example, when the "create text frame" tool is selected, the status bar would display for example :
"Create text frame (CTRL : square frame)"

When the "create image frame" tool is selected, the status bar would display
"Create image frame (SHIFT : full size ; CTRL : square frame)".

I choosed short explanations but they might be choosen longer and more explicit as long as there is room for these explanations in the status bar.

With these hints appearing, newcomers would discover new abilities... and so would also oldtimers, since since most of us dont know ALL of the shortcuts possibilities.
It would help to make the best use of Scribus existing strengths.

So I think this bug should be reopened as for now.

JLuc

2013-09-12 21:51

developer  

cbradney

2013-09-19 18:39

administrator   ~0030607

Jluc.. Please submit a patch. Code is around line 1700 of actionmanager.cpp. Eg:
    (*scrActions)["toolsInsertTextFrame"]->setStatusTextAndShortcut( tr("Insert a text frame"));

JLuc

2018-03-30 11:53

developer   ~0045125

Last edited: 2018-03-30 11:54

View 2 revisions

Commit #18470 (see https://www.scribus.net/websvn/comp.php?repname=Scribus&compare[]=%2F@18469&compare[]=%2F@18470) introduced new hint text for base actions, but did not add special hints for possible keyboard modifiers.

ale

2019-06-18 07:52

manager   ~0046323

the idea is very good.

but i'm not sure that the status bar is the right place for showing the information.

if we add it, we should do it in a way that in the future it's easy to move the messages from the status bar to a dedicated panel that would give hints to the user, with a bigger area available and a link for further information.

Issue History

Date Modified Username Field Change
2012-08-02 09:33 JLuc New Issue
2013-09-09 18:53 cbradney Note Added: 0030581
2013-09-09 18:53 cbradney Assigned To => cbradney
2013-09-09 18:53 cbradney Status new => assigned
2013-09-09 19:54 cbradney Note Added: 0030582
2013-09-09 19:54 cbradney Status assigned => resolved
2013-09-09 19:54 cbradney Fixed in Version => 1.5.0svn
2013-09-09 19:54 cbradney Resolution open => fixed
2013-09-12 21:44 JLuc Note Added: 0030586
2013-09-12 21:51 JLuc File Added: gimp status bar with modifier.png
2013-09-19 18:39 cbradney Note Added: 0030607
2013-10-30 21:39 cbradney Status resolved => closed
2018-03-30 11:53 JLuc Status closed => feedback
2018-03-30 11:53 JLuc Resolution fixed => reopened
2018-03-30 11:53 JLuc Note Added: 0045125
2018-03-30 11:53 JLuc Status feedback => new
2018-03-30 11:53 JLuc Patch => No
2018-03-30 11:54 JLuc Note Edited: 0045125 View Revisions
2018-03-30 16:36 JLuc Summary display possible keyboard modifiers => display possible keyboard modifiers for current action
2018-03-30 16:36 JLuc Additional Information Updated View Revisions
2018-03-30 16:38 JLuc Additional Information Updated View Revisions
2019-06-17 10:10 JLuc Relationship added related to 0015713
2019-06-18 07:52 ale Note Added: 0046323