View Issue Details

IDProjectCategoryView StatusLast Update
0000011ScribusStory Editor / Text Framespublic2015-02-23 19:16
Reportercbradney Assigned Tocbradney  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
PlatformallOSallOS Versionall
Product Version1.3 
Target VersionFixed in Version1.4.2.svn 
Summary0000011: Add Spellcheck functionality to Story Editor
DescriptionUsing one of the standard libraries existing on Linux (aspell, ispell, MySpell), or possibly even use Enchant (http://www.abiword.org/enchant/)
TagsNo tags attached.
PatchNo

Relationships

related to 0002576 acknowledged Add a GUI to create user dictionaries for hyphenation and short words (and spellchecking) 

Activities

cbradney

2003-11-19 16:47

administrator   ~0000003

Need to keep track of how KDE/KOffice are moving along with their spellchecking. The Enchant page mentioned the possible use of Enchant in the KOffice after 1.3. GnomeSpell and GTKSpell also have Enchant patches.

plinnell

2004-01-29 14:25

viewer   ~0000381

moving to 1.3+
in addition..Scribus only imports txt at the moment. Most editors have spell check i.e. kedit,gedit,OO

mhanski

2006-04-12 23:09

developer   ~0009880

on the roadmap for 1.3.8, changing the status to acknowledged

louisdesjardins

2006-04-13 11:32

developer   ~0009885

Can we relate this to 0001791 as I think this will be needed sooner or later if we are going to make a standalone Story Editor?

gora

2007-11-21 11:10

reporter   ~0017980

Hi,
  Here is an implementation of a spell-checker plugin, currently
using aspell, but with plans to move to enchant. Please see the
file README.user which describes the workflow for a typical user
interaction, and README.code which describes the code from a
developer's perspective.

This version will work with Scribus 1.3.5 SVN. Please note that
it has only been minimally tested, and that there are known issues
with the modified text in a text frame not being properly updated
after spell-checking (apparently, this is a display issue).

Regards,
Gora

2007-11-21 11:11

 

scribus-aspell-0.0.1.tar.gz (130,016 bytes)

fschmid

2007-11-23 22:24

administrator   ~0017995

Have added the most important parts now to SVN and adjusted the code to run with current SVN.

louisdesjardins

2010-06-25 02:36

developer   ~0024218

What’s the status of this at present time? Last note was in late 2007. The bug was reported on late 2003. Interesting!

christoph_s

2010-06-25 03:13

administrator   ~0024221

The spellchecker does basically work on Linux and OS X, but not on Windows and OS/2. Sooner or later we'll have to move from aspell to hunspell, because this is maintained for all platforms.

Issue History

Date Modified Username Field Change
2003-11-19 16:46 cbradney New Issue
2003-11-19 16:47 cbradney Note Added: 0000003
2004-01-29 14:25 plinnell Note Added: 0000381
2004-01-29 14:25 plinnell Priority normal => low
2004-01-29 14:25 plinnell ETA none => > 1 month
2004-01-29 14:25 plinnell Product Version => 1.3
2006-04-11 13:14 mhanski OS => all
2006-04-11 13:14 mhanski OS Version => all
2006-04-11 13:14 mhanski Platform => all
2006-04-11 13:14 mhanski Product Version 1.3 => 1.3.4cvs
2006-04-12 23:09 mhanski Note Added: 0009880
2006-04-12 23:09 mhanski Status new => acknowledged
2006-04-13 11:32 louisdesjardins Note Added: 0009885
2006-04-13 11:34 mhanski Relationship added related to 0001791
2006-04-13 23:13 plinnell Product Version 1.3.4cvs => 1.3
2006-04-14 13:59 mhanski Relationship added related to 0002576
2007-11-21 11:10 gora Note Added: 0017980
2007-11-21 11:11 gora File Added: scribus-aspell-0.0.1.tar.gz
2007-11-21 23:40 christoph_s Status acknowledged => assigned
2007-11-21 23:40 christoph_s Assigned To => plinnell
2007-11-23 21:32 plinnell Assigned To plinnell => fschmid
2007-11-23 22:24 fschmid Note Added: 0017995
2010-06-25 02:36 louisdesjardins Note Added: 0024218
2010-06-25 03:13 christoph_s Note Added: 0024221
2011-01-11 14:37 plinnell Priority low => normal
2011-01-11 14:37 plinnell Target Version => 1.6 milestone
2012-04-25 22:44 cbradney Assigned To fschmid => cbradney
2012-05-02 16:02 cbradney Status assigned => resolved
2012-05-02 16:02 cbradney Fixed in Version => 1.4.2.svn
2012-05-02 16:02 cbradney Resolution open => fixed
2012-05-09 21:23 cbradney Status resolved => closed
2015-02-23 19:16 Kunda Patch => No
2015-02-23 19:16 Kunda Target Version 1.6 milestone =>
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames
2016-05-06 19:41 JLuc Relationship deleted related to 0001791