View Issue Details

IDProjectCategoryView StatusLast Update
0001130ScribusGeneralpublic2016-03-06 10:09
Reporterblazej Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformOSMandrakeOS Version9.2
Product Version1.2.5cvs 
Target VersionFixed in Version 
Summary0001130: Problems with hyphenation
DescriptionThere are a few issues related to this feature - I'm putting them all together here.

1. When I click Extras | Hyphenate, it is unclear what this command applies to: current frame only, all linked frames, ... (see 0013743)
2. Hyphenating text doesn't raise the "Modified" flag on the document.
3. If I deselect "Fully Automatic" in Hyphenator Settings and then select Extras | Hyphenate, Scribus asks me about EVERY SINGLE word in my text. (See 0013744)
 - Why doesn't it only ask about words that are at line boundary?
 - It asks many times about the same word. It should learn!
4. When I select a frame and then select Extras | Hyphenate, the frame sometimes goes blank after that. I have to scroll to a different page and back to see the text. And the text in that frame is not always hyphenated. This only happens if the frame is part of a linked frames chain.

The bottom line is that the hyphenator is not very intuitive and behaves strangely at times.
TagsNo tags attached.
PatchNo

Relationships

related to 0001108 assignedavox Let user specify hyphenation exceptions 
related to 0004676 acknowledged feature to mark words as "do not hyphenate" 
related to 0001475 acknowledged hyphenation: use soft hyphen character (U+00AD) instead signed by ITEXT CSTYLE 8th bit attribute 
related to 0013743 new Extras > Hyphenate: unclear what this command applies to: current frame only, all linked frames ? 
related to 0013744 new Hyphenation: deselect "Fully Automatic" and then select Extras > Hyphenate issues 
child of 0003828 acknowledged Metabug: Hyphenation 

Activities

louisdesjardins

2004-09-20 11:56

developer   ~0002439

Last edited: 2005-07-23 22:15

I most agree with Blazej as his suggestions add up to what I reported on bug 0000971 and bug 0001108, both related to Hyphenation (interface, problem, new feature).

I think hyphenation needs attention as we are getting more and more people to use Scribus. For *long* text documents: it's a task we all want to let the computer do for us!

Blazej, please review (if not done already!) the two bugs cited above and let us know what you think, if you think the ideas there could help solve the issues you're facing.

The typographic quality of Scribus will be raised as much!

mhanski

2004-09-21 20:45

developer   ~0002452

Last edited: 2016-02-15 14:56

View 3 revisions

Blazej wrote in 0001129 :

"However, there is a another serious problem now:
I have multiple linked text frames.
After applying the hyphenation to the first one, all of them get hyphenated - cool!
PROBLEM: the dashes are visible ONLY in the first frame! Subsequent frames are hyphenated but the dashes are not visible!!!!

If someone figures this out, can they tell me how I can fix this on my machine - I need this hyphenator guy to work!"

mhanski:

I've been observing the same behaviour, the dashes become visible after a doubleclick in the second frame. However, the print preview looks fine then, it seems to be a display problem. Please hyphenate the attached test file to see the problem.

This issue has been made to a separate bug:
0001136

edited on: 04-09-22 07:34

2004-09-21 20:46

 

hyph_test.sla (8,286 bytes)

plinnell

2005-05-08 19:05

viewer   ~0004554

Last edited: 2016-02-15 14:31

View 2 revisions

1. When I click Extras | Hyphenate, it is unclear what this command applies to: current frame only, all linked frames

Current Frames

2. Hyphenating text doesn't raise the "Modified" flag on the document.

Fixed in 1.2.2

3. If I deselect "Fully Automatic" in Hyphenator Settings and then select Extras | Hyphenate, Scribus asks me about EVERY SINGLE word in my text.

Confirmed.

 - Why doesn't it only ask about words that are at line boundary?

Confirmed.

 - It asks many times about the same word. It should learn!

4. When I select a frame and then select Extras | Hyphenate, the frame sometimes goes blank after that. I have to scroll to a different page and back to see the text. And the text in that frame is not always hyphenated. This only happens if the frame is part of a linked frames chain.

This seems to be OK with 1.2.2cvs.

plinnell

2005-05-08 19:07

viewer   ~0004555

Thanks for the test case also. Very helpful.

plinnell

2005-12-26 19:32

viewer   ~0007817

bumping to 1.2.5, as we cannot apply a fix without breaking strings.

Le_Tigre

2006-02-15 13:12

reporter   ~0008764

It would be very useful to refuse an hyphenation.

When choosing automatic hyphenation, if you see a word that shouldn't be cut (eg country or cities names), you should say: I don't want that hyphenation (without having to use the manual editor). Or just delete the hyphen.

Related: when you choose a manual optionnal hyphen, you should be able to delete it. At this moment, you have to delete a character and the retype it.

louisdesjardins

2006-02-19 23:24

developer   ~0008816

Last edited: 2016-02-15 14:37

View 2 revisions

Actually, what we need is a way of telling Scribus not to hyphenate a specific word in a specific situation. (0004676)

QXP does that when you type the smart hyphen in front of a word. Otherwise, you can type a smart hyphen elsewhere in the word. For further fine tuning, the "hyphenation exception" dialog is there to help.

Kunda

2016-02-15 14:58

manager   ~0038757

Last edited: 2016-02-15 15:03

View 2 revisions

Split off
Issue 1. and created 0013743
Issue 3. and created 0013744

Kunda

2016-02-15 15:05

manager   ~0038758

Cleaned up ticket and split up issues in to other ticket. Resolving this in favor of those split tickets

Issue History

Date Modified Username Field Change
2004-09-20 02:29 blazej New Issue
2004-09-20 11:56 louisdesjardins Note Added: 0002439
2004-09-21 20:45 mhanski Note Added: 0002452
2004-09-21 20:46 mhanski File Added: hyph_test.sla
2004-09-22 05:34 mhanski Note Edited: 0002452
2005-05-08 19:05 plinnell Note Added: 0004554
2005-05-08 19:07 plinnell Note Added: 0004555
2005-05-08 19:07 plinnell Status new => confirmed
2005-05-08 19:07 plinnell Product Version 1.2 => 1.2.2cvs
2005-07-06 11:16 plinnell Product Version 1.2.2cvs => 1.2.3cvs
2005-07-23 22:15 louisdesjardins Note Edited: 0002439
2005-09-12 07:01 plinnell Product Version 1.2.3cvs => 1.2.4cvs
2005-12-26 19:32 plinnell Note Added: 0007817
2005-12-26 19:32 plinnell Product Version 1.2.4cvs => 1.2.5cvs
2006-01-31 13:16 plinnell Relationship added related to 0001475
2006-02-15 13:12 Le_Tigre Note Added: 0008764
2006-02-19 23:24 louisdesjardins Note Added: 0008816
2006-05-16 21:57 christoph_s Relationship added child of 0003828
2016-02-15 14:31 Kunda Note Edited: 0004554 View Revisions
2016-02-15 14:32 Kunda Patch => No
2016-02-15 14:32 Kunda Description Updated View Revisions
2016-02-15 14:33 Kunda Relationship added related to 0001108
2016-02-15 14:37 Kunda Note Edited: 0008816 View Revisions
2016-02-15 14:37 Kunda Relationship added related to 0004676
2016-02-15 14:55 Kunda Relationship added related to 0013743
2016-02-15 14:55 Kunda Note Edited: 0002452 View Revisions
2016-02-15 14:56 Kunda Note Edited: 0002452 View Revisions
2016-02-15 14:56 Kunda Description Updated View Revisions
2016-02-15 14:58 Kunda Note Added: 0038757
2016-02-15 15:02 Kunda Relationship added related to 0013744
2016-02-15 15:03 Kunda Description Updated View Revisions
2016-02-15 15:03 Kunda Note Edited: 0038757 View Revisions
2016-02-15 15:05 Kunda Note Added: 0038758
2016-02-15 15:05 Kunda Status confirmed => resolved
2016-02-15 15:05 Kunda Resolution open => duplicate
2016-02-15 15:05 Kunda Assigned To => Kunda
2016-02-15 15:05 Kunda Assigned To Kunda =>
2016-03-06 10:09 cbradney Status resolved => closed