View Issue Details

IDProjectCategoryView StatusLast Update
0011359ScribusStory Editor / Text Framespublic2016-05-11 03:55
ReporterJLuc Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version1.5.2Fixed in Version1.5.2.svn 
Summary0011359: Missing redraw of inline frames
Description1 [Fixed] when scrolling the page, previously not displayed inline frames are not drawn and appear as blank zones. For example scrolling up (the inline frame is outside screen) and down back to original place : the inline frame has disappeared.

2) when editing an inline frame (in special edit mode), display should be updated after changing the inline-frame's dimensions
Tagsinline
PatchNo

Relationships

related to 0013698 confirmed Missing Redraw of Selected Page Border 
related to 0008553 closedKunda canvas does not reflect new document area after resizing 
related to 0013141 confirmed Inline edit exit : display jumps to last linked text frame 
related to 0012067 closedfschmid Inline Items are wrongly placed in Text Frames 
child of 0013075 acknowledged Metabug: missing display refresh 

Activities

JLuc

2013-07-12 17:29

developer   ~0030433

Last edited: 2013-07-18 17:02

View 4 revisions

In today scribus 1.5, only the bottom part of the inline image frame is displayed when i scroll the whole doc.

AMOF the same problem happens

- with inline text frames

- for links between linked text frames : only bits are displayed

Kunda

2015-11-06 12:48

updater   ~0037280

jluc, can you retest please

Kunda

2016-01-31 14:00

updater   ~0038505

I think that the issues jluc is pointing out are being addressed in the following:
0008548
0013108
0013470
+ all the rest of them in the Metabug 0013075

Is it safe to close this ticket as duplicate, jluc?

fschmid

2016-02-07 12:56

administrator   ~0038557

Part 1 is fixed now.

Kunda

2016-02-08 17:11

updater   ~0038563

Jluc, I'm not sure I know how to test fix. Can you confirm? Also does this ticket have any duplicates in 0013075 ?

Franz, thanks!

JLuc

2016-02-08 20:43

developer   ~0038567

Kunda : not a duplicate.

JLuc

2016-02-08 20:53

developer   ~0038568

I confirm : first point is fixed. I edit the report to mention it.

JLuc

2016-02-08 20:58

developer   ~0038569

And i dont reproduce 2nd point anymore. ( Either it has been fixed at some point, or i dont understand anymore how to produce it. )

Kunda

2016-02-08 23:40

updater   ~0038571

Franz, can you reproduce 2) ?

Kunda

2016-02-09 16:58

updater   ~0038590

Is 0008553 also related ?

JLuc

2016-02-09 17:07

developer   ~0038592

kunda : I dont see why you say 'also'. The present issue is related to inline objects.

Kunda

2016-02-09 19:29

updater   ~0038596

looks like a similar phenomena just in another component(?) of the canvas ?

Kunda

2016-05-10 19:16

updater   ~0040949

franz committed fix in r21301
Please test

Kunda

2016-05-11 03:43

updater   ~0040957

jluc, please test. thx

Kunda

2016-05-11 03:55

updater   ~0040958

Closing per 0011359:0038569

Issue History

Date Modified Username Field Change
2013-01-07 19:48 JLuc New Issue
2013-07-12 17:29 JLuc Note Added: 0030433
2013-07-15 22:57 JLuc Note Edited: 0030433 View Revisions
2013-07-18 17:02 JLuc Note Edited: 0030433 View Revisions
2013-07-18 17:02 JLuc Note Edited: 0030433 View Revisions
2015-06-27 02:31 Kunda Relationship added child of 0013075
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames
2015-11-06 12:48 Kunda Note Added: 0037280
2016-01-31 12:26 Kunda File Added: doc-outline-missing-refresh.gif
2016-01-31 12:28 Kunda Patch => No
2016-01-31 12:28 Kunda Target Version => 1.5.3
2016-01-31 12:28 Kunda Summary redraw inline frames => Missing redraw of inline frames
2016-01-31 12:35 Kunda File Deleted: doc-outline-missing-refresh.gif
2016-01-31 14:00 Kunda Note Added: 0038505
2016-02-07 12:56 fschmid Note Added: 0038557
2016-02-08 17:11 Kunda Note Added: 0038563
2016-02-08 20:43 JLuc Note Added: 0038567
2016-02-08 20:53 JLuc Note Added: 0038568
2016-02-08 20:53 JLuc Description Updated View Revisions
2016-02-08 20:58 JLuc Note Added: 0038569
2016-02-08 23:12 Kunda Relationship added related to 0013698
2016-02-08 23:40 Kunda Note Added: 0038571
2016-02-09 16:58 Kunda Note Added: 0038590
2016-02-09 16:58 Kunda Relationship added related to 0008553
2016-02-09 17:07 JLuc Note Added: 0038592
2016-02-09 19:29 Kunda Note Added: 0038596
2016-04-14 14:19 Kunda Relationship added related to 0013141
2016-04-14 14:20 Kunda Tag Attached: inline
2016-05-10 12:10 Kunda Tag Attached: #screen[shot|cast] needed
2016-05-10 19:03 fschmid Status new => resolved
2016-05-10 19:03 fschmid Fixed in Version => 1.5.2.svn
2016-05-10 19:03 fschmid Resolution open => fixed
2016-05-10 19:03 fschmid Assigned To => fschmid
2016-05-10 19:15 Kunda Relationship added related to 0012067
2016-05-10 19:16 Kunda Note Added: 0040949
2016-05-11 03:43 Kunda Note Added: 0040957
2016-05-11 03:54 Kunda Target Version 1.5.3 => 1.5.2
2016-05-11 03:55 Kunda Note Added: 0040958
2016-05-11 03:55 Kunda Status resolved => closed
2016-05-11 03:55 Kunda Tag Detached: #screen[shot|cast] needed