View Issue Details

IDProjectCategoryView StatusLast Update
0011369ScribusStory Editor / Text Framespublic2019-12-08 21:24
ReporterJLuc Assigned Tojghali  
PriorityhighSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version1.4.2.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0011369: Scribus doesn't show the search results outside the viewport or outside of linked textframe
DescriptionAs far as i can experiment it, scribus do not show the results of its search.

It might hilight the result with selection, but when it is outside viewport, scribus leaves it as is, and result is left secret.

Scribus should move the viewport to the result.
TagsMABs, usability
PatchNo

Relationships

has duplicate 0014919 closedjghali Find and replace highlight issue 
has duplicate 0015528 closedjghali Search/replace severe shortcomings 
related to 0003858 new Zoom doesn't recognise cursor placement 
child of 0003157 acknowledged Metabug: Cursor placement fixes 
child of 0012755 new Metabug: Search & Replace (1.5.x svn) 

Activities

JLuc

2013-03-03 22:13

developer   ~0029953

More explanations :

Imagine you have a big text frame and a big zoom : viewport only display part of the frame
or imagine you have 3 linked text frames : viewport only displays first text frame

When searching a string, the answer (the found string) could be *outside* the viewport (not displayed).

Problem is that in such a situation, Scribus do not scroll to this "found" position.

So the search might have succeeded and found the string, but it is not possible to use the result since it remains hidden !

The viewport should move to the "found" position, so it is possible to see it.

JLuc

2013-10-25 08:25

developer   ~0030777

Same happens when double-clicking on the footnotes REcall in the footnote frame : focus is brought to footnote call in the main text frame, but this place might be out of the viewport because viewport is centered on the center of the frame.
The (not called or not existing yet) "move viewport to precise edit place" function should be used there too.

JLuc

2014-04-23 15:47

developer   ~0031774

see also 0003858: Zoom doesn't recognise cursor placement

Pancho

2014-04-23 16:30

reporter   ~0031776

Actually this is at least two issues which I can both confirm:

- the search & replace dialog doesn't bring the matched result into viewport if it's not yet there.

- when searching in linked text frames, the result is only highlighted if it happens to be in the active text frame.

- when doing a replace operation in linked text frames, even if it happens to be on viewport, the replacement is only displayed if it has taken place in the active text frame. The change can only be observed after the dialog is closed.

So what we'd need to do is:
- move the first/next search result into viewport
- focus and highlight the search result
- after any replacement has taken place: redraw the whole viewport or the linked frame that is really affected
- when closing the dialog: leave the edit cursor at the current search result with the search result being marked.

Even better if the dialog wasn't modal, so it would be possible to do manual corrections, or undo any replacement at once, without closing the search dialog.

Issue History

Date Modified Username Field Change
2013-01-13 18:59 JLuc New Issue
2013-03-03 22:13 JLuc Note Added: 0029953
2013-03-03 22:16 christoph_s Status new => confirmed
2013-03-04 09:08 christoph_s Priority high => normal
2013-10-25 08:25 JLuc Note Added: 0030777
2014-03-23 10:14 JLuc Tag Attached: foundation
2014-04-06 10:50 JLuc Tag Attached: usability
2014-04-23 15:47 JLuc Note Added: 0031774
2014-04-23 16:30 Pancho Note Added: 0031776
2014-07-17 01:23 Kunda Relationship added related to 0003858
2014-07-17 01:24 Kunda Relationship added child of 0003157
2014-07-23 21:41 Kunda Summary Scribus dont show the search results => Scribus doesn't show the search results
2014-10-04 19:15 JLuc Tag Detached: foundation
2014-10-08 00:08 Kunda Relationship added child of 0012755
2014-11-06 19:28 Kunda Tag Attached: MABs
2014-12-24 16:45 JLuc Patch => No
2014-12-24 16:45 JLuc Priority normal => high
2015-02-16 08:52 Kunda Summary Scribus doesn't show the search results => Scribus doesn't show the search results (*outside* the viewport or outside of linked textframe)
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames
2017-07-21 09:28 jghali Relationship added has duplicate 0014919
2019-01-08 17:19 jghali Relationship added has duplicate 0015528
2019-11-17 12:59 JLuc Severity major => feature
2019-12-05 06:34 jghali Summary Scribus doesn't show the search results (*outside* the viewport or outside of linked textframe) => Scribus doesn't show the search results outside the viewport or outside of linked textframe
2019-12-05 06:36 jghali Assigned To => jghali
2019-12-05 06:36 jghali Status confirmed => resolved
2019-12-05 06:36 jghali Resolution open => fixed
2019-12-05 06:36 jghali Fixed in Version => 1.5.6.svn
2019-12-08 21:24 cbradney Status resolved => closed