View Issue Details

IDProjectCategoryView StatusLast Update
0011537ScribusStylespublic2014-07-14 15:50
Reporterdetly Assigned Tocbradney  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
PlatformLinux amd64OSUbuntuOS Version12.10 (quantal)
Product Version1.5.0svn 
Target VersionFixed in Version 
Summary0011537: Creating new character style causes crash due to signal 0000006
DescriptionAttempting to create a new character style causes Scribus to crash due to signal 0000006.
Steps To Reproduce1. Start scribus-trunk
2. Create any new document
3. Do Edit > Styles
4. Do New > Character Style

The style manager dialog appears, but so does a message box saying "Scribus crashes due to Signal 0000006".

Console output is:

scribus-trunk
"en_AU.UTF-8"
ASSERT: "di != -1" in file /build/buildd/scribus-trunk-1.5.0svn201305220336/scribus/ui/smcstylewidget.cpp, line 297
Scribus Crash
-------------
Scribus crashes due to Signal 0000006
Calling Emergency Save
Additional InformationThe exact version of Scribus I tried this on was: 1.5.0svn201305220336-24~quantal1

If it helps, the version of libqtcore4 is: 4:4.8.3+dfsg-0ubuntu3.1
TagsNo tags attached.
Patch

Activities

christoph_s

2013-05-22 18:12

administrator   ~0030160

I can't replicate this.

jghali

2013-05-22 19:31

administrator   ~0030162

Cannot reproduce either...

bubu

2013-05-22 19:53

reporter   ~0030163

I can't reproduce this. (Ubuntu 13.04, trunk, Hungarian locale)

detly

2013-05-24 11:11

reporter   ~0030173

I created a new user profile, and couldn't reproduce this problem on it. Then I tried renaming my normal ~/.scribus dir and restarting Scribus, and the problem disappeared.

So either you can close this as invalid, or if you want to know what's causing it I'll let you know when I find out.

(I do run both scribus and scribus-trunk, depending on what I need to do, and it does appear that they share ~/.scribus, so maybe that's causing problems.)

detly

2013-05-25 14:47

reporter   ~0030177

I just wanted to add: I managed to track down what caused the crash. Scribus creates the file ~/.scribus/scribus150.rc, which has an entry at line 543. On my system, this is:

<Hyphenator WordLength="3" AutomaticCheck="0" HyphenCount="2" Automatic="1" Language="en_GB"/>

If I change the 'en_GB' to 'en', I get the crash.

My locale is, in fact, neither en_GB nor en, it's en_AU.

Issue History

Date Modified Username Field Change
2013-05-22 09:27 detly New Issue
2013-05-22 18:12 christoph_s Note Added: 0030160
2013-05-22 19:31 jghali Note Added: 0030162
2013-05-22 19:53 bubu Note Added: 0030163
2013-05-24 11:11 detly Note Added: 0030173
2013-05-25 05:05 christoph_s Status new => resolved
2013-05-25 05:05 christoph_s Resolution open => unable to reproduce
2013-05-25 05:05 christoph_s Assigned To => christoph_s
2013-05-25 05:05 christoph_s Status resolved => closed
2013-05-25 14:47 detly Note Added: 0030177
2013-05-25 14:47 detly Status closed => feedback
2013-05-25 14:47 detly Resolution unable to reproduce => reopened
2013-05-26 06:31 christoph_s Assigned To christoph_s => cbradney
2013-05-26 06:31 christoph_s Status feedback => assigned
2014-07-14 15:50 FirasH Status assigned => closed
2014-07-14 15:50 FirasH Resolution reopened => no change required