View Issue Details

IDProjectCategoryView StatusLast Update
0011544ScribusUser Interfacepublic2016-04-25 12:07
Reportercezaryece Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformallOSOS Version
Product Version1.5.0svn 
Target Version1.5.2Fixed in Version1.5.2.svn 
Summary0011544: Docked palettes position / size is not saved between sessions.
DescriptionIf you organize your docked palettes in one docking area (let say on the right I have PP and ScrapBook organized in tabs so each one take whole available height when selected) it is not saved while closing Scribus and after new run you have the palettes in default vertical order without tabs.
If you organize docked palettes in some vertical order (ScrapBook above PP) and height then after new run you have it in default order and size.
Additional InformationMy proposal is not only saving palettes order or size.
I would like to
1. have all screen layout saved with document (palettes visibility/layout, view layout set in View menu)
2. have possibility to save some screen layouts in preferences and choosing them on the fly (0004262)
TagsNo tags attached.
PatchNo

Relationships

related to 0004262 acknowledged (Layout Profiles) Add ability to save and load window layouts  
related to 0013808 closedfschmid Regression: Ghost Palettes 
has duplicate 0012081 closedjghali Grouped "Windows" disposition is not restored after restarting Scribus 
has duplicate 0012094 closedjghali No save panel position 
has duplicate 0012221 closedjghali After exiting windows last position will not restore. 
has duplicate 0012445 closedjghali docking palettes in tabs does not survive restart 
has duplicate 0012587 closedjghali PP forgets palette placement 
has duplicate 0012968 closedjghali tabbing of panes is not retained 
has duplicate 0013009 closedjghali Overlapped docked window arent overlaped anymore after restart 
has duplicate 0011017 closedfschmid Palettes: By default, show them docked instead of undocked 
related to 0011511 closed "Corner Toolbar" visibility state amnesia 
related to 0009719 confirmed Palettes/Windows position not saved after restart (or even in the same session) 
related to 0013978 assignedcbradney Regression: Docked palettes position is not saved between sessions (0011544

Activities

JLuc

2014-04-24 08:12

developer   ~0031800

I confirm.

Kunda

2014-07-14 16:18

manager   ~0032740

Last edited: 2014-07-14 16:35

View 2 revisions

Can reproduce on r19342
FirasH made a screencast: https://www.dropbox.com/s/ov4hm9abxcbt5u6/11544.mp4

fschmid

2016-02-21 08:59

administrator   ~0038853

Hmm, difficult to solve as Qt itself lacks functions to save and restore the tabbified order of docked palettes.

Kunda

2016-02-27 13:11

manager   ~0038913

Cool, this is fixed in r21040 on OSX 10.10.5 1.5.2svn
Thanks Franz

PeterBenedek

2016-02-28 16:55

developer   ~0038928

This is great! I have been waiting!

Kunda

2016-03-04 17:19

manager   ~0038973

Franz, can you reproduce 0009719 as well ?

Kunda

2016-03-12 11:38

manager   ~0039144

Last edited: 2016-03-12 11:41

View 2 revisions

Menus are acting funny. 2 observations:
1) they aren't being saved correctly between sessions. For example if I move palette in to the left panel so that they each take up the full size of the panel and a dropdown menu appears so that one can toggle through them.. then over time perhaps between several different scribus sessions (not sure) if one moves one of those palettes and closes Scribus.. upon re-opening the dropdown menu configuration re-appears. Scribus doesn't remember the previous state correctly.
2) Regression: Scribus is acting like it has ghost palettes. see screencast in 0013808

Kunda

2016-03-14 18:01

manager   ~0039166

Last edited: 2016-03-14 18:05

View 2 revisions

Franz, u/l a screencast showing that palettes positions are not saved between sessions.
OSX 10.10.5 1.5.2svn r21084

Kunda

2016-03-14 18:01

manager  

remember-docks.gif (366,859 bytes)
remember-docks.gif (366,859 bytes)

Kunda

2016-03-22 12:41

manager   ~0039330

Looks like it's fixed after updating to Qt5.6
Thanks again Franz!

Issue History

Date Modified Username Field Change
2013-05-27 07:00 cezaryece New Issue
2014-02-22 17:47 jghali Relationship added has duplicate 0012081
2014-02-25 16:45 jghali Relationship added has duplicate 0012094
2014-04-19 11:33 jghali Relationship added has duplicate 0012221
2014-04-24 08:12 JLuc Note Added: 0031800
2014-06-27 09:09 jghali Relationship added has duplicate 0012445
2014-07-14 16:18 Kunda Note Added: 0032740
2014-07-14 16:18 Kunda Status new => feedback
2014-07-14 16:35 Kunda Note Edited: 0032740 View Revisions
2014-07-14 16:35 Kunda Status feedback => confirmed
2014-07-14 20:45 Kunda Target Version => 1.5.1
2014-08-04 07:52 jghali Relationship added has duplicate 0012587
2014-08-29 12:10 Kunda Relationship added related to 0011511
2015-04-01 10:55 jghali Relationship added has duplicate 0012968
2015-04-12 14:41 jghali Relationship added has duplicate 0013009
2015-04-15 17:56 JLuc Relationship added related to 0009719
2016-01-23 17:17 cbradney Target Version 1.5.1 => 1.5.3
2016-02-21 08:59 fschmid Note Added: 0038853
2016-02-27 10:37 fschmid Status confirmed => resolved
2016-02-27 10:37 fschmid Fixed in Version => 1.5.2.svn
2016-02-27 10:37 fschmid Resolution open => fixed
2016-02-27 10:37 fschmid Assigned To => fschmid
2016-02-27 13:11 Kunda Note Added: 0038913
2016-02-27 13:12 Kunda Patch => No
2016-02-27 13:12 Kunda Target Version 1.5.3 => 1.5.2
2016-02-27 13:30 Kunda Additional Information Updated View Revisions
2016-02-27 13:31 Kunda Relationship added related to 0004262
2016-02-28 16:55 PeterBenedek Note Added: 0038928
2016-03-02 22:16 Kunda Relationship added related to 0011017
2016-03-04 02:27 Kunda Relationship replaced has duplicate 0011017
2016-03-04 17:19 Kunda Note Added: 0038973
2016-03-06 10:09 cbradney Status resolved => closed
2016-03-12 11:38 Kunda Note Added: 0039144
2016-03-12 11:38 Kunda Status closed => feedback
2016-03-12 11:38 Kunda Resolution fixed => reopened
2016-03-12 11:41 Kunda Note Edited: 0039144 View Revisions
2016-03-12 11:41 Kunda Relationship added related to 0013808
2016-03-14 18:01 Kunda Note Added: 0039166
2016-03-14 18:01 Kunda File Added: remember-docks.gif
2016-03-14 18:05 Kunda Note Edited: 0039166 View Revisions
2016-03-22 12:41 Kunda Note Added: 0039330
2016-03-22 12:41 Kunda Status feedback => closed
2016-03-22 12:41 Kunda Resolution reopened => fixed
2016-04-25 12:07 Kunda Relationship added related to 0013978