View Issue Details

IDProjectCategoryView StatusLast Update
0011661ScribusStory Editor / Text Framespublic2019-05-09 18:14
Reporterzerubbabel Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionreopened 
PlatformLinuxOSKubuntuOS Version13.04
Product Version1.5.0svn 
Target Version1.5.4Fixed in Version 
Summary0011661: Numbering of all footnotes is zero
DescriptionI created a simple layout to see how the footnotes feature works, importing a LibreOffice document with footnotes. The footnotes were displayed properly at the bottom of the text frames, with their correct footnote numbers. I saved the file, then a few days later I checked out the latest version and built the updated version (Build-ID C-C-T-F-C1.12.14-64bit), then ran it and opened the same file that I had saved a few days earlier. The footnote references are correctly numbered in the text, but the footnotes all have zero (0) as their number. I'm attaching a zip file containing the actual source files, including a pdf showing how it looks on my screen.
Tags#please_test, #rottenpatch, footnotes
PatchYes

Relationships

duplicate of 0015681 new Crash when deleting text with footnotes 
related to 0013280 closed [OSX] Importing an .sla crashes with Sig11 
child of 0012496 acknowledged Metabug: Marks & Footnotes & Weld (1.5.0.svn) 

Activities

zerubbabel

2013-07-13 00:28

reporter  

Spanking.zip (400,962 bytes)

JLuc

2013-07-15 06:40

developer   ~0030445

would you upload ODT imported document ?

zerubbabel

2013-07-15 09:09

reporter  

DZ_LawAgainstLove.odt (42,481 bytes)

cezaryece

2013-10-23 12:37

developer   ~0030760

Fixed in footntoes_fix branch in scribus.git

jghali

2013-10-23 13:27

administrator   ~0030763

This issue has not been reported against a contributor build. So please do not mark a bug as resolved unless it is fixed in *SVN*.

JLuc

2013-10-23 17:49

developer   ~0030765

I tested importing the ODT document and found i could not reproduce the issue, neither with last QT4 1.5 svn (end of august version), nor with the footnotes_fix GIT version : the notes are imported and are correctly numbered from 1 to 7, and i can save and reopen the doc with notes being ok.

However i found a crash issue on the new GIT branch : after importing the uploaded ODT (and auto-creating the notes) into a set of 4 linked text frames, scribus crashes when :
- Double click first frame,
- Edit > Select all (or CTRL+A)
- Delete

bt is as follow :

ASSERT failure in QList<T>::at: "index out of range", file /usr/include/qt5/QtCore/qlist.h, line 454

Program received signal SIGABRT, Aborted.
0xb7fdd424 in __kernel_vsyscall ()
(gdb) bt
#0 0xb7fdd424 in __kernel_vsyscall ()
0000001 0xb6943b1f in raise () from /lib/i386-linux-gnu/libc.so.6
0000002 0xb69470b3 in abort () from /lib/i386-linux-gnu/libc.so.6
0000003 0xb7add553 in QMessageLogger::fatal(char const*, ...) const ()
   from /usr/lib/i386-linux-gnu/libQt5Core.so.5
0000004 0xb7ada143 in qt_assert_x(char const*, char const*, char const*, int) ()
   from /usr/lib/i386-linux-gnu/libQt5Core.so.5
0000005 0x08d0ac26 in QList<ScText*>::at (this=0xa087168, i=11861)
    at /usr/include/qt5/QtCore/qlist.h:454
0000006 0x08d02a7b in StoryText::hasMarkType (this=0xa084fb0, pos=11861,
    mt=MARKBullNumType)
    at /home/jluc1304/dev/git/Scribus/scribus/text/storytext.cpp:833
0000007 0x085793ba in PageItem_TextFrame::removeMarksFromText (this=0xa084cf8,
    doUndo=true)
    at /home/jluc1304/dev/git/Scribus/scribus/pageitem_textframe.cpp:6042
0000008 0x0857025f in PageItem_TextFrame::deleteSelectedTextFromFrame (
    this=0xa084cf8)
    at /home/jluc1304/dev/git/Scribus/scribus/pageitem_textframe.cpp:4820
0000009 0x0856d874 in PageItem_TextFrame::handleModeEditKey (this=0xa084cf8,
    k=0xbfffee44, keyRepeat=@0x92e55eb: true)
    at /home/jluc1304/dev/git/Scribus/scribus/pageitem_textframe.cpp:4526
0000010 0x08788c8e in ScribusMainWindow::keyPressEvent (this=0x92e5428,
    k=0xbfffee44) at /home/jluc1304/dev/git/Scribus/scribus/scribus.cpp:1719
---Type <return> to continue, or q <return> to quit---
0000011 0x088a6494 in ScribusView::eventFilter (this=0x9ef2b38, obj=0x9ef2b38,
    event=0xbfffee44)
    at /home/jluc1304/dev/git/Scribus/scribus/scribusview.cpp:4402
0000012 0xb7c8a0cc in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQt5Core.so.5
0000013 0xb753e90d in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
0000014 0xb754182e in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
0000015 0xb7c89ebe in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /usr/lib/i386-linux-gnu/libQt5Core.so.5
0000016 0xb759f98c in ?? () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
0000017 0xb75a2634 in ?? () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
0000018 0xb753e93c in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
0000019 0xb7540bce in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
0000020 0xb7c89ebe in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /usr/lib/i386-linux-gnu/libQt5Core.so.5
0000021 0xb712789d in QGuiApplicationPrivate::processKeyEvent(QWindowSystemInterfacePrivate::KeyEvent*) () from /usr/lib/i386-linux-gnu/libQt5Gui.so.5
0000022 0xb712af10 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib/i386-linux-gnu/libQt5Gui.so.5
0000023 0xb7117a66 in QWindowSystemInterface::sendWindowSystemEventsImplementation(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib/i386-linux-gnu/libQt5Gui.so.5
0000024 0xb7117acf in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQt5Gui.so.5
0000025 0xb17383a1 in ?? ()
   from /usr/lib/i386-linux-gnu/qt5/plugins/platforms/libqxcb.so
0000026 0xb62b63b3 in g_main_context_dispatch ()
   from /lib/i386-linux-gnu/libglib-2.0.so.0
0000027 0xb62b6750 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
0000028 0xb62b6831 in g_main_context_iteration ()
   from /lib/i386-linux-gnu/libglib-2.0.so.0
0000029 0xb7cd836f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQt5Core.so.5
0000030 0xb17385f6 in ?? ()
   from /usr/lib/i386-linux-gnu/qt5/plugins/platforms/libqxcb.so
0000031 0xb7c88746 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQt5Core.so.5
0000032 0xb7c88bac in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib/i386-linux-gnu/libQt5Core.so.5
0000033 0xb7c8edf2 in QCoreApplication::exec() ()
   from /usr/lib/i386-linux-gnu/libQt5Core.so.5
---Type <return> to continue, or q <return> to quit---
0000034 0xb7122634 in QGuiApplication::exec() ()
   from /usr/lib/i386-linux-gnu/libQt5Gui.so.5
0000035 0xb753d664 in QApplication::exec() ()
   from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
0000036 0x08cd93ea in mainApp (argc=1, argv=0xbffff2c4)
    at /home/jluc1304/dev/git/Scribus/scribus/main_nix.cpp:86
0000037 0x08cd9373 in main (argc=1, argv=0xbffff2c4)
    at /home/jluc1304/dev/git/Scribus/scribus/main_nix.cpp:54

JLuc

2013-10-23 17:53

developer  

footnotes_fix odt import note numbers.sla (42,057 bytes)

JLuc

2013-10-23 17:55

developer   ~0030766

Last edited: 2013-10-23 17:55

View 2 revisions

I've uploaded the SLA resulting (with the footnotes_fix GIT branch) of the import of the spanking ODT.
To reproduce the crash, select all main text (from first frame) and delete.

cezaryece

2013-10-24 06:21

developer   ~0030771

Thank JLuc very much.
But... please, do not report new issues in bug reports of other (quite different) issues.
If topic is solved then let close report. Feedback just "solved".
If you found new issue then create new report.

zerubbabel

2014-08-25 00:09

reporter   ~0033340

I do not understand why the target version for fixing this bug has been changed from 1.5.0 to 1.5.1, since the automatic footnotes feature is useless with this bug.

Kunda

2014-08-25 04:20

manager   ~0033341

zerubbabel, many issues that were labeled for 1.5.0 were automatically bumped to 1.5.1 per a decision by the devs. 1.5.0 only contains crash/major bugs. Unfortunately, cezaryece has his attention on work and personal things these days and so we don't have an ETA when any of the footnote issues will get fixed.

zerubbabel

2015-08-07 18:50

reporter   ~0035975

Actually, this bug is fixed in version 1.5.0

Kunda

2015-08-07 19:55

manager   ~0035976

zerubbabel, great news. Thanks for following up!
We should prolly to test this on Windows and OSX as well before closing.

Kunda

2015-10-29 04:54

manager   ~0037078

testing needed

cezaryece

2015-10-29 06:23

developer   ~0037082

Yes, I am out, but I am still looking bihind street corner what happens in Scribus.

About numbers of footnotes:
I decide not to update footnote`s numbers live during editing. Footnotes are used mainly in books, where document have long story in many linked frames and Scribus is not doing well in that case. So user have to update numbers by manually invoke of menu command Update Document. In this routine footnotes numbers (and other things like markers) are updated to proper state.
Update Document is also automaticaly invoked on Open, Print and Export.
If not - this is a bug. After opening document with footnotes all of them should have proper numbers.

I got this behaviour from Ventura Publisher where even much faster application have similiar feature for updating enumartions in document.
Update Document will update TOC, all markers and indexes (where they will implemented).

cezaryece

2015-10-29 06:25

developer   ~0037083

And I am not sure if my last patch for footnotes (should be in branch on git) were aplied? If not it will be fine if someone take it and test it.

Kunda

2015-10-29 19:08

manager   ~0037111

cez! Thanks for the feedback!
Noted.

Kunda

2015-10-29 19:27

manager   ~0037112

Ok, thx to jluc we have the patches all in one place, github.

https://github.com/AlterScribus/contributors/tree/footnotes_fix

here are the listed commits:
https://github.com/AlterScribus/contributors/compare/footnotes_fix

Kunda

2016-01-28 20:59

manager   ~0038480

This issue is a huge deal-breaker for people who need footnote functionality

JLuc

2018-01-24 07:51

developer   ~0044870

Does this still happen ?
In such a case, couldnt the patches be merged ?

JLuc

2019-05-09 17:58

developer   ~0046199

tested today
- original issue is fixed : no numbering issue
- crash still happens when deleting all selected text

JLuc

2019-05-09 18:14

developer   ~0046201

remaining issue is now 0015681

Issue History

Date Modified Username Field Change
2013-07-13 00:28 zerubbabel New Issue
2013-07-13 00:28 zerubbabel File Added: Spanking.zip
2013-07-13 12:19 jghali Target Version => 1.5.0
2013-07-15 06:40 JLuc Note Added: 0030445
2013-07-15 09:09 zerubbabel File Added: DZ_LawAgainstLove.odt
2013-10-15 21:04 cbradney Assigned To => cezaryece
2013-10-15 21:04 cbradney Status new => assigned
2013-10-23 12:37 cezaryece Note Added: 0030760
2013-10-23 12:37 cezaryece Status assigned => resolved
2013-10-23 12:37 cezaryece Resolution open => fixed
2013-10-23 13:27 jghali Note Added: 0030763
2013-10-23 13:27 jghali Status resolved => new
2013-10-23 17:49 JLuc Note Added: 0030765
2013-10-23 17:53 JLuc File Added: footnotes_fix odt import note numbers.sla
2013-10-23 17:55 JLuc Note Added: 0030766
2013-10-23 17:55 JLuc Note Edited: 0030766 View Revisions
2013-10-24 06:21 cezaryece Note Added: 0030771
2013-10-24 06:23 cezaryece Status new => resolved
2013-10-24 12:07 cezaryece Status resolved => feedback
2013-10-24 12:07 cezaryece Resolution fixed => reopened
2013-11-14 14:30 cezaryece Status feedback => assigned
2013-11-14 14:31 cezaryece Status assigned => acknowledged
2014-07-03 19:41 Kunda Target Version 1.5.0 => 1.5.1
2014-08-25 00:09 zerubbabel Note Added: 0033340
2014-08-25 04:20 Kunda Note Added: 0033341
2015-08-07 18:50 zerubbabel Note Added: 0035975
2015-08-07 19:55 Kunda Note Added: 0035976
2015-08-08 12:21 Kunda Issue cloned: 0013280
2015-08-08 12:21 Kunda Relationship added related to 0013280
2015-10-29 04:54 Kunda Note Added: 0037078
2015-10-29 06:23 cezaryece Note Added: 0037082
2015-10-29 06:25 cezaryece Note Added: 0037083
2015-10-29 19:08 Kunda Note Added: 0037111
2015-10-29 19:27 Kunda Note Added: 0037112
2015-11-13 01:38 Kunda Relationship added child of 0012496
2016-01-23 17:17 cbradney Target Version 1.5.1 => 1.5.3
2016-01-28 20:59 Kunda Note Added: 0038480
2016-01-28 21:00 Kunda Tag Attached: MABs
2016-04-11 18:20 Kunda Tag Attached: footnotes
2016-12-08 22:04 Kunda Target Version 1.5.3 => 1.5.4
2018-01-24 07:50 JLuc Assigned To cezaryece =>
2018-01-24 07:50 JLuc Severity major => minor
2018-01-24 07:50 JLuc Reproducibility always => have not tried
2018-01-24 07:50 JLuc Status acknowledged => feedback
2018-01-24 07:50 JLuc Category - => Story Editor / Text Frames
2018-01-24 07:50 JLuc Patch => No
2018-01-24 07:50 JLuc Tag Detached: MABs
2018-01-24 07:51 JLuc Note Added: 0044870
2018-01-24 07:51 JLuc Tag Attached: #please_test
2018-01-24 07:51 JLuc Tag Attached: #rottenpatch
2018-01-24 07:52 JLuc Patch No => Yes
2019-05-09 17:58 JLuc Note Added: 0046199
2019-05-09 17:58 JLuc Status feedback => confirmed
2019-05-09 18:14 JLuc Relationship added duplicate of 0015681
2019-05-09 18:14 JLuc Status confirmed => closed
2019-05-09 18:14 JLuc Note Added: 0046201