View Issue Details

IDProjectCategoryView StatusLast Update
0011683ScribusStory Editor / Text Framespublic2015-10-23 17:52
ReporterFirasH Assigned Tojghali  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSopenSUSEOS Version
Product Version1.5.0svn 
Target Version1.5.1Fixed in Version1.5.1svn 
Summary0011683: Crash due to wrong management of Reference to Item Marks
DescriptionScribus crashes double clicking on the entry in the Marks Manager that has been deleted in the text.
Steps To Reproduce1) Create a new document
2) Insert a Text Frame
3) Fill the Text Frame with Sample Text
4) Open: Edit > Marks...

Choose an area in the text to try the following steps easily

5) Insert > Marks > Reference to Item as follows:
     Label: TEST
     Item: Text1

Now in the Marks Manager you can see that there is a new entry (Marks to Items > TEST)

6) Delete the Mark in the text with backspace
Pressing Update All Marks does not remove the entry in the Marks Manager.

7) Double click on the entry TEST in the Marks Manager

Scribus crashes due to Signal 11
Additional InformationScribus 1.5.0.svn (18396)
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0012551 closedjghali Delete Reference to Item crashes Scribus 
child of 0012496 acknowledged Metabug: Marks & Footnotes & Weld (1.5.0.svn) 

Activities

FirasH

2014-03-07 22:05

developer   ~0031478

Program received signal SIGSEGV, Segmentation fault.
0x0000000000770fa6 in load<int> (_q_value=@0x40ad870e1c3870e2: <error reading variable>)
    at /home/.../Qt/5.2.1/gcc_64/include/QtCore/qgenericatomic.h:96
96 return _q_value;
(gdb) bt
#0 0x0000000000770fa6 in load<int> (_q_value=@0x40ad870e1c3870e2: <error reading variable>)
    at /home/.../Qt/5.2.1/gcc_64/include/QtCore/qgenericatomic.h:96
0000001 QBasicAtomicInteger<int>::load (this=0x40ad870e1c3870e2) at /home/.../Qt/5.2.1/gcc_64/include/QtCore/qbasicatomic.h:142
0000002 0x0000000000771510 in QtPrivate::RefCount::ref (this=0x40ad870e1c3870e2)
    at /home/.../Qt/5.2.1/gcc_64/include/QtCore/qrefcount.h:57
0000003 0x0000000000775cea in QString::QString (this=0x7fffffffc020, other=...)
    at /home/.../Qt/5.2.1/gcc_64/include/QtCore/qstring.h:766
0000004 0x0000000000a2c07b in Mark::getItemName (this=0x2e7d080) at /home/.../Scribus/scribus/marks.h:61
0000005 0x0000000000d59f73 in ScribusDoc::setCursor2MarkPos (this=0x3307530, mark=0x2e7d080)
    at /home/.../Scribus/scribus/scribusdoc.cpp:17407
0000006 0x0000000000f39d49 in MarksManager::on_listView_doubleClicked (this=0x2cd6af0, index=...)
    at /home/.../Scribus/scribus/ui/marksmanager.cpp:230
0000007 0x00000000007a17d0 in MarksManager::qt_static_metacall (_o=0x2cd6af0, _c=QMetaObject::InvokeMetaMethod, _id=6,
    _a=0x7fffffffc250) at /home/.../Scribus/build/scribus/ui/moc_marksmanager.cpp:103
0000008 0x00000000007a18f8 in MarksManager::qt_metacall (this=0x2cd6af0, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0x7fffffffc250)
    at /home/.../Scribus/build/scribus/ui/moc_marksmanager.cpp:138
0000009 0x00007ffff769dad3 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Core.so.5
0000010 0x00007ffff6f303d5 in QAbstractItemView::doubleClicked(QModelIndex const&) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000011 0x00007ffff6f7dd90 in QTreeView::mouseDoubleClickEvent(QMouseEvent*) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000012 0x00007ffff6d24091 in QWidget::event(QEvent*) () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000013 0x00007ffff6e2f0f6 in QFrame::event(QEvent*) () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000014 0x00007ffff6f3b79b in QAbstractItemView::viewportEvent(QEvent*) () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000015 0x00007ffff6f78c8a in QTreeView::viewportEvent(QEvent*) () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000016 0x00007ffff767495d in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Core.so.5
0000017 0x00007ffff6cec0bf in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000018 0x00007ffff6cef4d6 in QApplication::notify(QObject*, QEvent*) () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000019 0x00007ffff7674734 in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Core.so.5
0000020 0x00007ffff6cee54a in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000021 0x00007ffff6d43b65 in ?? () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000022 0x00007ffff6d45f98 in ?? () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000023 0x00007ffff6cec0f4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000024 0x00007ffff6cef6ae in QApplication::notify(QObject*, QEvent*) () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000025 0x00007ffff7674734 in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Core.so.5
0000026 0x00007ffff6608ccc in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Gui.so.5
0000027 0x00007ffff66094a5 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Gui.so.5
0000028 0x00007ffff65f0ba8 in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Gui.so.5
0000029 0x00007fffe58281b0 in ?? () from /home/.../Qt/5.2.1/gcc_64/plugins/platforms/libqxcb.so
0000030 0x00007fffed05d316 in g_main_dispatch (context=0x7fffe0001740) at gmain.c:3066
0000031 g_main_context_dispatch (context=context@entry=0x7fffe0001740) at gmain.c:3642
0000032 0x00007fffed05d668 in g_main_context_iterate (context=context@entry=0x7fffe0001740, block=block@entry=1,
    dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3713
0000033 0x00007fffed05d70c in g_main_context_iteration (context=0x7fffe0001740, may_block=1) at gmain.c:3774
0000034 0x00007ffff76c5374 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Core.so.5
0000035 0x00007ffff76734ab in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Core.so.5
0000036 0x00007ffff767753e in QCoreApplication::exec() () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Core.so.5
0000037 0x0000000001225ad0 in mainApp (argc=1, argv=0x7fffffffdd78) at /home/.../Scribus/scribus/main_nix.cpp:86
0000038 0x0000000001225a60 in main (argc=1, argv=0x7fffffffdd78) at /home/.../Scribus/scribus/main_nix.cpp:54

Kunda

2014-09-11 13:09

manager   ~0033617

Confirmed on 1.5svn r19492

anood

2015-10-22 08:00

reporter   ~0036808

duplicate issue
http://bugs.scribus.net/view.php?id=12551

JLuc

2015-10-22 16:03

developer   ~0036827

doublon de 12551

JLuc

2015-10-22 16:04

developer   ~0036828

not fixed, just closed

JLuc

2015-10-22 16:04

developer   ~0036829

re-dupe

JLuc

2015-10-22 16:05

developer   ~0036830

pfew

FirasH

2015-10-23 17:52

developer   ~0036869

Fixed in 1.5.1.svn (20488) along with 0012551.

Issue History

Date Modified Username Field Change
2013-07-24 00:08 FirasH New Issue
2014-03-06 06:18 jghali Target Version => 1.5.0
2014-03-07 22:05 FirasH Note Added: 0031478
2014-07-08 18:15 FirasH Relationship added child of 0012496
2014-07-10 17:58 FirasH Category Internal => Story Editor / Text Frames
2014-07-16 17:13 FirasH Summary Crash due to wrong managment of Reference to Item Marks => Crash due to wrong management of Reference to Item Marks
2014-07-16 17:18 FirasH Steps to Reproduce Updated View Revisions
2014-07-16 17:20 FirasH OS => openSUSE
2014-07-16 17:20 FirasH Platform => x86_64
2014-07-16 17:20 FirasH Description Updated View Revisions
2014-07-16 17:20 FirasH Steps to Reproduce Updated View Revisions
2014-07-16 17:20 FirasH Additional Information Updated View Revisions
2014-09-11 02:47 Kunda Severity crash => block
2014-09-11 13:09 Kunda Note Added: 0033617
2014-09-11 13:09 Kunda Status new => confirmed
2015-05-19 20:56 cbradney Target Version 1.5.0 => 1.5.1
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames
2015-10-22 08:00 anood Note Added: 0036808
2015-10-22 16:02 JLuc Relationship added duplicate of 0012551
2015-10-22 16:03 JLuc Note Added: 0036827
2015-10-22 16:03 JLuc Status confirmed => closed
2015-10-22 16:03 JLuc Assigned To => JLuc
2015-10-22 16:03 JLuc Resolution open => fixed
2015-10-22 16:04 JLuc Note Added: 0036828
2015-10-22 16:04 JLuc Status closed => feedback
2015-10-22 16:04 JLuc Resolution fixed => reopened
2015-10-22 16:04 JLuc Note Added: 0036829
2015-10-22 16:04 JLuc Status feedback => closed
2015-10-22 16:04 JLuc Resolution reopened => fixed
2015-10-22 16:04 JLuc Status closed => feedback
2015-10-22 16:04 JLuc Resolution fixed => reopened
2015-10-22 16:05 JLuc Patch => No
2015-10-22 16:05 JLuc Resolution reopened => duplicate
2015-10-22 16:05 JLuc Note Added: 0036830
2015-10-22 16:05 JLuc Status feedback => closed
2015-10-23 17:51 FirasH Assigned To JLuc =>
2015-10-23 17:51 FirasH Status closed => feedback
2015-10-23 17:51 FirasH Resolution duplicate => reopened
2015-10-23 17:51 FirasH Resolution reopened => fixed
2015-10-23 17:51 FirasH Fixed in Version => 1.5.1svn
2015-10-23 17:51 FirasH Status feedback => resolved
2015-10-23 17:52 FirasH Note Added: 0036869
2015-10-23 17:52 FirasH Status resolved => closed
2015-10-23 17:52 FirasH Assigned To => jghali