View Issue Details

IDProjectCategoryView StatusLast Update
0011797ScribusUsabilitypublic2014-04-21 23:21
ReporterJLuc Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0011797: Importing image should not reset zoom
DescriptionWhen importing an image, the zoom mode is not changed (fit to frame image / free scale mode is unchanged) but when in "free scale" mode, the zoom is reset to 100%.
Reseting the scale is generally not the best option because when replacing an image with another often means that these images share some characteristics, including "viewport width" and, as a consequence, desired import scale.

Scale mode and scale value should be reset or not reset in the same circumstances. There is no use in keeping the scale mode setting when not keeping the scale setting itself.

When importing an image in an allready existing frame, the zoom should not be reset, as is not reset the scale mode.

When importing a completely different image that requires to set new display settings, user can easily create a new image frame that will use the default settings.


TagsNo tags attached.
Patch

Relationships

duplicate of 0012253 assignedale [WIP PATCH] Importing image in non empty frame should preserve scale and position 

Activities

JLuc

2013-10-19 15:08

developer   ~0030745

title should read : "importing image should not reset scale"

JLuc

2013-10-19 15:20

developer   ~0030747

The rotation is not reset neither, which is fine.

Undo the scale reset and the import action will be globaly more consistent.

jghali

2014-04-21 23:21

administrator   ~0031753

Duplicate of 0012253

Issue History

Date Modified Username Field Change
2013-10-19 15:08 JLuc New Issue
2013-10-19 15:08 JLuc Note Added: 0030745
2013-10-19 15:20 JLuc Note Added: 0030747
2014-04-21 23:21 jghali Note Added: 0031753
2014-04-21 23:21 jghali Relationship added duplicate of 0012253
2014-04-21 23:21 jghali Status new => resolved
2014-04-21 23:21 jghali Resolution open => duplicate
2014-04-21 23:21 jghali Assigned To => jghali
2014-04-21 23:21 jghali Status resolved => closed