View Issue Details

IDProjectCategoryView StatusLast Update
0011837Contributor Builds[All Projects] Generalpublic2018-07-29 19:45
ReporterJLuc Assigned To 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionunable to reproduce 
Summary0011837: footnotes_fix : crash when deleteing text of 2 footnotes at once
Descriptioncreate 2 footnotes in same text frame
double click in footnotes frame
select-all text of 2 footnotes (both texts at once) and delete it
crash
Steps To Reproducedownload SLA example file
doubleclick in footnotes frames
CTRL+A to select all = text of both footnotes
DELETE key
crash
Additional Informationbacktrace :

QBackingStore::flush() called with non-exposed window, behavior is undefined
QBackingStore::flush() called with non-exposed window, behavior is undefined
ASSERT failure in QList<T>::at: "index out of range", file /usr/include/qt5/QtCore/qlist.h, line 454

Program received signal SIGABRT, Aborted.
0x00007ffff3e9cf77 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
56 ../nptl/sysdeps/unix/sysv/linux/raise.c: Aucun fichier ou dossier de ce type.
(gdb) bt
#0 0x00007ffff3e9cf77 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
0000001 0x00007ffff3ea05e8 in __GI_abort () at abort.c:90
0000002 0x00007ffff75383f5 in QMessageLogger::fatal(char const*, ...) const () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000003 0x00007ffff75354f7 in qt_assert_x(char const*, char const*, char const*, int) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000004 0x00000000011bc7cb in QList<ScText*>::at (this=0x32183d0, i=13) at /usr/include/qt5/QtCore/qlist.h:454
0000005 0x00000000011b444d in StoryText::hasMark (this=0x3217c20, pos=13, mrk=0x0) at /home/jluc/dev/scribus/git/Scribus/scribus/text/storytext.cpp:820
0000006 0x00000000009b2273 in PageItem_TextFrame::deleteSelectedTextFromFrame (this=0x3217870) at /home/jluc/dev/scribus/git/Scribus/scribus/pageitem_textframe.cpp:4810
0000007 0x00000000009af493 in PageItem_TextFrame::handleModeEditKey (this=0x3217870, k=0x7fffffffdac0, keyRepeat=@0x1a89703: true) at /home/jluc/dev/scribus/git/Scribus/scribus/pageitem_textframe.cpp:4503
0000008 0x0000000000bee60b in ScribusMainWindow::keyPressEvent (this=0x1a89400, k=0x7fffffffdac0) at /home/jluc/dev/scribus/git/Scribus/scribus/scribus.cpp:1721
0000009 0x0000000000d23b69 in ScribusView::eventFilter (this=0x2f2f990, obj=0x2f2f990, event=0x7fffffffdac0) at /home/jluc/dev/scribus/git/Scribus/scribus/scribusview.cpp:4409
0000010 0x00007ffff76c2ee5 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000011 0x00007ffff6dec07c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000012 0x00007ffff6df15e8 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000013 0x00007ffff76c2cbd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000014 0x00007ffff6e42a23 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000015 0x00007ffff6dec09c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000016 0x00007ffff6df0db2 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000017 0x00007ffff76c2cbd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000018 0x00007ffff67ab1e5 in QGuiApplicationPrivate::processKeyEvent(QWindowSystemInterfacePrivate::KeyEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000019 0x00007ffff67afbd1 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000020 0x00007ffff679cab8 in QWindowSystemInterface::sendWindowSystemEventsImplementation(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000021 0x00007fffe5e14700 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so
0000022 0x00007ffff1e0a3b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000023 0x00007ffff1e0a708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000024 0x00007ffff1e0a7ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000025 0x00007ffff7707b0c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000026 0x00007ffff76c1b6b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000027 0x00007ffff76c7301 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000028 0x000000000118a971 in mainApp (argc=1, argv=0x7fffffffdf58) at /home/jluc/dev/scribus/git/Scribus/scribus/main_nix.cpp:86
0000029 0x000000000118a8fe in main (argc=1, argv=0x7fffffffdf58) at /home/jluc/dev/scribus/git/Scribus/scribus/main_nix.cpp:54
Tagsfootnotes
Patch

Relationships

child of 0012496 acknowledged Scribus Metabug: Marks & Footnotes & Weld (1.5.0.svn) 

Activities

JLuc

2013-11-12 09:56

updater  

2footnotes deletetogether.sla (17,892 bytes)

JLuc

2014-09-09 13:18

updater   ~0033599

Same happens in today svn, but in svn it even happens when deleting only one footnote.

Issue History

Date Modified Username Field Change
2013-11-12 09:56 JLuc New Issue
2013-11-12 09:56 JLuc File Added: 2footnotes deletetogether.sla
2014-09-09 13:18 JLuc Note Added: 0033599
2018-07-29 19:23 JLuc Tag Attached: footnotes
2018-07-29 19:23 JLuc Relationship added child of 0012496
2018-07-29 19:45 JLuc Status new => closed
2018-07-29 19:45 JLuc Resolution open => unable to reproduce