View Issue Details

IDProjectCategoryView StatusLast Update
0011971ScribusPDFpublic2014-07-03 15:29
Reporterperosredo Assigned To 
PrioritynormalSeveritycrashReproducibilityrandom
Status closedResolutionunable to reproduce 
Platformamd64OSXubuntu OS Version14.04
Product Version1.5.0svn 
Target VersionFixed in Version 
Summary0011971: Export to PDF froze Scribus
DescriptionClicking 'Save as PDF' in the Export menu froze Scribus - gdb log and bt in Additional Information.
Additional InformationQXcbConnection: XCB error: 3 (BadWindow), sequence: 39006, resource id: 50341708, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39007, resource id: 50341708, major code: 25 (SendEvent), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39008, resource id: 50341709, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39009, resource id: 50341709, major code: 25 (SendEvent), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39010, resource id: 50341710, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39011, resource id: 50341710, major code: 25 (SendEvent), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39012, resource id: 50341711, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39013, resource id: 50341711, major code: 25 (SendEvent), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39014, resource id: 50341712, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39015, resource id: 50341712, major code: 25 (SendEvent), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39016, resource id: 50341713, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39017, resource id: 50341713, major code: 25 (SendEvent), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39018, resource id: 50341714, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39019, resource id: 50341714, major code: 25 (SendEvent), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39020, resource id: 50341715, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39021, resource id: 50341715, major code: 25 (SendEvent), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39023, resource id: 50341716, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39024, resource id: 50341716, major code: 25 (SendEvent), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39025, resource id: 50341717, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39026, resource id: 50341717, major code: 25 (SendEvent), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39027, resource id: 50341718, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39028, resource id: 50341718, major code: 25 (SendEvent), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39489, resource id: 50332938, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39490, resource id: 50332938, major code: 25 (SendEvent), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39493, resource id: 50341847, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 39494, resource id: 50341847, major code: 25 (SendEvent), minor code: 0
storytext::charstyle: access at end of text %i 202
QRegion empty
QRegion empty
QRegion empty
storytext::charstyle: access at end of text %i 10
storytext::charstyle: access at end of text %i 431
^C
Program received signal SIGINT, Interrupt.
0x00007ffff235074d in poll () at ../sysdeps/unix/syscall-template.S:81
81 ../sysdeps/unix/syscall-template.S: No such file or directory.
(gdb) bt
#0 0x00007ffff235074d in poll () at ../sysdeps/unix/syscall-template.S:81
0000001 0x00007ffff01b8cd4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000002 0x00007ffff01b8ddc in g_main_context_iteration ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000003 0x00007ffff770676c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000004 0x00007ffff76c084b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000005 0x00007ffff6fc909d in QDialog::exec() ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000006 0x0000000000cd3f26 in ScribusMainWindow::doSaveAsPDF (this=0x1c30220)
    at /build/buildd/scribus-trunk-1.5.0svn201401141803/scribus/scribus.cpp:8531
0000007 0x0000000000cd39e2 in ScribusMainWindow::SaveAsPDF (this=0x1c30220)
    at /build/buildd/scribus-trunk-1.5.0svn201401141803/scribus/scribus.cpp:8489
0000008 0x00000000007b0c81 in ScribusMainWindow::qt_static_metacall (_o=0x1c30220,
    _c=QMetaObject::InvokeMetaMethod, _id=168, _a=0x7fffffffd9d0)
    at /build/buildd/scribus-trunk-1.5.0svn201401141803/debian/build/scribus/moc_scribus.cpp:1095
0000009 0x00007ffff76e5e06 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000010 0x00007ffff6de30d2 in QAction::triggered(bool) ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000011 0x00007ffff6de53d8 in QAction::activate(QAction::ActionEvent) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000012 0x00007ffff6de54f4 in QAction::event(QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000013 0x00007ffff6dea0bc in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000014 0x00007ffff6deedc2 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000015 0x00007ffff76c197d in QCoreApplication::notifyInternal(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000016 0x00007ffff67cdb71 in QShortcutMap::dispatchEvent(QKeyEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000017 0x00007ffff67cdc84 in QShortcutMap::tryShortcutEvent(QObject*, QKeyEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000018 0x00007ffff6df0c24 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000019 0x00007ffff76c197d in QCoreApplication::notifyInternal(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000020 0x00007ffff6e40943 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000021 0x00007ffff6dea0bc in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
---Type <return> to continue, or q <return> to quit---
0000022 0x00007ffff6deedc2 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
0000023 0x00007ffff76c197d in QCoreApplication::notifyInternal(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000024 0x00007ffff67a9295 in QGuiApplicationPrivate::processKeyEvent(QWindowSystemInterfacePrivate::KeyEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000025 0x00007ffff67adc61 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000026 0x00007ffff679ab68 in QWindowSystemInterface::sendWindowSystemEventsImplementation(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
0000027 0x00007fffe2c8d780 in ?? ()
   from /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so
0000028 0x00007ffff01b8af4 in g_main_context_dispatch ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000029 0x00007ffff01b8d38 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000030 0x00007ffff01b8ddc in g_main_context_iteration ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000031 0x00007ffff770676c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000032 0x00007ffff76c084b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
---Type <return> to continue, or q <return> to quit---
0000033 0x00007ffff76c5fa1 in QCoreApplication::exec() ()
   from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
0000034 0x00000000012400eb in mainApp (argc=1, argv=0x7fffffffe668)
    at /build/buildd/scribus-trunk-1.5.0svn201401141803/scribus/main_nix.cpp:86
0000035 0x0000000001240078 in main (argc=1, argv=0x7fffffffe668)
    at /build/buildd/scribus-trunk-1.5.0svn201401141803/scribus/main_nix.cpp:54
TagsNo tags attached.
Patch

Activities

jghali

2014-01-16 20:31

administrator   ~0031094

We need a sample document, cannot reproduce such issue on Windows.

FirasH

2014-06-28 10:42

developer   ~0032350

perosredo do you still have this issue?

Issue History

Date Modified Username Field Change
2014-01-16 07:30 perosredo New Issue
2014-01-16 20:31 jghali Note Added: 0031094
2014-06-28 10:42 FirasH Note Added: 0032350
2014-06-30 16:40 FirasH Status new => feedback
2014-07-03 15:29 FirasH Status feedback => closed
2014-07-03 15:29 FirasH Resolution open => unable to reproduce