View Issue Details

IDProjectCategoryView StatusLast Update
0011996ScribusUser Interfacepublic2014-01-27 07:23
Reporterperosredo Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformamd64OSFedoraOS Version20
Product Version1.5.0svn 
Target VersionFixed in Version1.5.0svn 
Summary0011996: Save As window issues in Fedora 20
DescriptionClicking Save As produces a window which is rather useless - it doesn't have a field to enter filename and no save button - and also defaults to /home. Screenshot attached.

Taking a screenshot with Shutter also reveals another quirk - there are actually 3 windows there: the actual visible window which is named 'untitled', and an invisible window titled 'Save As' within it, and another invisible window titled 'Open file' to the top right.

This bug is present in the Fedora-rebuilt 18738 sRPMs from the OpenSUSE repository, as well as my owned hacked-together built from ticket 0011986 - I'm not sure if that invalidates the bug.
TagsNo tags attached.
Patch

Activities

perosredo

2014-01-19 00:38

reporter  

Untitled window_008.png (33,623 bytes)
Untitled window_008.png (33,623 bytes)

perosredo

2014-01-20 03:02

reporter   ~0031152

This bug applies to all Save dialogues.

JLuc

2014-01-24 09:46

developer   ~0031180

Last edited: 2014-01-24 11:47

View 10 revisions

I have same issue, now, aswell, with Ubuntu 13.10.
- Save windows doesnt propose the filename input
- Save triggers 2 windows : one with folder trees only, as chown on screenshot, the other one with "compress file" checkbox only (and OK / Cancel buttons)

Similar issue happens with "Import ODT into text frame" dialog (with 2 partial windows that both have to be submitted) but with no bad consequences since 'import odt' only needs not choose a file, instead "Save as" requires the input of a new name.

SVN with this bug is clean-compiled version 18767 as of 2014-01-21 with uptodate Qt5.2
AMOF Same with SVN 18745, 18738, 18670 now compiled.

Strangely, i dont think that the 18745 version showed this bug when compiled a couple of days ago with freshly installed Qt5.2.

====

Problems does not happen with scribus 1.5 from PPA which is compiled with Qt5.0.2 (but it has other blocking bugs).

JLuc

2014-01-24 11:48

developer   ~0031181

i suggest to rise the severity or priority of this bug.

perosredo

2014-01-24 21:05

reporter   ~0031185

The 'execute script' dialog does not function as intended as well - cannot click the button after selecting the script.

perosredo

2014-01-25 02:41

reporter   ~0031187

Last edited: 2014-01-25 08:52

View 4 revisions

Issue persists on Fedora 20 with build 18770 compiled using OpenSUSE's OpenBuild specifically for F20 - I branched Christophe Giboudeaux's Factory KDE repo and tinkered with the dependencies in the spec file until it compiled successfully.

Repo:
https://build.opensuse.org/package/show/home:perosredo:branches:KDE:Unstable:Extra/scribus-unstable
Spec: https://build.opensuse.org/package/view_file/home:perosredo:branches:KDE:Unstable
Log: https://build.opensuse.org/package/live_build_log/home:perosredo:branches:KDE:Unstable:Extra/scribus-unstable/Fedora_20/x86_64

jghali

2014-01-25 13:27

administrator   ~0031189

I applied a patch which should fix the issue with Qt 5.2.0 on Ubuntu and OS X. Unfortunately I have no clue about the reason of this issue on Fedora.

jghali

2014-01-25 14:18

administrator   ~0031190

With this fix, the file dialog works in Fedora with Qt 5.2.0 as provided with Qt online installer from qt-project.org. So the rest of this issue seems a pure Fedora issue.

JLuc

2014-01-25 15:43

developer   ~0031191

I confirm its ok now on Ubuntu 13.10

perosredo

2014-01-25 18:21

reporter   ~0031192

Resolved in F20 with 18771 - thanks.

jghali

2014-01-25 18:38

administrator   ~0031193

It is indeed. After a full rebuild, it works too in my Fedora 20 VM.

Issue History

Date Modified Username Field Change
2014-01-19 00:38 perosredo New Issue
2014-01-19 00:38 perosredo File Added: Untitled window_008.png
2014-01-20 03:02 perosredo Note Added: 0031152
2014-01-24 09:46 JLuc Note Added: 0031180
2014-01-24 10:04 JLuc Note Edited: 0031180 View Revisions
2014-01-24 10:05 JLuc Note Edited: 0031180 View Revisions
2014-01-24 11:09 JLuc Note Edited: 0031180 View Revisions
2014-01-24 11:13 JLuc Note Edited: 0031180 View Revisions
2014-01-24 11:14 JLuc Note Edited: 0031180 View Revisions
2014-01-24 11:26 JLuc Note Edited: 0031180 View Revisions
2014-01-24 11:45 JLuc Note Edited: 0031180 View Revisions
2014-01-24 11:46 JLuc Note Edited: 0031180 View Revisions
2014-01-24 11:47 JLuc Note Edited: 0031180 View Revisions
2014-01-24 11:48 JLuc Note Added: 0031181
2014-01-24 21:05 perosredo Note Added: 0031185
2014-01-25 02:41 perosredo Note Added: 0031187
2014-01-25 02:42 perosredo Note Edited: 0031187 View Revisions
2014-01-25 02:43 perosredo Note Edited: 0031187 View Revisions
2014-01-25 08:52 perosredo Note Edited: 0031187 View Revisions
2014-01-25 13:27 jghali Note Added: 0031189
2014-01-25 14:18 jghali Note Added: 0031190
2014-01-25 15:43 JLuc Note Added: 0031191
2014-01-25 18:21 perosredo Note Added: 0031192
2014-01-25 18:38 jghali Note Added: 0031193
2014-01-25 18:38 jghali Status new => resolved
2014-01-25 18:38 jghali Fixed in Version => 1.5.0svn
2014-01-25 18:38 jghali Resolution open => fixed
2014-01-25 18:38 jghali Assigned To => jghali
2014-01-27 07:23 christoph_s Status resolved => closed