View Issue Details

IDProjectCategoryView StatusLast Update
0012043ScribusUndo/Redopublic2017-12-20 20:58
ReporterJLuc Assigned Tojghali  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.0svn 
Target Version1.5.5Fixed in Version1.5.4.svn 
Summary0012043: Undo on cutting text doesnt restore correctly, but in text of previous edit or delete instead
DescriptionUndo on text cut with Ctrl+X sometime doesnt restore the text in right place, but in text of previous edit or delete instead
Steps To Reproducecreate doc, create frame, fill it with text
select some word, cut it with Ctrl+X
select some other word a few lines further, do the same.

UNDO

See : both texts have been restored at once, but the second one has been placed just after the first one instead of in its original place
Additional InformationSame type of "restore not in original place" undo issue happens similarly in other simple edit situations.
Tagsundo
PatchNo

Relationships

related to 0015067 closedjghali Undoing text paste over causes old and new text merge 
child of 0012500 acknowledged Metabug: Undo/Redo (1.5.x.svn) 

Activities

JLuc

2014-02-05 20:37

developer   ~0031271

Last edited: 2014-02-05 20:58

View 2 revisions

Beside "not right place", it should require 2 undos to undo both deletes. it looks like a good debug starting point.

JLuc

2017-12-12 20:07

developer   ~0044744

Cant reproduce with 12/12/2017's nightly build

JLuc

2017-12-12 20:12

developer   ~0044745

confirmer le fix aprés récent commit

jghali

2017-12-12 20:17

administrator   ~0044746

Last edited: 2017-12-12 20:18

View 2 revisions

Fixed with issue 0012276 by commits r21931 and r21948

JLuc

2017-12-13 09:15

developer   ~0044749

yes !

Issue History

Date Modified Username Field Change
2014-02-05 20:36 JLuc New Issue
2014-02-05 20:37 JLuc Tag Attached: undo
2014-02-05 20:37 JLuc Note Added: 0031271
2014-02-05 20:58 JLuc Note Edited: 0031271 View Revisions
2014-02-05 22:50 christoph_s Status new => confirmed
2014-02-05 22:50 christoph_s Summary Undo on text delete => Undo on cutting text
2014-02-05 22:50 christoph_s Description Updated View Revisions
2014-02-05 22:50 christoph_s Steps to Reproduce Updated View Revisions
2014-07-09 01:38 FirasH Relationship added child of 0012500
2014-07-22 11:35 Kunda Target Version => 1.5.1
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames
2015-11-29 17:53 Kunda Patch => No
2015-11-29 17:53 Kunda Category Story Editor / Text Frames => Undo/Redo
2015-11-29 17:53 Kunda Summary Undo on cutting text => Undo on cutting text doesnt restore correctly, but in text of previous edit or delete instead
2016-01-23 17:16 cbradney Target Version 1.5.1 => 1.5.3
2016-12-08 21:30 Kunda Target Version 1.5.3 => 1.5.5
2017-12-11 18:42 JLuc Relationship added related to 0015067
2017-12-12 20:07 JLuc Note Added: 0044744
2017-12-12 20:12 JLuc Assigned To => JLuc
2017-12-12 20:12 JLuc Status confirmed => feedback
2017-12-12 20:12 JLuc Note Added: 0044745
2017-12-12 20:17 jghali Assigned To JLuc => jghali
2017-12-12 20:17 jghali Status feedback => resolved
2017-12-12 20:17 jghali Resolution open => fixed
2017-12-12 20:17 jghali Fixed in Version => 1.5.4.svn
2017-12-12 20:17 jghali Note Added: 0044746
2017-12-12 20:18 jghali Note Edited: 0044746 View Revisions
2017-12-13 09:15 JLuc Note Added: 0044749
2017-12-20 20:58 cbradney Status resolved => closed