View Issue Details

IDProjectCategoryView StatusLast Update
0012084ScribusUndo/Redopublic2019-10-04 09:00
ReporterFirasH Assigned ToFirasH  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSopenSUSEOS Version13.1
Product Version1.5.0svn 
Target Version1.5.5Fixed in Version1.5.6.svn 
Summary0012084: Undo does not work with Attach/Detach text to/from path
DescriptionUndo does not Detach Text from Path after Attaching Text to Path.
Steps To Reproduce0) Create a new document
1) Insert a Bezier Curve
2) Insert a Text Frame and add some Sample Text
3) Select the Bezier Curve and the Text Frame
4) Go to Item > Path Tools > Attach Text to Path
5) Undo Step 4

The Text is positioned in its previous position, but its still attached to a "copy" of the Bezier Curve created in Step 4.
Now if you select the Text restored and Item > Path Tools > Detach Text from Path the text is at should.
From this situation if you Undo and Redo everything the Frame of the Wrongly restored Text is not deleted.
Additional InformationScribus 1.5.0 SVN (18831) - Qt 5.2.1

Works as expected with Scribus 1.4.3 SVN (18831)
Tagstext to path, undo
Patch

Relationships

has duplicate 0014195 closed undo Text to path doesn't reset text frame 
related to 0013922 closedFirasH Undoing setting the text onto a circle shape "path" duplicates instead of undoing 
child of 0012500 acknowledged Metabug: Undo/Redo (1.5.x.svn) 

Activities

Kunda

2014-07-07 20:41

manager   ~0032558

Bug confirmed on 10.8.5 1.5svn r19322
BTW, Is it normal behavior for the belzier curved line to disappear when the text is imposed on it ?

eudoxos

2017-07-19 21:08

reporter   ~0044187

Confirming with 1.5.4svn. @Kunda: it seems this is expected, but the curve can be shown via Path Text Properties / Show curve.

FirasH

2019-08-18 14:39

developer   ~0046475

Cannot reproduce with 1.5.6.svn (190814) Windows build. If someone can confirm the fix we can close this issue.

FirasH

2019-08-18 14:46

developer   ~0046476

I noticed that Undo is able to detach the Text Frame from the Bezier Curve but the size of the Text Frame is not correctly restored. In fact it is slightly smaller, I will open a new report for that

FirasH

2019-10-04 09:00

developer   ~0046732

Closing. Cannot reproduce with 1.5.6.svn (2019-10-03).

Issue History

Date Modified Username Field Change
2014-02-22 20:15 FirasH New Issue
2014-02-22 23:15 JLuc Tag Attached: undo
2014-07-07 20:41 Kunda Note Added: 0032558
2014-07-07 20:41 Kunda Status new => confirmed
2014-07-07 20:41 Kunda Target Version => 1.5.1
2014-07-09 01:25 FirasH Relationship added child of 0012500
2015-11-29 13:56 Kunda Target Version 1.5.1 => 1.5.2
2016-01-23 17:15 cbradney Target Version 1.5.2 => 1.5.4.svn
2016-04-19 19:42 Kunda Tag Attached: text to path
2016-05-15 13:05 Kunda Relationship added related to 0013922
2016-05-15 23:02 Kunda Target Version 1.5.4.svn => 1.5.5
2016-12-03 23:15 FirasH Relationship added related to 0014195
2016-12-03 23:27 FirasH Relationship deleted related to 0014195
2016-12-03 23:27 FirasH Relationship added duplicate of 0014195
2016-12-03 23:28 FirasH Relationship deleted 0014195
2016-12-03 23:29 FirasH Relationship added has duplicate 0014195
2017-07-19 21:08 eudoxos Note Added: 0044187
2019-08-18 14:39 FirasH Assigned To => FirasH
2019-08-18 14:39 FirasH Status confirmed => resolved
2019-08-18 14:39 FirasH Resolution open => fixed
2019-08-18 14:39 FirasH Fixed in Version => 1.5.6.svn
2019-08-18 14:39 FirasH Note Added: 0046475
2019-08-18 14:46 FirasH Note Added: 0046476
2019-10-04 09:00 FirasH Status resolved => closed
2019-10-04 09:00 FirasH Note Added: 0046732