View Issue Details

IDProjectCategoryView StatusLast Update
0012091ScribusUser Interfacepublic2016-10-31 11:43
ReporterPeterBenedek Assigned Tojghali  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformDesktop PC and NotebookOSLinux Mint OS Version16 or later
Product Version1.5.0svn 
Target Version1.5.1Fixed in Version1.5.1svn 
Summary0012091: Search result in Story Editor complexities (modal window problem + loses location when search dialog closed)
DescriptionA text is inserted in a text box of the document. I would like to search the text, so I continue working in the text editor.
When I am searching a text (CTRL+T) in the text editor, the program finds a select the search string, but doesn't allow editing it, until the search window is closed. However, on closing the search window, the focus will jump to the first character of the text, losing the place of the search result.
It works this way until the text in the text editor is edited.

Link this video: https://www.dropbox.com/s/pxcm8insznsz3cx/find_text_problem.avi
Additional InformationEnvironment: Linux Mint 16 "Petra"
Version: Scribus 1.5.0 (https://launchpad.net/~scribus/+archive/ppa)
Language: HU
TagsNo tags attached.
PatchNo

Relationships

related to 0011721 confirmed SE defaults when switching away and back to Scribus  
related to 0010641 new Changing focus from and back to text editor causing many trailing paragraphs to vanish 
child of 0012755 new Metabug: Search & Replace (1.5.x svn) 

Activities

FirasH

2014-07-03 18:03

developer   ~0032448

Reproduced with 1.5.0.svn (19309).

Kunda

2015-09-21 00:55

manager   ~0036306

Renamed issue

Kunda

2015-09-25 19:35

manager   ~0036383

Possible Duplicate of 0005189

PeterBenedek

2015-10-08 19:23

developer   ~0036552

Last edited: 2015-10-08 19:26

View 3 revisions

Fixed? Does not work! :-(

Scribus ver. 1.5.1.svn
03 Október 2015
Build ID: C-C-T-F-C1.13.1-64bit

Qt 5.4.2

Kunda

2015-10-08 21:06

manager   ~0036553

Changing status back to assigned since OP can recreate.

cbradney

2015-10-08 22:04

administrator   ~0036558

The position of the cursor remains in the found location.. so please describe how it doesn't work for you? I have, and am not, making the search window non-modal. That involves more detailed work.

PeterBenedek

2015-10-09 06:13

developer   ~0036570

Last edited: 2015-10-09 06:27

View 2 revisions

One short video.
https://www.dropbox.com/s/d5er22q83308r09/example.avi?dl=0

Source: ppa:scribus/ppa (https://launchpad.net/~scribus/+archive/ubuntu/ppa)


I can not find in the list this bug.
http://scribus.net/websvn/log.php?repname=Scribus&path=%2Ftrunk%2FScribus%2F&isdir=1&

Kunda

2015-10-09 14:31

manager   ~0036576

Peter, are you looking for Craig's fix?
http://scribus.net/websvn/revision.php?repname=Scribus&path=%2F&isdir=1&rev=20441

Kunda

2015-10-09 14:38

manager   ~0036577

I can't reproduce on OSX 10.10.5 1.5.1svn r20445 Qt5.5

PeterBenedek

2015-10-09 17:47

developer   ~0036580

I know reproduce Linux Mint 17.2, 64bit; Qt5.5

Scribus ver.: 1.5.1svn~r20447~20151007~ppa37~ubuntu15.10.1

cbradney

2015-10-09 19:27

administrator   ~0036586

Unable to replicate.. I can put in lorem, add a 2 at the end, search for the 2 and the cursor stays there.

cbradney

2015-10-09 20:38

administrator   ~0036590

Please attach a doc where it does not work for you.

PeterBenedek

2015-10-10 05:04

developer  

DOC.sla (21,447 bytes)

PeterBenedek

2015-10-10 05:17

developer   ~0036595

Attached.

Kunda

2015-10-10 09:06

manager  

search_result_remember_cursor.m4v (2,218,055 bytes)

Kunda

2015-10-10 09:08

manager   ~0036597

Tested Peter's .sla and can't reproduce bug (on OSX). See attached screencast.

PeterBenedek

2015-10-11 06:47

developer   ~0036615

Tested three computer.
Operation system: Linux Mint 17.2, 32 and 64 bit.
Qt version: 5.5

Does not work.

It is possible that in the source does not include the repair?
Source: ppa:scribus/ppa (https://launchpad.net/~scribus/+archive/ubuntu/ppa)

cbradney

2015-10-11 10:14

administrator   ~0036618

Might be a bug in Qt on Linux then. Works fine on OSX with Qt 5.4.1 and 5.5, but not on Ubuntu/Mint.

PeterBenedek

2015-10-11 16:40

developer   ~0036622

:-(

Kunda

2015-10-12 18:29

manager   ~0036655

Peter, can you test against Qt5.6 alpha ?

PeterBenedek

2015-10-13 09:52

developer   ~0036660

Not found "qt-opensource-linux-x64-5.6.0.run" file (linux installation kit).

Unfortunately I can not test.

jghali

2015-10-27 12:50

administrator   ~0036984

I backported current fix to 1.4.6svn. Works at least on Windows and Mac OSX.

PeterBenedek

2015-10-27 14:36

developer   ~0036988

Linux Qt is accursed. :(

jghali

2015-10-27 18:49

administrator   ~0036995

I committed an additional fix for Linux. Please test.

Kunda

2015-10-27 21:43

manager   ~0036997

Peter please retest

PeterBenedek

2015-10-28 16:39

developer   ~0037050

Yet source has not been updated (https://launchpad.net/~scribus/+archive/ubuntu/ppa)
When finished, I'll retest.

PeterBenedek

2015-10-28 18:40

developer   ~0037053

Last edited: 2015-10-28 18:48

View 2 revisions

Tested.
It works great! Cursor stays in place (but selection is terminated)!

Thanks jghali, Kunda (and Scribus team)!

Kunda

2015-10-28 19:03

manager   ~0037057

Hallelujah. jghali committed fix in r20504
Closing.

Kunda

2016-02-15 13:08

manager   ~0038745

Last edited: 2016-02-15 13:10

View 2 revisions

OK, so what is left is that highlighting, aka the selected text, is terminated. See 0011721:0038746 for progress on that

Issue History

Date Modified Username Field Change
2014-02-25 10:46 PeterBenedek New Issue
2014-07-03 18:03 FirasH Note Added: 0032448
2014-07-03 18:37 Kunda Status new => confirmed
2014-07-03 18:37 Kunda Target Version => 1.5.1
2015-05-16 13:56 Kunda Patch => No
2015-05-16 13:56 Kunda Priority normal => high
2015-05-16 13:56 Kunda Description Updated View Revisions
2015-05-16 13:56 Kunda Additional Information Updated View Revisions
2015-09-21 00:55 Kunda Note Added: 0036306
2015-09-21 00:55 Kunda Summary Search for text editor problem => Search result in text editor complexities (modal window problem + loses location when search dialog closed)
2015-09-21 00:56 Kunda Summary Search result in text editor complexities (modal window problem + loses location when search dialog closed) => Search result in Story Editor complexities (modal window problem + loses location when search dialog closed)
2015-09-25 19:35 Kunda Note Added: 0036383
2015-09-25 19:36 Kunda Relationship added child of 0012755
2015-10-04 03:26 cbradney Status confirmed => resolved
2015-10-04 03:26 cbradney Fixed in Version => 1.5.1svn
2015-10-04 03:26 cbradney Resolution open => fixed
2015-10-04 03:26 cbradney Assigned To => cbradney
2015-10-08 19:23 PeterBenedek Note Added: 0036552
2015-10-08 19:25 PeterBenedek Note Edited: 0036552 View Revisions
2015-10-08 19:26 PeterBenedek Note Edited: 0036552 View Revisions
2015-10-08 21:06 Kunda Note Added: 0036553
2015-10-08 21:06 Kunda Status resolved => assigned
2015-10-08 22:04 cbradney Note Added: 0036558
2015-10-09 06:13 PeterBenedek Note Added: 0036570
2015-10-09 06:27 PeterBenedek Note Edited: 0036570 View Revisions
2015-10-09 14:31 Kunda Note Added: 0036576
2015-10-09 14:38 Kunda Note Added: 0036577
2015-10-09 17:47 PeterBenedek Note Added: 0036580
2015-10-09 19:27 cbradney Note Added: 0036586
2015-10-09 20:38 cbradney Note Added: 0036590
2015-10-10 05:04 PeterBenedek File Added: DOC.sla
2015-10-10 05:17 PeterBenedek Note Added: 0036595
2015-10-10 09:06 Kunda File Added: search_result_remember_cursor.m4v
2015-10-10 09:08 Kunda Note Added: 0036597
2015-10-11 06:47 PeterBenedek Note Added: 0036615
2015-10-11 10:14 cbradney Note Added: 0036618
2015-10-11 16:40 PeterBenedek Note Added: 0036622
2015-10-12 18:29 Kunda Note Added: 0036655
2015-10-13 09:52 PeterBenedek Note Added: 0036660
2015-10-27 12:50 jghali Note Added: 0036984
2015-10-27 14:36 PeterBenedek Note Added: 0036988
2015-10-27 18:49 jghali Note Added: 0036995
2015-10-27 21:43 Kunda Note Added: 0036997
2015-10-28 16:39 PeterBenedek Note Added: 0037050
2015-10-28 18:40 PeterBenedek Note Added: 0037053
2015-10-28 18:48 PeterBenedek Note Edited: 0037053 View Revisions
2015-10-28 19:03 Kunda Note Added: 0037057
2015-10-28 19:03 Kunda Status assigned => closed
2015-10-28 19:03 Kunda Assigned To cbradney => jghali
2016-02-15 13:02 Kunda Relationship added related to 0011721
2016-02-15 13:08 Kunda Note Added: 0038745
2016-02-15 13:10 Kunda Note Edited: 0038745 View Revisions
2016-10-31 11:43 PeterBenedek Relationship added related to 0010641