View Issue Details

IDProjectCategoryView StatusLast Update
0012138ScribusStory Editor / Text Framespublic2016-04-18 21:39
ReporterJLuc Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.5.0svn 
Target Version1.5.2Fixed in Version1.5.2.svn 
Summary0012138: [Patch] Bottom align : text disappear when frame is too high
DescriptionWith the new "vertical align" setting, the text disappear in the overflown text when the frame is too high.

As for "what is the too high" measure, it seems it depends on heigth-changes history.
TagsHOST-Oman, layout, MABs
PatchYes

Activities

JLuc

2014-03-10 08:25

developer  

bottom align.sla (15,463 bytes)

PeterBenedek

2014-03-15 15:08

developer   ~0031513

Last edited: 2014-03-16 21:01

View 2 revisions

Might help in video...
Link this video: https://www.dropbox.com/s/c331qc5bjjva9ni/out_2.ogv

In case of linked text frames in vertical alignment does not work
Link this video: https://www.dropbox.com/s/jmp0cwf165d8s6f/out_3.ogv

Kunda

2014-07-07 11:28

updater   ~0032532

http://wiki.scribus.net/canvas/Most_Annoying_Bugs

IbtisamN

2015-11-10 10:46

reporter  

issue#12138.patch (755 bytes)
Index: pageitem_textframe.cpp
===================================================================
--- pageitem_textframe.cpp	(revision 20509)
+++ pageitem_textframe.cpp	(working copy)
@@ -3053,9 +3053,9 @@
 		double topDist = m_textDistanceMargins.top();
 		double hAdjust = 0;
 		if (verticalAlign == 1)
-			hAdjust = (height() - (m_textDistanceMargins.bottom() + lineCorr) - maxY) / 2.0;
+			hAdjust = (height() - (m_textDistanceMargins.bottom() + lineCorr) - ceil(maxY)) / 2.0;
 		else if (verticalAlign == 2)
-			hAdjust = (height() - (m_textDistanceMargins.bottom() + lineCorr) - maxY);
+			hAdjust = (height() - (m_textDistanceMargins.bottom() + lineCorr) - ceil(maxY));
 		if (hAdjust > 0)
 		{
 			m_textDistanceMargins.setTop(topDist + hAdjust);
issue#12138.patch (755 bytes)

IbtisamN

2015-11-10 10:58

reporter   ~0037378

I finished solving the first part of the bug which reported by JLuc. The problem was in the value of maxY, we must take ceiling value of it when calculate the hAdjust which will be set as top margin when choosing bottom alignment. Check the Uploaded patch.

Kunda

2015-11-11 15:33

updater   ~0037428

Devs, please review

fschmid

2016-04-17 18:26

administrator   ~0040227

Can't reproduce it anymore with current SVN, resolving.

Kunda

2016-04-18 04:02

updater   ~0040235

Franz, Thanks
So i can't reproduce the text disappearing.
What I can reproduce is the PeterBenedek's report: 0012138:0031513
In case of linked text frames in vertical alignment does not work
Link this video: https://www.dropbox.com/s/jmp0cwf165d8s6f/out_3.ogv 


Should we open a new ticket for it ?

jghali

2016-04-18 09:32

administrator   ~0040240

Yes, however I'm not sure it's a bug. Indesign itself disable vertical alignment for linked text frames. In the common case, that would be only useful for the last frame of the chain anyway. For the other frames of the chain, there would be usually little or no effect. So vertical alignment for linked text frames is in fact quite useless.

Kunda

2016-04-18 13:01

updater   ~0040246

So can we do something like:
if linkedTextFrame && !lastLinkedTextFrame then textVerticalAlignment == disable

jghali

2016-04-18 21:22

administrator   ~0040293

My opinion is that:
- users would not understand such behavior
- there is basically no use case for vertical alignment in text chains

Kunda

2016-04-18 21:39

updater   ~0040294

Ok.. then closing ticket.

Issue History

Date Modified Username Field Change
2014-03-10 08:25 JLuc New Issue
2014-03-10 08:25 JLuc File Added: bottom align.sla
2014-03-15 15:08 PeterBenedek Note Added: 0031513
2014-03-16 21:01 PeterBenedek Note Edited: 0031513 View Revisions
2014-04-07 15:41 JLuc Tag Attached: layout
2014-07-07 11:28 Kunda Note Added: 0032532
2014-07-07 11:28 Kunda Target Version => 1.5.1
2014-07-07 11:28 Kunda Status new => confirmed
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames
2015-09-18 02:01 Kunda Tag Attached: MABs
2015-11-10 10:45 IbtisamN Tag Attached: HOST-Oman
2015-11-10 10:46 IbtisamN File Added: issue#12138.patch
2015-11-10 10:58 IbtisamN Note Added: 0037378
2015-11-10 15:40 Kunda Patch => Yes
2015-11-10 15:40 Kunda Summary Bottom align : text disappear when frame is too high => [Patch] Bottom align : text disappear when frame is too high
2015-11-10 15:41 Kunda Sticky Issue No => Yes
2015-11-11 15:33 Kunda Note Added: 0037428
2016-01-23 17:16 cbradney Target Version 1.5.1 => 1.5.3
2016-04-17 18:26 fschmid Note Added: 0040227
2016-04-17 18:26 fschmid Status confirmed => resolved
2016-04-17 18:26 fschmid Fixed in Version => 1.5.2.svn
2016-04-17 18:26 fschmid Resolution open => fixed
2016-04-17 18:26 fschmid Assigned To => fschmid
2016-04-17 20:22 Kunda Target Version 1.5.3 => 1.5.2
2016-04-18 04:02 Kunda Note Added: 0040235
2016-04-18 04:02 Kunda Status resolved => feedback
2016-04-18 04:02 Kunda Resolution fixed => reopened
2016-04-18 09:32 jghali Note Added: 0040240
2016-04-18 09:32 jghali Status feedback => resolved
2016-04-18 09:32 jghali Resolution reopened => fixed
2016-04-18 09:32 jghali Sticky Issue Yes => No
2016-04-18 13:01 Kunda Note Added: 0040246
2016-04-18 21:22 jghali Note Added: 0040293
2016-04-18 21:39 Kunda Note Added: 0040294
2016-04-18 21:39 Kunda Status resolved => closed