View Issue Details

IDProjectCategoryView StatusLast Update
0012157ScribusImport / Exportpublic2019-06-04 20:56
Reporterowencook Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSSUSEOS Version13.1
Product Version1.5.0svn 
Target Version1.5.4Fixed in Version1.5.4.svn 
Summary0012157: Rotated PDFs clipped on export
DescriptionI set up a portrait page, imported a landscape shape PDF, rotated it 90 degrees and after export to PDF, the imported PDF had been clipped. See Document-1.pdf.

(setting original page to landscape and then importing PDF was OK)

Edit:
Original issue not reproducible in 1.5.2svn but there are some strange warnings. See thread below
Steps To ReproduceFile->New A4 (margins at 14.111mm)
File->Import->Get Vector File (Assessment.pdf attached)
PP, set Base point to centre, rotate 90 degrees
PP, Link Width and Height and shrunk to height 184.903mm

Centred approximately on page
Export to PDF, pdf 1.4, ignore errors

See attached Document-1.pdf
Additional InformationThe pdf was made by importing a xls file into OOo, saving as an ods (editing to remove personal information) then using OOo export to PDF facility (Assessment.pdf)
Tags#pending
PatchNo

Relationships

child of 0012524 acknowledged Metabug: Preflight Verifier (1.5.0.svn) 

Activities

owencook

2014-03-23 06:21

reporter  

data.tar.gz (659,239 bytes)

owencook

2014-03-23 06:27

reporter   ~0031535

Meant to add this was with Rev 18933

Kunda

2016-04-13 13:12

manager   ~0040115

I can't reproduce on MacOSX 10.10.5 1.5.2svn r21187 Qt5.6
What I do see is that preflight verifier (see attached) is finding missing objects but if I continue and export to PDF it imports without clipping the chart.

Kunda

2016-04-13 13:12

manager  

Kunda

2016-04-13 13:13

manager   ~0040116

Owen, can you still reproduce ?

Laser

2016-04-13 13:51

reporter   ~0040122

Cannot reproduce with 1.5.2 r21141


Just one strange error^^ (see attached)

Laser

2016-04-13 13:51

reporter  

Kunda

2016-04-13 13:54

manager   ~0040123

Thanks Laser. Yea, that is strange, I don't get that issue AFAICT

owencook

2016-04-22 03:46

reporter   ~0040378

Well with Rev 21193 I cannot reprodce it so like all "bugs" they seem to disappear as code is updated.

Maybe best to close this one.

Kunda

2016-04-22 03:51

manager   ~0040379

@Owencook original bug is not reproducible but there are still some odd behaviors that are demonstrated in the ticket.

jghali

2018-02-01 12:58

administrator   ~0044897

Closing as I cannot reproduce the issue anymore

Issue History

Date Modified Username Field Change
2014-03-23 06:21 owencook New Issue
2014-03-23 06:21 owencook File Added: data.tar.gz
2014-03-23 06:27 owencook Note Added: 0031535
2016-04-13 13:12 Kunda Note Added: 0040115
2016-04-13 13:12 Kunda File Added: preflight-missing-objects.png
2016-04-13 13:13 Kunda Note Added: 0040116
2016-04-13 13:40 Kunda Tag Attached: #tobeclosed
2016-04-13 13:51 Laser Note Added: 0040122
2016-04-13 13:51 Laser File Added: Bildschirmfoto_2016-04-13_15-50-01.png
2016-04-13 13:54 Kunda Note Added: 0040123
2016-04-13 13:55 Kunda Patch => No
2016-04-13 13:55 Kunda Target Version => 1.5.3
2016-04-13 13:55 Kunda Summary Rotated PDFs clipped => Rotated PDFs clipped (strange warnings)
2016-04-13 13:55 Kunda Description Updated View Revisions
2016-04-13 16:24 Kunda Summary Rotated PDFs clipped (strange warnings) => Rotated PDFs clipped (strange warnings) + produce odd warnings in Preflight and Layers
2016-04-22 03:46 owencook Note Added: 0040378
2016-04-22 03:51 Kunda Note Added: 0040379
2016-05-14 04:38 Kunda Status new => confirmed
2016-05-14 12:46 Kunda Tag Detached: #tobeclosed
2016-05-14 12:46 Kunda Tag Attached: #pending
2016-05-14 12:53 Kunda Relationship added child of 0012524
2016-12-08 22:04 Kunda Target Version 1.5.3 => 1.5.4
2018-02-01 12:57 jghali Summary Rotated PDFs clipped (strange warnings) + produce odd warnings in Preflight and Layers => Rotated PDFs clipped on export
2018-02-01 12:58 jghali Assigned To => jghali
2018-02-01 12:58 jghali Status confirmed => resolved
2018-02-01 12:58 jghali Resolution open => fixed
2018-02-01 12:58 jghali Fixed in Version => 1.5.4.svn
2018-02-01 12:58 jghali Note Added: 0044897
2019-06-04 20:56 cbradney Status resolved => closed