View Issue Details

IDProjectCategoryView StatusLast Update
0012204ScribusQt5 Portpublic2016-03-24 18:37
ReporterPeterBenedek Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86OSLinux Mint OS Version16 (32bit)
Product Version1.5.0svn 
Target Version1.5.2Fixed in Version1.5.2.svn 
Summary0012204: Opening/Closing Properties palette tabs moves the view to the first document (2+ document Tabs)
DescriptionK├Ârnyezet: Linux Mint 16 "Petra"
Verzi├│: Scribus 1.5.0 (https://launchpad.net/~scribus/+archive/ppa)
Nyelv: HU

At least two open document:
The "Snap to Items" does not work in one document!
Incorrectly set when you close the active document properties tab!

Link this video: https://www.dropbox.com/s/y7cq8bs7yrwnrxc/example.avi
Steps To Reproduce0) Make sure "Use Tabs for Document" is enabled (File > Preferences > User Interface)
1) Create a new document
2) Insert a red Shape
3) Create another document (you have 2 tabs now)
4) Insert a blue Shape
5) From Windows > Properties open close one of the tabs (example: X,Y,Z or Line)

The view is moved to the first document.
Additional InformationTested with 1.5.0.svn (19335) on openSUSE
Tagsupstream
PatchNo

Relationships

related to 0013468 assignedcbradney If chained frames touching each other, in case marker arrow shown in wrong place. 
has duplicate 0013104 closed random switching between open documents 
related to 0013804 closedjghali Change in tabs triggered by operation 

Activities

PeterBenedek

2014-04-08 16:16

developer   ~0031654

Pardon: Not Documentum! Correctly Document! :-)

jghali

2014-04-08 22:10

administrator   ~0031659

Last edited: 2014-04-08 22:10

View 2 revisions

I have cloned this issue to 0012208 in order to isolate the bug related to display of snapping properties in "Page" menu. Grid, guides and item snapping are doc specific so the state of those properties must be updated when switching between docs... which is not the case currently.

jghali

2014-04-08 22:14

administrator   ~0031660

I fixed 0012208. I cannot reproduce the issue shown in the video on Windows.

FirasH

2014-07-03 17:57

developer   ~0032447

Reproduced the issue of the Properties palette when 2 or more documents are opened.

Dawoodalbadi

2015-10-29 05:15

reporter   ~0037080

I apply all step so many times and I can not reproduce the bug

Kunda

2015-10-29 12:20

manager   ~0037097

Dawood? What are you trying to reproduce because there were 2 issues reported originally in this bug.
1) 2nd open tab opens without being invoked by some operation done on 1st open tab.
2) 'Snap to Item' not functioning correctly on 2nd open tab

Also what OS, OS version, Scribus version and revision are you testing ?

jghali

2015-10-29 13:16

administrator   ~0037101

Unable to reproduce both issues on Windows.

Kunda

2015-10-29 16:00

manager   ~0037104

Peter, can you still reproduce ?

Kunda

2015-10-29 16:05

manager   ~0037105

Can't reproduce on OSX latest HEAD

PeterBenedek

2015-10-30 10:59

developer   ~0037119

Can reroduce Linux Mint 17.2, Qt 5.4.2.

https://www.dropbox.com/s/cvh4ed4xcn4w1ps/example_2.avi?dl=0

jfl

2015-10-30 19:15

reporter   ~0037124

I cannot reproduce either issues with:

Scribus Version 1.5.1.svn 09 October 2015
Build ID: C-C-T-F-C1.14.2-64bit

on openSUSE Tumbleweed with Qt version 5.5.1.

PeterBenedek

2015-10-30 19:24

developer  

Dokumentum-1.sla (14,255 bytes)

PeterBenedek

2015-10-30 19:24

developer  

Dokumentum-2.sla (14,295 bytes)

Kunda

2015-11-05 01:56

manager   ~0037230

waiting for Peter to test on a Qt5.5=>
bumped to 1.5.2 in the meantime

PeterBenedek

2015-11-12 08:43

developer   ~0037444

Tested: r20547, Qt5.6.0 (beta)
It does not work well!

AlmaTlust

2016-01-11 15:05

reporter   ~0038068

Last edited: 2016-01-11 15:07

View 2 revisions

I can reproduce with both 1.5.0 and 1.5.1svn on Kubuntu Linux (actually 13104 is a duplicate). but Qt is still 5.4.2.

AlmaTlust

2016-01-14 08:44

reporter   ~0038149

Steps to reproduce (on Linux with QT 5.4.2):

1) open two documents
2) in the second document, select any object
3) in properties palette, click twice on any tab (either open-close the same tab or click on two different tabs, it doesn't matter).

Effect - first document gets moved to the foreground (and of course your desired action is delayed).

Important observation: The bug is only triggered when no tab is open. When there already are open tabs, everything works as expected.

Kunda

2016-03-19 12:59

manager   ~0039263

See also 0013804

jghali

2016-03-19 16:05

administrator   ~0039271

I think I found the cause of the issue. Please check with r21095.

Kunda

2016-03-19 19:51

manager   ~0039277

Peter & Alma, please retest. Thanks!

AlmaTlust

2016-03-21 07:36

reporter   ~0039300

Works now for me. Thanks!

AlmaTlust

2016-03-21 07:37

reporter   ~0039301

Version r21099, sorry.

PeterBenedek

2016-03-21 07:49

developer   ~0039302

Last edited: 2016-03-21 07:50

View 2 revisions

I test soon...

PeterBenedek

2016-03-24 18:25

developer   ~0039392

Tested.
Works well!

Thanks!!!

Kunda

2016-03-24 18:37

manager   ~0039393

Closing, thanks to everyone involved.

Issue History

Date Modified Username Field Change
2014-04-08 16:07 PeterBenedek New Issue
2014-04-08 16:16 PeterBenedek Note Added: 0031654
2014-04-08 22:00 jghali Issue cloned: 0012208
2014-04-08 22:10 jghali Note Added: 0031659
2014-04-08 22:10 jghali Note Edited: 0031659 View Revisions
2014-04-08 22:14 jghali Note Added: 0031660
2014-07-03 17:57 FirasH Note Added: 0032447
2014-07-03 18:26 Kunda Status new => confirmed
2014-07-03 18:26 Kunda Target Version => 1.5.1
2014-07-11 02:54 FirasH Summary Two_errors_in_one => Opening/Closing Properties palette tabs moves the view to the first document (2+ document Tabs)
2014-07-11 02:54 FirasH Steps to Reproduce Updated View Revisions
2014-07-11 02:54 FirasH Additional Information Updated View Revisions
2014-07-30 22:26 Kunda Category Canvas => Properties Palette
2015-10-29 05:15 Dawoodalbadi Note Added: 0037080
2015-10-29 12:20 Kunda Note Added: 0037097
2015-10-29 13:16 jghali Note Added: 0037101
2015-10-29 16:00 Kunda Note Added: 0037104
2015-10-29 16:05 Kunda Note Added: 0037105
2015-10-30 10:59 PeterBenedek Note Added: 0037119
2015-10-30 19:15 jfl Note Added: 0037124
2015-10-30 19:24 PeterBenedek File Added: Dokumentum-1.sla
2015-10-30 19:24 PeterBenedek File Added: Dokumentum-2.sla
2015-11-05 01:56 Kunda Patch => No
2015-11-05 01:56 Kunda Note Added: 0037230
2015-11-05 01:56 Kunda Category Properties Palette => Qt5 Port
2015-11-05 01:56 Kunda Target Version 1.5.1 => 1.5.2
2015-11-05 01:58 Kunda Relationship added related to 0013468
2015-11-10 22:02 Kunda Tag Attached: upstream
2015-11-12 08:43 PeterBenedek Note Added: 0037444
2015-11-23 13:33 JLuc Status confirmed => feedback
2016-01-11 15:05 AlmaTlust Note Added: 0038068
2016-01-11 15:07 AlmaTlust Note Edited: 0038068 View Revisions
2016-01-12 06:21 Kunda Relationship added has duplicate 0013104
2016-01-14 08:44 AlmaTlust Note Added: 0038149
2016-01-23 17:15 cbradney Target Version 1.5.2 => 1.5.4.svn
2016-03-19 12:59 Kunda Relationship added related to 0013804
2016-03-19 12:59 Kunda Note Added: 0039263
2016-03-19 16:05 jghali Note Added: 0039271
2016-03-19 16:05 jghali Status feedback => resolved
2016-03-19 16:05 jghali Fixed in Version => 1.5.2.svn
2016-03-19 16:05 jghali Resolution open => fixed
2016-03-19 16:05 jghali Assigned To => jghali
2016-03-19 19:51 Kunda Note Added: 0039277
2016-03-21 07:36 AlmaTlust Note Added: 0039300
2016-03-21 07:37 AlmaTlust Note Added: 0039301
2016-03-21 07:49 PeterBenedek Note Added: 0039302
2016-03-21 07:50 PeterBenedek Note Edited: 0039302 View Revisions
2016-03-21 23:16 Kunda Target Version 1.5.4.svn => 1.5.2
2016-03-24 18:25 PeterBenedek Note Added: 0039392
2016-03-24 18:37 Kunda Note Added: 0039393
2016-03-24 18:37 Kunda Status resolved => closed